Skip to content

Commit

Permalink
dev-gap/io: backport fix for assertion failure
Browse files Browse the repository at this point in the history
Signed-off-by: Michael Orlitzky <[email protected]>
  • Loading branch information
orlitzky committed Feb 1, 2024
1 parent 1065046 commit b485329
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
35 changes: 35 additions & 0 deletions dev-gap/io/files/io-4.8.2-fix-failed-assertion.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From edfbed91b1c98abbed7c57463b88a1e8e134f2c3 Mon Sep 17 00:00:00 2001
From: Chris Jefferson <[email protected]>
Date: Wed, 24 Jan 2024 11:18:09 +0800
Subject: [PATCH] Check arguments to IO_gmtime and IO_localtime

---
src/io.c | 8 ++++++++
1 file changed, 8 insertions(+)

diff --git a/src/io.c b/src/io.c
index 731880e..2a1536e 100644
--- a/src/io.c
+++ b/src/io.c
@@ -1777,6 +1777,10 @@ static Obj FuncIO_gmtime(Obj self, Obj time)
Obj tmp;
time_t t;
struct tm * s;
+ if (!IS_INT(time)) {
+ SyClearErrorNo();
+ return Fail;
+ }
if (!IS_INTOBJ(time)) {
tmp = QuoInt(time, INTOBJ_INT(256));
if (!IS_INTOBJ(tmp))
@@ -1808,6 +1812,10 @@ static Obj FuncIO_localtime(Obj self, Obj time)
Obj tmp;
time_t t;
struct tm * s;
+ if (!IS_INT(time)) {
+ SyClearErrorNo();
+ return Fail;
+ }
if (!IS_INTOBJ(time)) {
tmp = QuoInt(time, INTOBJ_INT(256));
if (!IS_INTOBJ(tmp))
3 changes: 3 additions & 0 deletions dev-gap/io/io-4.8.2.ebuild → dev-gap/io/io-4.8.2-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -16,6 +16,9 @@ IUSE="examples"
DEPEND="sci-mathematics/gap:="
RDEPEND="${DEPEND}"

# backport, merged upstream already
PATCHES=( "${FILESDIR}/${P}-fix-failed-assertion.patch" )

gap-pkg_enable_tests

src_prepare() {
Expand Down

0 comments on commit b485329

Please sign in to comment.