Skip to content

Commit

Permalink
dev-db/mongodb: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
ultrabug committed Mar 9, 2016
1 parent 17c2972 commit b492a1a
Show file tree
Hide file tree
Showing 2 changed files with 185 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/mongodb/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST mongodb-src-r3.0.10.tar.gz 29336823 SHA256 7dbecb1e32c35dca1b0e00cd55ba08bf
DIST mongodb-src-r3.0.8.tar.gz 26245612 SHA256 3574f2f577e212ff1876485e1502c91f70f996fbbcc5a4657fe440ac76bd97a5 SHA512 3b8578ed2a6196cda0867d219214e1dc9fe95ecaa8320cdee3766c9a8a78e9cf66013769a3fbbf03ccf9a35d97e02a1eaa5fe8fc7429a0d76dd78486db7520ac WHIRLPOOL ded0b84b940c66b8a7ef6b363f179a4b2c1ddc23a3077b9cadb01f76c2a90956f0a720e713d4806db6132ac96b1026b82c2bf966ec3869af095e12590ea04d0e
DIST mongodb-src-r3.0.9.tar.gz 26249669 SHA256 5b6f189458739a327a2ad4a5ecab4f733c6a6751ccb067ec8879a0f98f2b97c3 SHA512 4ebcd89394ea0ccbd84adde1a6ce1776d86873bea13520c31bf3a783a922598cadd9ce1c11998f028e5e1affe6cb6639d1a4ff9c0e5771ff88bed873ddf7dc97 WHIRLPOOL a7d6cb51ee62717bcc2e612ae8e72ea43be7c9867c0de3fa2afc1d5c731bc3b1ca04ac70a351feaba71c27e00cf6cbf9b9997c4276362f98a725350aff37b750
DIST mongodb-src-r3.2.3.tar.gz 29607224 SHA256 82030ada190095b5d95c0b59e9cf74efe9db602b49d2b8857b06f2683a5227fa SHA512 43b652da8fb461c36be1566965985aed036d53a8f4ed2a5f4a67e08571697c4030eb682a2a14ebc41991757d7083a268c5161b536d20dc1b3de13dac8df1da53 WHIRLPOOL 2e262616f0f317185330c8386ea31f81af9d7713dd02e70a4292d2ace17b22fadaead8666840679aa3eedccb624a48817cf68d1d29af3840e4af10aa77d434a5
DIST mongodb-src-r3.2.4.tar.gz 29647777 SHA256 b60743cc641de975c38e6e69ebbef60059ee9fe176cdd98bfab8d5c844dab42c SHA512 fb7b3ea3c704cde023ec540f4a142d3beba217f33e8c30da04318e365c5d52cbfa00b98824c53485b5f8918a83095c9b26db43861d80029e8e924e66dd8ea694 WHIRLPOOL ffd0ac839f3279776602ccf829ac629557f43ea50a5640bebc5532bc77072035181cf5d456ec467dca9d1a1f26adb2f1ab1de06968ca501c7b1dfe26fdc9a4ff
184 changes: 184 additions & 0 deletions dev-db/mongodb/mongodb-3.2.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,184 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
SCONS_MIN_VERSION="2.3.0"
CHECKREQS_DISK_BUILD="2400M"
CHECKREQS_DISK_USR="512M"
CHECKREQS_MEMORY="1024M"

inherit eutils flag-o-matic multilib pax-utils scons-utils systemd toolchain-funcs user versionator check-reqs

MY_P=${PN}-src-r${PV/_rc/-rc}

DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
HOMEPAGE="http://www.mongodb.org"
SRC_URI="https://fastdl.mongodb.org/src/${MY_P}.tar.gz"

LICENSE="AGPL-3 Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug kerberos libressl mms-agent ssl test +tools"

RDEPEND=">=app-arch/snappy-1.1.2
|| ( =dev-cpp/yaml-cpp-0.5.1 >dev-cpp/yaml-cpp-0.5.2 )
>=dev-libs/boost-1.57[threads(+)]
>=dev-libs/libpcre-8.37[cxx]
dev-libs/snowball-stemmer
net-libs/libpcap
>=sys-libs/zlib-1.2.8
mms-agent? ( app-admin/mms-agent )
ssl? (
!libressl? ( >=dev-libs/openssl-1.0.1g:0= )
libressl? ( dev-libs/libressl:= )
)"
DEPEND="${RDEPEND}
>=sys-devel/gcc-4.8.2:*
sys-libs/ncurses
sys-libs/readline
debug? ( dev-util/valgrind )
kerberos? ( dev-libs/cyrus-sasl[kerberos] )
test? (
dev-python/pymongo
dev-python/pyyaml
)"
PDEPEND="tools? ( >=app-admin/mongo-tools-${PV} )"

S=${WORKDIR}/${MY_P}

pkg_pretend() {
if [[ ${REPLACING_VERSIONS} < 3.0 ]]; then
ewarn "To upgrade an existing MongoDB deployment to 3.2, you must be"
ewarn "running a 3.0-series release. Please update to the latest 3.0"
ewarn "release before continuing if wish to keep your data."
fi
}

pkg_setup() {
enewgroup mongodb
enewuser mongodb -1 -1 /var/lib/${PN} mongodb

# Maintainer notes
#
# --use-system-tcmalloc is strongly NOT recommended:
# https://www.mongodb.org/about/contributors/tutorial/build-mongodb-from-source/

scons_opts=(
CC="$(tc-getCC)"
CXX="$(tc-getCXX)"

--disable-warnings-as-errors
--use-system-boost
--use-system-pcre
--use-system-snappy
--use-system-stemmer
--use-system-yaml
--use-system-zlib
)

# wiredtiger not supported on 32bit platforms #572166
use x86 && scons_opts+=( --wiredtiger=off )

if use debug; then
scons_opts+=( --dbg=on )
fi

if use prefix; then
scons_opts+=(
--cpppath="${EPREFIX}/usr/include"
--libpath="${EPREFIX}/usr/$(get_libdir)"
)
fi

if use kerberos; then
scons_opts+=( --use-sasl-client )
fi

if use ssl; then
scons_opts+=( --ssl )
fi
}

src_prepare() {
epatch "${FILESDIR}/${PN}-3.2.0-fix-scons.patch"
epatch_user
}

src_compile() {
# respect mongoDB upstream's basic recommendations
# see bug #536688 and #526114
if ! use debug; then
filter-flags '-m*'
filter-flags '-O?'
fi
escons "${scons_opts[@]}" core tools
}

src_install() {
escons "${scons_opts[@]}" --nostrip install --prefix="${ED}"/usr

for x in /var/{lib,log}/${PN}; do
keepdir "${x}"
fowners mongodb:mongodb "${x}"
done

doman debian/mongo*.1
dodoc README docs/building.md

newinitd "${FILESDIR}/${PN}.initd-r2" ${PN}
newconfd "${FILESDIR}/${PN}.confd-r2" ${PN}
newinitd "${FILESDIR}/${PN/db/s}.initd-r2" ${PN/db/s}
newconfd "${FILESDIR}/${PN/db/s}.confd-r2" ${PN/db/s}

insinto /etc
newins "${FILESDIR}/${PN}.conf-r3" ${PN}.conf
newins "${FILESDIR}/${PN/db/s}.conf-r2" ${PN/db/s}.conf

systemd_dounit "${FILESDIR}/${PN}.service"

insinto /etc/logrotate.d/
newins "${FILESDIR}/${PN}.logrotate" ${PN}

# see bug #526114
pax-mark emr "${ED}"/usr/bin/{mongo,mongod,mongos}
}

pkg_preinst() {
# wrt bug #461466
if [[ "$(get_libdir)" == "lib64" ]]; then
rmdir "${ED}"/usr/lib/ &>/dev/null
fi
}

src_test() {
# this one test fails
rm jstests/core/repl_write_threads_start_param.js

./buildscripts/resmoke.py --dbpathPrefix=test --suites core || die "Tests failed"
}

pkg_postinst() {
if [[ ${REPLACING_VERSIONS} < 3.0 ]]; then
ewarn "!! IMPORTANT !!"
ewarn " "
ewarn "${PN} configuration files have changed !"
ewarn " "
ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
ewarn " "
ewarn "Make sure you also follow the upgrading process :"
ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
ewarn " "
ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
fi

ewarn "Make sure to read the release notes and follow the upgrade process:"
ewarn " https://docs.mongodb.org/manual/release-notes/3.2/"
ewarn " https://docs.mongodb.org/master/release-notes/3.2-upgrade/"
ewarn
ewarn " Starting in 3.2, MongoDB uses the WiredTiger as the default storage engine."
}

0 comments on commit b492a1a

Please sign in to comment.