Skip to content

Commit

Permalink
dev-perl/Emacs-PDE: Bump to version 0.2.17
Browse files Browse the repository at this point in the history
- EAPI7
- Fix LICENSE
- Remove empty/used variable assignments
- Push myconf closer to src_configure as a guard against variables
  being augmented between ebuild sourcing and function execution

Package-Manager: Portage-2.3.103, Repoman-2.3.22
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Aug 7, 2020
1 parent bfc7f1f commit b4d57be
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
46 changes: 46 additions & 0 deletions dev-perl/Emacs-PDE/Emacs-PDE-0.2.17.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIST_AUTHOR=YEWENBIN
DIST_VERSION="v${PV}"
inherit perl-module elisp-common

DESCRIPTION="Perl Develop Environment in Emacs"
# Some elisp files are GPL-2+
# Some templates are FDL-1.1+
LICENSE="|| ( Artistic GPL-1+ ) GPL-2+ FDL-1.1+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"

RDEPEND=">=app-editors/emacs-23.1:*"
DEPEND="dev-perl/Module-Build"
BDEPEND="${RDEPEND}
>=dev-perl/Module-Build-0.420.0
"
src_configure() {
myconf="--elispdir=${D}${SITELISP}/pde"
perl-module_src_configure
}
src_test() {
local MODULES=(
"Emacs::PDE ${PV}"
"Emacs::PDE::Util"
)
local failed=()
for dep in "${MODULES[@]}"; do
ebegin "Compile testing ${dep}"
perl -Mblib="${S}" -M"${dep} ()" -e1
eend $? || failed+=( "$dep" )
done
if [[ ${failed[@]} ]]; then
echo
eerror "One or more modules failed compile:";
for dep in "${failed[@]}"; do
eerror " ${dep}"
done
die "Failing due to module compilation errors";
fi
perl-module_src_test
}
1 change: 1 addition & 0 deletions dev-perl/Emacs-PDE/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Emacs-PDE-0.2.16.tar.gz 619372 BLAKE2B 7d9eb5a7e3c61424b58bab4186efbd4426ac6c94a2043ade3a5de2da060e5eca2c2fc8ab20d5b3bcd3458036bdd8db861aef1ef963e0276e1c759c151843f362 SHA512 ab104070c820a618b0ce05a2d658cca56ad9c0d537e98697a98262c4135486cba2284ee597210dfe8c30348a0fadb9f76455453e17a86a0123618ce076b5565b
DIST Emacs-PDE-v0.2.17.tar.gz 664587 BLAKE2B 3b80a5643f71801e9117fd266c28acebc3dddbbdb07eb50d0b123afc1e54134090ffb1c04c4421938e702969d79b9ee6f8948e5dbefeeefc21f822e6a5c6ec95 SHA512 66c6044f41d81689d66d6c6b478291323790b569f9611cd6847d30fecdbee4447e5bea0efd816f243e6323e8872934e5cc15399e80cf29568edc625f87bf109f

0 comments on commit b4d57be

Please sign in to comment.