Skip to content

Commit

Permalink
dev-util/cpptest: Support USE=-static-libs
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/724290
Signed-off-by: Sebastian Pipping <[email protected]>
Package-Manager: Portage-2.3.99, Repoman-2.3.22
  • Loading branch information
hartwork committed May 20, 2020
1 parent bf2139a commit b4e5320
Showing 1 changed file with 27 additions and 0 deletions.
27 changes: 27 additions & 0 deletions dev-util/cpptest/cpptest-2.0.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Simple but powerful unit testing framework for C++"
HOMEPAGE="https://github.com/cpptest/cpptest"
SRC_URI="https://github.com/cpptest/cpptest/releases/download/${PV}/${P}.tar.bz2"

LICENSE="LGPL-2.1"
SLOT="1" # for soversion 1.x.x
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE="doc static-libs"

DEPEND="doc? ( app-doc/doxygen )"
RDEPEND="!dev-util/cpptest:0"

DOCS=( AUTHORS BUGS NEWS README )

src_configure() {
econf $(use_enable doc) $(use_enable static-libs static)
}

src_install() {
default
find "${D}" -name '*.la' -delete || die
}

0 comments on commit b4e5320

Please sign in to comment.