Skip to content

Commit

Permalink
app-admin/awscli: Bump to 1.27.31
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 16, 2022
1 parent 4dd529a commit b503185
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/awscli/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -10,4 +10,5 @@ DIST aws-cli-1.27.25.gh.tar.gz 2319262 BLAKE2B 1207b7879a82c538be9d1ee3dc8a69f20
DIST aws-cli-1.27.26.gh.tar.gz 2319897 BLAKE2B 65307b3c63656b751ad3d96ca6ffdb2e9778cdb11cb35c730dc22dad83ee4b0e1cb37afc4d1de7b2c1cbbabd4622610fc2385e7dbc21cfa2c9833a36d693b1ff SHA512 508f8ae1abe037786c3ee35204f4c84fb06bb7bb8471d75217bf914cf7c9aea897cbecb364554f8b39c75001769c894ede7a1b06dd761187aff468f19001708f
DIST aws-cli-1.27.27.gh.tar.gz 2320454 BLAKE2B 5ac7c2b872d23173dd3c1d0c586389b558c43de4bd0c1e0e5e45fee574d3d952aafb5591165fdd9eb2d14435df1342b27526dbd7ec1b7d63c1291e2d4d14bf80 SHA512 f5b9cf61b5045775142ae9868b3fd3193d82b09c4b0d52f05dadd173cc8dbc97699a2df458b17a97a5bc4743e14252fd9e7b6583fc9e49d8f26b96eb2c5d5d08
DIST aws-cli-1.27.29.gh.tar.gz 2325759 BLAKE2B 693131da782ce248a00560617d3d1cd57e1dcac20ba8a6a560b5a1c06c7f6b18576efd4e0a2151d538e28b3f59593ded609e8fea3d29bce9f91bc270f888e23a SHA512 828a3fdda0b3156c1b09ed53b5c2c6486857bdd1e4e3d5cfd77e817bc6c1e53e1ff3f7ddf83c55e8ca93b2944f37333244adffa0f3b9416b1c4197db9b364dde
DIST aws-cli-1.27.31.gh.tar.gz 2327529 BLAKE2B 5c274358df6ed3081e945f21aac184fb774cc4b5d621954f4c4b88996252c3edb0b9c76d6aaab1f5273f0c2db1d19a7d5a46f3c1915190e7d5c141e9cfcf908d SHA512 37b295265d32e8ca73f3b16c4225027df8b735c39a930ad64db9590737da0e9407560fb82514417a0f7b42692fec27c8b949f91c973e719199c9767ff613559d
DIST aws-cli-1.27.8.gh.tar.gz 2301766 BLAKE2B 1873d92b8d2f6d3f29a65b4177927a1a14034da71dbc95ff6abf3f49df6cf3ee192412eeea15be14c8cf9fca0a5603f2c76b80b280f4feb95e661055abcd8b60 SHA512 e53828cac1b3e10e2ddd45312d71cdb748216dbc37c3e9833e7a1320b236c3bef6a13204a38b946d9182430f169fca1ddc77d3d06c1c2c6e05978dc61f675168
80 changes: 80 additions & 0 deletions app-admin/awscli/awscli-1.27.31.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )

inherit bash-completion-r1 distutils-r1 multiprocessing

MY_P=aws-cli-${PV}
DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="
https://github.com/aws/aws-cli/
https://pypi.org/project/awscli/
"
SRC_URI="
https://github.com/aws/aws-cli/archive/${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
"
S=${WORKDIR}/${MY_P}

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"

# botocore is x.(y+2).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
!app-admin/awscli-bin
"
BDEPEND="
test? (
dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

src_prepare() {
# do not rely on bundled deps in botocore (sic!)
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die
# strip overzealous upper bounds on requirements
sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
distutils-r1_src_prepare
}

python_test() {
local EPYTEST_DESELECT=(
# TODO
tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
)

# integration tests require AWS credentials and Internet access
epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
}

python_install_all() {
newbashcomp bin/aws_bash_completer aws

insinto /usr/share/zsh/site-functions
newins bin/aws_zsh_completer.sh _aws

distutils-r1_python_install_all

rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
}

0 comments on commit b503185

Please sign in to comment.