forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
openstack p2, newton is done, will add heat later
- Loading branch information
1 parent
9922308
commit b54a183
Showing
103 changed files
with
2,887 additions
and
336 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,142 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit distutils-r1 git-r3 user | ||
|
||
DESCRIPTION="Services for discovering, registering, and retrieving VM images" | ||
HOMEPAGE="https://launchpad.net/glance" | ||
EGIT_REPO_URI="https://github.com/openstack/glance.git" | ||
EGIT_BRANCH="stable/newton" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="" | ||
IUSE="doc mysql postgres +sqlite +swift" | ||
REQUIRED_USE="|| ( mysql postgres sqlite )" | ||
|
||
CDEPEND=">=dev-python/pbr-1.6.0[${PYTHON_USEDEP}]" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
${CDEPEND}" | ||
|
||
#note to self, wsgiref is a python builtin, no need to package it | ||
#>=dev-python/wsgiref-0.1.2[${PYTHON_USEDEP}] | ||
|
||
RDEPEND=" | ||
${CDEPEND} | ||
sqlite? ( | ||
>=dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}] | ||
<dev-python/sqlalchemy-1.1.0[sqlite,${PYTHON_USEDEP}] | ||
) | ||
mysql? ( | ||
>=dev-python/pymysql-0.6.2[${PYTHON_USEDEP}] | ||
!~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}] | ||
<dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}] | ||
) | ||
postgres? ( | ||
>=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}] | ||
<dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}] | ||
) | ||
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}] | ||
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}] | ||
!~dev-python/routes-2.0[${PYTHON_USEDEP}] | ||
!~dev-python/routes-2.1[$(python_gen_usedep 'python2_7')] | ||
!~dev-python/routes-2.3[${PYTHON_USEDEP}] | ||
>=dev-python/webob-1.2.3[${PYTHON_USEDEP}] | ||
>=dev-python/sqlalchemy-migrate-0.9.6[${PYTHON_USEDEP}] | ||
>=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}] | ||
>=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-context-2.9.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-service-1.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}] | ||
>=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}] | ||
>=dev-python/futurist-0.11.0[${PYTHON_USEDEP}] | ||
!~dev-python/futurist-0.15.0[${PYTHON_USEDEP}] | ||
>=dev-python/taskflow-1.26.0[${PYTHON_USEDEP}] | ||
>=dev-python/keystoneauth-2.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/keystonemiddleware-4.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/keystonemiddleware-4.1.0[${PYTHON_USEDEP}] | ||
!~dev-python/keystonemiddleware-4.5.0[${PYTHON_USEDEP}] | ||
>=dev-python/WSME-0.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/prettytable-0.7.0[${PYTHON_USEDEP}] | ||
<dev-python/prettytable-0.8.0[${PYTHON_USEDEP}] | ||
dev-python/paste[${PYTHON_USEDEP}] | ||
>=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}] | ||
<dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/python-keystoneclient-2.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-db-4.10.0[${PYTHON_USEDEP}] | ||
!~dev-python/oslo-db-4.13.1[${PYTHON_USEDEP}] | ||
!~dev-python/oslo-db-4.13.2[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-messaging-5.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-middleware-3.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-policy-1.9.0[${PYTHON_USEDEP}] | ||
>=dev-python/retrying-1.2.3[${PYTHON_USEDEP}] | ||
!~dev-python/retrying-1.3.0[${PYTHON_USEDEP}] | ||
>=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/glance_store-0.18.0[${PYTHON_USEDEP}] | ||
>=dev-python/semantic_version-2.3.1[${PYTHON_USEDEP}] | ||
>=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/cryptography-1.0[${PYTHON_USEDEP}] | ||
!~dev-python/cryptography-1.3.0[${PYTHON_USEDEP}] | ||
>=dev-python/cursive-0.1.1[${PYTHON_USEDEP}] | ||
>=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}] | ||
>=dev-python/monotonic-0.6[${PYTHON_USEDEP}] | ||
" | ||
|
||
#PATCHES=( | ||
#) | ||
|
||
pkg_setup() { | ||
enewgroup glance | ||
enewuser glance -1 -1 /var/lib/glance glance | ||
} | ||
|
||
python_prepare_all() { | ||
sed -i '/xattr/d' test-requirements.txt || die | ||
sed -i '/pysendfile/d' test-requirements.txt || die | ||
sed -i '/^hacking/d' test-requirements.txt || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_compile_all() { | ||
use doc && "${PYTHON}" setup.py build_sphinx | ||
} | ||
|
||
python_install() { | ||
distutils-r1_python_install | ||
|
||
for svc in api glare registry scrubber; do | ||
newinitd "${FILESDIR}/glance.initd" glance-${svc} | ||
done | ||
|
||
diropts -m 0750 -o glance -g glance | ||
dodir /var/log/glance /var/lib/glance/images /var/lib/glance/scrubber | ||
keepdir /etc/glance | ||
keepdir /var/log/glance | ||
keepdir /var/lib/glance/images | ||
keepdir /var/lib/glance/scrubber | ||
|
||
insinto /etc/glance | ||
insopts -m 0640 -o glance -g glance | ||
doins -r etc/*.ini etc/*.conf etc/*.sample etc/*.json etc/meta* | ||
} | ||
|
||
python_install_all() { | ||
use doc && local HTML_DOCS=( doc/build/html/. ) | ||
distutils-r1_python_install_all | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST cliff-2.0.0.tar.gz 51837 SHA256 6e219dc3ed80a23e3dc5c88b741f3997b8450581c1d2572bde14b2dfa556d782 SHA512 6bc53c4958f21e4b67a71a97a7413bb6760065987e92c922b5de6b748deb55b5bd711c1de962573c326d0c451c755c5fad2cc0458b2d4eb4ec67bcaa750d20bc WHIRLPOOL 132ec260e55bec0dba40433abf580e5f11f265152dd8497cc42b42c5cb576284a6c0c7f867fd0ddbab2205ac27c1108e7fbd13ccfdae9ddba84cf17c2246d366 | ||
DIST cliff-2.2.0.tar.gz 57767 SHA256 a12a6bd3cf9085f0e0589c5019037ac4ee410413abbb76189fa62695f79f84fc SHA512 b6f1c55c676e040c0ca8996a0bbb33331c83d102c17cc62700014fec47f8135ba1c9185cbf10e60401799490b2f02b8471ca4d130d1ead978f6076bf29e36de0 WHIRLPOOL 3286a91d1c0af07e408244f3179a53f6a54529b611d63adc74b12c9ea851ca38e5f32cec0039f53e97848e64fa36e1b20bcb90108d6d55d286ce638e1955c798 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,58 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Command Line Interface Formulation Framework" | ||
HOMEPAGE="https://github.com/dreamhost/cliff" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="doc test" | ||
|
||
CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
${CDEPEND} | ||
test? ( | ||
dev-python/nose[${PYTHON_USEDEP}] | ||
>=dev-python/mock-2.0[${PYTHON_USEDEP}] | ||
>=dev-python/coverage-3.6[${PYTHON_USEDEP}] ) | ||
doc? ( | ||
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] | ||
!~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}] | ||
<dev-python/sphinx-1.3[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}] | ||
!~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}] ) | ||
" | ||
# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1 | ||
RDEPEND=" | ||
${CDEPEND} | ||
>=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}] | ||
>=dev-python/prettytable-0.7[${PYTHON_USEDEP}] | ||
<dev-python/prettytable-0.8[${PYTHON_USEDEP}] | ||
>=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9.0[${PYTHON_USEDEP}] | ||
>=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}] | ||
>=dev-python/unicodecsv-0.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}] | ||
" | ||
|
||
python_compile() { | ||
use doc && esetup.py build_sphinx | ||
} | ||
|
||
python_test() { | ||
nosetests ${PN}/tests || die "Tests fail with ${EPYTHON}" | ||
} | ||
|
||
python_install_all() { | ||
use doc && local HTML_DOCS=( doc/build/html/. ) | ||
distutils-r1_python_install_all | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST cursive-0.1.1.tar.gz 18522 SHA256 751745b868f6450d928749c9d08b0040bd13f82bcf7c4ed414a57da66b2bc104 SHA512 3a6ae804c010ae2b596eac8fbc3c9be6d7994ea8984513617f1eaa7c77c8335ce2c36419d8e6acadb305210d96d51ead8470a79e8425f2c00ef0dc9ead59929b WHIRLPOOL 8c5705780deb037fb61e9a511fecda55673fa069cda0d4e605c7387266a18bc6eefb3992910f44464268a86f6fd26580f381e8e96847eb04f1d51fef9deaacfe |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 python3_4 python3_5 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Cursive implements OpenStack-specific validation of digital signatures." | ||
HOMEPAGE="https://github.com/openstack/cursive" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="" | ||
|
||
CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
${CDEPEND}" | ||
RDEPEND=" | ||
${CDEPEND} | ||
>=dev-python/lxml-2.3[${PYTHON_USEDEP}] | ||
>=dev-python/cryptography-1.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}] | ||
>=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>Matthew Thode</name> | ||
</maintainer> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Openstack</name> | ||
</maintainer> | ||
<longdescription lang="en"> | ||
Cursive implements OpenStack-specific validation of digital signatures. | ||
</longdescription> | ||
<upstream> | ||
<remote-id type="pypi">cursive</remote-id> | ||
<remote-id type="github">openstack/cursive</remote-id> | ||
</upstream> | ||
</pkgmetadata> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST glance_store-0.13.1.tar.gz 127250 SHA256 e2f2051ff22abaa462fdb7fe8741312de8543bba7f6f65165b9c52343ccd35fc SHA512 1625849ed35d8fec6d730790485451fd740240a6fd076ad084cd0444b5b8bfadeab82164854a9bee194f6f3cabff7c30815d5fdcd800a7d982ed8c3224e6aaec WHIRLPOOL e16ad3aef7ca1ef15ead956fa7e459a4f6259b3c7ffb0086b11aa5fe2c4034011d306df09255cf6b94bf9474861546e483147c3823d804b661244455e463a217 | ||
DIST glance_store-0.18.0.tar.gz 126949 SHA256 56b8b33f5deb74c652bd82d781aa82459e14152a5ee5c74726f0f1545c2355a7 SHA512 f23505b0081d0bb9948a4a2550868ea9864c00604358264c826551caccb4e35cbdcfcaa1e0ed3d470fbe72250196e246b596cbb57db0e99cc49fba3e0c609e01 WHIRLPOOL a1f26bc06a19a6deb14b910813829a07726ec9408b71e4fbb854ea3a2815f872cd27dfd82ae4f84e1bf49fdf5b89ef079c8f17f24a883bbf5a2cacc218f0ce8f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 python3_4 python3_5 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="A library for glance" | ||
HOMEPAGE="https://github.com/openstack/glance_store" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
IUSE="+cinder" | ||
|
||
CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
${CDEPEND} | ||
" | ||
RDEPEND=" | ||
${CDEPEND} | ||
>=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}] | ||
>=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}] | ||
>=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}] | ||
virtual/python-enum34[${PYTHON_USEDEP}] | ||
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9.0[${PYTHON_USEDEP}] | ||
>=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}] | ||
<dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/python-keystoneclient-2.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/requests-2.10.0[${PYTHON_USEDEP}] | ||
cinder? ( >=dev-python/python-cinderclient-1.2.1[${PYTHON_USEDEP}] ) | ||
" | ||
|
||
python_prepare_all() { | ||
sed -i '/ordereddict/d' requirements.txt | ||
distutils-r1_python_prepare_all | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST microversion_parse-0.1.4.tar.gz 12795 SHA256 040558958b5a9db618b55c326c5cb15a59e21ae7a2754c7017ffc85015b2db7c SHA512 06d7063370cc55b6c41f2d9cae33caf5cce501694d4271d0ae586cb5a468cc2e6361f93906f18405a0f99a59f442cda1b56bd565069d6dbf2bbc409942ea189f WHIRLPOOL 22d6b34f674d7b04e20571607ecda50913b50c77b42d2216e790cde6c45d3edd33dfaccd8e535dc45d44baf51d3f1fdd7d89835629ffcbb820b860bbd1b81f47 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>Matthew Thode</name> | ||
</maintainer> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Openstack</name> | ||
</maintainer> | ||
<longdescription lang="en"> | ||
A simple parser for OpenStack microversion headers. | ||
</longdescription> | ||
<upstream> | ||
<remote-id type="pypi">microversion_parse</remote-id> | ||
<remote-id type="github">openstack/microversion-parse</remote-id> | ||
</upstream> | ||
</pkgmetadata> |
26 changes: 26 additions & 0 deletions
26
dev-python/microversion-parse/microversion-parse-0.1.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 python3_4 python3_5 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="A simple parser for OpenStack microversion headers" | ||
HOMEPAGE="https://github.com/openstack/microversion-parse" | ||
SRC_URI="mirror://pypi/${PN:0:1}/microversion_parse/microversion_parse-${PV}.tar.gz" | ||
S="${WORKDIR}/microversion_parse-${PV}" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="" | ||
|
||
CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
${CDEPEND}" | ||
RDEPEND=" | ||
${CDEPEND} | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST netifaces-0.10.4.tar.gz 22969 SHA256 9656a169cb83da34d732b0eb72b39373d48774aee009a3d1272b7ea2ce109cde SHA512 1b9b92b69e01e4dd9f9304d3812d78d58ec195a657cb47b2e629ccb1311de4a8cd9716825d7b94d4791f7c479c289638780f6f9afa8a6465fb555130da622b24 WHIRLPOOL 44cb33b6ca0c6cda059bf7e88ca5b4904d1e2d5bb7201f23d8e5b9c3bd337acc99dc47dec76016b6ceee7c5d8d72af03af96afb709ff9368a8dfff8683d4b7e2 | ||
DIST netifaces-0.10.5.tar.gz 24879 SHA256 59d8ad52dd3116fcb6635e175751b250dc783fb011adba539558bd764e5d628b SHA512 736bb985b444e78676dc10533a7597e750cadf41033196c4be49c4f33e91d46eba33a1f485e07e9f70aec2170c958564a6f54bbaa1ab193bfaca04b1fb07b3a1 WHIRLPOOL 7a0d63508dc2d2f80a4fbe4a92468696cb3335c9a47410a617de12f7c1f167a4bfc9d3a122dc666e5956b9b1422ed11f9e1839e929c85f0b0cc289eeccba4c35 | ||
DIST netifaces-0.8.tar.gz 15484 SHA256 53a711038db3d6e5cf7129d6f751185fd052f830f12f271fbfe17bd2671ab1ec SHA512 b3735c4f83d4ed1d52f59937187659f148205a721fd05ce5a10e9ec89ea3519971001b2985e24bb30fb112ee741310babd847f84d4c3fbb34989edc6a743f551 WHIRLPOOL 4f638d769a38a474f0a27642544e1b6e932643f224133024cbfdb44e9637700afc10675fccd61e52e5f6e8a121b25173895d9f173b428aefceded22a42af7ab6 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy{,3} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Portable network interface information" | ||
HOMEPAGE=" | ||
https://pypi.python.org/pypi/netifaces/ | ||
http://alastairs-place.net/netifaces/ | ||
https://bitbucket.org/al45tair/netifaces" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="" | ||
|
||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]" | ||
RDEPEND="" | ||
|
||
PATCHES=( "${FILESDIR}"/${PN}-0.10.4-remove-osx-fix.patch ) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST neutron-lib-0.0.2.tar.gz 49102 SHA256 2040a08937bece401a49fb4a867ccf5a910a8267edc26947ab0c523b4903ce7d SHA512 efe524b18835ee351abc9514aa2026ed543857f523f0cb7ab47e509e2e53246aa093daa0b28cbfcede27487ba8eff3c054531bfab7d43af70354c4063f34ac92 WHIRLPOOL 159294e363e588b9d2c3204d8b92b5e5df9923d8a08b70d28d0a4cdd20f9b6bd6b01301f557e97a99fcad6aac5a2724768d0898d997750c1c015f85df02db708 | ||
DIST neutron-lib-0.4.0.tar.gz 147871 SHA256 018550848e31e3eb20e5fb3d8173ae75cce46c6233fd020227fa9a49af593d6a SHA512 c76c17331d52dd3708be67da5b509b50580be5df7238162aa66a8b89a0ff36c08b03f2f2c1a66061f5a67dc010affa5d39616549d8ed3cc5e8df96292e6257d7 WHIRLPOOL 4949b04d3c60bb906b8912758f7229e22ae9595c3f4e335bb124687a255382452bc0e0e7bd6c7e68755a5a0b4e53498f858f4a3c86c0c1824bfebc6f77358c26 |
Oops, something went wrong.