Skip to content

Commit

Permalink
x11-plugins/wmmon+smp: EAPI7, improve ebuild
Browse files Browse the repository at this point in the history
  • Loading branch information
mm1ke authored and voyageur committed Aug 2, 2018
1 parent 58646bc commit b567e9b
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 4 deletions.
8 changes: 4 additions & 4 deletions x11-plugins/wmmon+smp/files/wmmon+smp-1.0-list.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
--- wmgeneral.orig/list.c 2016-01-04 13:28:36.583339716 +0100
+++ wmgeneral/list.c 2016-01-04 13:28:48.694343645 +0100
--- a/wmgeneral/list.c 2016-01-04 13:28:36.583339716 +0100
+++ b/wmgeneral/list.c 2016-01-04 13:28:48.694343645 +0100
@@ -38,7 +38,7 @@

/* Return a cons cell produced from (head . tail)
Expand Down Expand Up @@ -83,8 +83,8 @@ diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
{
while(list)
diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
--- wmgeneral.orig/list.h 2016-01-04 13:28:36.583339716 +0100
+++ wmgeneral/list.h 2016-01-04 13:28:39.471340654 +0100
--- a/wmgeneral/list.h 2016-01-04 13:28:36.583339716 +0100
+++ b/wmgeneral/list.h 2016-01-04 13:28:39.471340654 +0100
@@ -29,31 +29,25 @@
#ifndef __LIST_H_
#define __LIST_H_
Expand Down
42 changes: 42 additions & 0 deletions x11-plugins/wmmon+smp/wmmon+smp-1.0-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="Dockapp CPU monitor resembling Xosview, support for smp"
HOMEPAGE="http://www.ne.jp/asahi/linux/timecop/"
SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/wmmon+smp.tar.gz"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc64 ~x86"

RDEPEND="
x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm"
DEPEND="${RDEPEND}
x11-base/xorg-proto"

S="${WORKDIR}/wmmon.app/wmmon"

PATCHES=( "${FILESDIR}"/${P}-list.patch )

src_prepare() {
tc-export CC
# Respect LDFLAGS, see bug #335047
sed \
-e 's/cc -o/${CC} ${LDFLAGS} -o/' \
-e 's/cc -c/${CC} ${CFLAGS} -c/' \
-i Makefile || die

cd "${WORKDIR}"/wmmon.app || die
default
}

src_install () {
newbin wmmon wmmon+smp
dodoc ../README
}

0 comments on commit b567e9b

Please sign in to comment.