Skip to content

Commit

Permalink
net-analyzer/cloudshark: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
ZeroChaos- committed Jan 27, 2016
1 parent 24ca08c commit b5e2630
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-analyzer/cloudshark/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST cloudshark-1.0.4.tar.gz 24947 SHA256 9b3c011c3cb6f08234754dbf8abf4e5e095d23b470262a07fe489c867bf60ea5 SHA512 5cb0e43e348d00c0ecc98f079a35f455865cbbe884e34101369b74429bb5bc14bb98acffa9749ce44a765e3653c0548e8b30cc658fb982b09dd61e2ec31b4f86 WHIRLPOOL 8f97d7aa0e88e5693994897abbcf6863b5e4cc4a414f0397130bd371e27436d22472a447d89d83f9870f5d8c0b93a0d54d083c6ea38e5e286965d5fee55b150e
DIST cloudshark-plugin-1.0.2-174.tgz 143067 SHA256 d5918e9e3dc60059bdc40d436409c18197df428266863d90367a762f08c3623e SHA512 42445e67630b1bd2968f0836f625acb3792f22257de104ec0b90c59fa8d2096649eba2252cd6161ce57c8ff79095d52c5663d2fa018c650667896c9905e9dd7e WHIRLPOOL 01f3f6bc87b3f09645d2fef953d84b7ba3828f960d7e9bb952bf18cbeb8422beb63cee21355434f392727795b0462e59fd2b07549cce6048e689e5e02bcdd19d
DIST cloudshark-plugin-1.0.3-180.tgz 143381 SHA256 0c0b204622107dcb29d302401688b62fa3b904eb0b5ccfa6bb42802084f5d102 SHA512 765144e6a2c7ce17eaa05f8170216e08ccac224ba6c11750893ae5caa8f40a2b6bee883fd9be91fa800ad3b45dc42d2ec81e564aa573015a91a8537be8384c73 WHIRLPOOL 818abb8dd904c72fe870336bb3702df04af7299c6e3bbed21510a0a4484997ec4eef68c14f0a556285f82a89ef57fd9768c6814cc3311c4abd28194d70159926
44 changes: 44 additions & 0 deletions net-analyzer/cloudshark/cloudshark-1.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils multilib

DESCRIPTION="Easily upload your wireshark captures to CloudShark"
HOMEPAGE="http://appliance.cloudshark.org/plug-ins-wireshark.html"
SRC_URI="https://github.com/${PN}/wireshark-plugin/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE=""

PDEPEND="net-analyzer/wireshark:=[lua]
net-misc/curl"

S="${WORKDIR}/wireshark-plugin-${PV}"

get_PV() {
local pv=$(best_version $1)
pv=${pv#$1-}; pv=${pv%-r*}
pv=${pv//_}; echo ${pv}
}

src_prepare() {
#cloudshark isn't meant to be installed systemwide, we fix that
epatch "${FILESDIR}"/cs_log_dir.patch

sed -i "s#%s/cloudshark_init.lua#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/cloudshark_init.lua#" cloudshark.lua

#this enables cloudshark by DEFAULT on tshark, not desired
#sed -i 's#CLOUDSHARK_TSHARK = "n"#CLOUDSHARK_TSHARK = "y"#' cloudshark_init.default
}

src_install() {
insinto /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)
doins cloudshark.lua json.lua
newins cloudshark_init.default cloudshark_init.lua
dodoc README.md
}

0 comments on commit b5e2630

Please sign in to comment.