Skip to content

Commit

Permalink
dev-php/pecl-apcu_bc: Fix tests in 1.0.4
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/667494
Signed-off-by: Brian Evans <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
Brian Evans committed Oct 18, 2018
1 parent 250f8bd commit b60e51f
Showing 1 changed file with 21 additions and 2 deletions.
23 changes: 21 additions & 2 deletions dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand All @@ -12,7 +12,7 @@ DOCS=( README.md )

USE_PHP="php7-0 php7-1 php7-2"

inherit php-ext-pecl-r3
inherit php-ext-pecl-r3 multilib

KEYWORDS="~amd64 ~x86"

Expand All @@ -23,3 +23,22 @@ IUSE=""

DEPEND="dev-php/pecl-apcu:7[php_targets_php7-0?,php_targets_php7-1?,php_targets_php7-2?]"
RDEPEND="${DEPEND}"

src_test() {
# This fixed version is necessary to have apcu load
# from the install before the tested apc.
# It is intentional to specify phpoptions twice.
# This mimics the Makefile.
local slot phpoptions
for slot in $(php_get_slots); do
php_init_slot_env "${slot}"
ln -s "${EXT_DIR}/apcu$(get_libname)" \
"modules/" || die
phpoptions=( -n -d extension_dir="${PHP_EXT_S}/modules"
-d extension=apcu$(get_libname)
-d extension=apc$(get_libname) )
NO_INTERACTION="yes" TEST_PHP_EXECUTABLE="${PHPCLI}" \
"${PHPCLI}" "${phpoptions[@]}" \
run-tests.php "${phpoptions[@]}" || die
done
}

0 comments on commit b60e51f

Please sign in to comment.