Skip to content

Commit

Permalink
dev-python/line_profiler: Bump to 4.0.1
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 16, 2022
1 parent b3efc23 commit b666a53
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/line_profiler/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST line_profiler-4.0.0.gh.tar.gz 62856 BLAKE2B 7beb4b63c016d180d1e7e39b0461759593d3ba3ad1c5150b3623890ece3a69ebb65d48f59e8dc3865a19565ab46f2dc8a2a86698abe890d9bd857e1080cbb557 SHA512 d10b9470c686da863c340da7d4af8b6c6b6cb715486a00af1e1d79686c26909b289b8400a4d526520ade6fbbcd58e868a97603345682d5060a9b3ae2fd3495be
DIST line_profiler-4.0.1.gh.tar.gz 63735 BLAKE2B 980298c2f0e2cffac12c1bb8dc87ca7876ac74969aafa77500aeb4ab1ab12e98ca56a2974d1311d560fdd7ff707fe6bb44d010f315a1070dc68accdede9041e9 SHA512 1943b359bc442fff8c35674c6e0ea108cbfb06706ed95dfe961daea5de8797ec01e70a712663fff0dcc727c954ddb8a4da4b45774817b14b903901f9cfe108c6
41 changes: 41 additions & 0 deletions dev-python/line_profiler/line_profiler-4.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )

inherit distutils-r1

DESCRIPTION="Line-by-line profiler"
HOMEPAGE="
https://github.com/pyutils/line_profiler/
https://pypi.org/project/line-profiler/
"
SRC_URI="
https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"

SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64 ~x86"

RDEPEND="
dev-python/ipython[${PYTHON_USEDEP}]
"
BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/ubelt[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

python_test() {
cd tests || die
epytest
}

0 comments on commit b666a53

Please sign in to comment.