forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
- Loading branch information
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
From e854f357f4037e2c8c781ebd04ec5164a882b9b3 Mon Sep 17 00:00:00 2001 | ||
From: Andreas Sturmlechner <[email protected]> | ||
Date: Thu, 12 Apr 2018 00:45:50 +0200 | ||
Subject: [PATCH] Make Qt5Network conditional on BUILD_TESTS | ||
|
||
Summary: I did not find it in use somewhere else. | ||
|
||
Reviewers: iromanov, sitter, rjvbb | ||
|
||
Reviewed By: rjvbb | ||
|
||
Subscribers: fvogt | ||
|
||
Differential Revision: https://phabricator.kde.org/D12129 | ||
--- | ||
CMakeLists.txt | 6 +++++- | ||
1 file changed, 5 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 28b0169..65b95f8 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -59,7 +59,11 @@ if (Qt5Core_FOUND) | ||
message(STATUS "Building with Qt5 support") | ||
# Got from ECM | ||
# Distros have no ECM. So I just copied required cmake modules. | ||
- find_package(Qt5Transitional REQUIRED Core Network) | ||
+ if(BUILD_TESTS) | ||
+ find_package(Qt5Transitional REQUIRED Core Network) | ||
+ else() | ||
+ find_package(Qt5Transitional REQUIRED Core) | ||
+ endif() | ||
include(ECMQt4To5Porting) | ||
|
||
include(GNUInstallDirs) | ||
-- | ||
2.17.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters