Skip to content

Commit

Permalink
app-i18n/transifex-client: fix failing test on 32 bit systems
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/771660
Signed-off-by: Robert Siebeck <[email protected]>
Closes: gentoo#19658
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
robert7k authored and thesamesam committed Feb 27, 2021
1 parent 75946dc commit b6ad4d9
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
14 changes: 14 additions & 0 deletions app-i18n/transifex-client/files/transifex-client-timestamp.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
diff -Naur ../transifex-client-0.14.2.orig/tests/test_project.py ./tests/test_project.py
--- ../transifex-client-0.14.2.orig/tests/test_project.py 2020-06-19 14:48:52.000000000 +0200
+++ ./tests/test_project.py 2021-02-25 22:08:29.353477306 +0100
@@ -717,8 +717,8 @@
)
self.assertEqual(res, True)

- # "Recent" timestamp (in the future - 2100)
- ts_mock.return_value = 4111417171
+ # "Recent" timestamp (in the future - 2038)
+ ts_mock.return_value = 2147483000
res = self.p._should_download(
'pt', self.stats, os.path.abspath(__file__), False,
use_git_timestamps=True
37 changes: 37 additions & 0 deletions app-i18n/transifex-client/transifex-client-0.14.2-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend

inherit eutils distutils-r1

DESCRIPTION="A command line interface for Transifex"
HOMEPAGE="https://pypi.org/project/transifex-client/ https://www.transifex.net/ https://github.com/transifex/transifex-client"
SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
RDEPEND="dev-python/GitPython[${PYTHON_USEDEP}]
<dev-python/python-slugify-5.0.0[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
<dev-python/six-2.0.0[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]"

distutils_enable_tests setup.py

src_prepare() {
eapply_user
sed -i -e 's:test_fetch_timestamp_from_git_tree:_&:' \
tests/test_utils.py || die
sed -i '/tests_require=\["mock>=3.0.5,<4.0"\]/d' setup.py || die
# Bug 771660
eapply "${FILESDIR}"/${PN}-timestamp.patch
}

0 comments on commit b6ad4d9

Please sign in to comment.