Skip to content

Commit

Permalink
dev-util/bite: initial import for live ebuild
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Jun 4, 2018
1 parent 956411c commit b769b2b
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
57 changes: 57 additions & 0 deletions dev-util/bite/bite-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python3_6 )
DISTUTILS_IN_SOURCE_BUILD=1
PYTHON_REQ_USE="xml"

inherit distutils-r1

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/bite/bite.git"
inherit git-r3
else
SRC_URI="https://github.com/bite/${PN}/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="bug, issue, and ticket extraction library and command line tool"
HOMEPAGE="https://github.com/bite/bite"
LICENSE="BSD"
SLOT="0"
IUSE="doc test"

RDEPEND="
>=dev-python/requests-2[${PYTHON_USEDEP}]
dev-python/multidict[${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
"
if [[ ${PV} == *9999 ]] ; then
RDEPEND+=" =dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
SPHINX="dev-python/sphinx[${PYTHON_USEDEP}]"
else
RDEPEND+=" >=dev-python/snakeoil-0.8[${PYTHON_USEDEP}]"
SPHINX="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
fi
DEPEND="
${SPHINX}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"

python_compile_all() {
esetup.py build_man $(usex doc "build_docs" "")
}

python_test() {
esetup.py test
}

python_install_all() {
distutils-r1_python_install install_man \
$(usex doc "install_docs --path="${ED%/}"/usr/share/doc/${PF}/html" "")
distutils-r1_python_install_all
}
11 changes: 11 additions & 0 deletions dev-util/bite/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Tim Harder</name>
</maintainer>
<upstream>
<remote-id type="github">bite/bite</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit b769b2b

Please sign in to comment.