Skip to content

Commit

Permalink
dev-ros/interval_intersection: backport upstream fix to build with gc…
Browse files Browse the repository at this point in the history
…c6, bug #594378, patch by Peter Levine.

Package-Manager: portage-2.3.2
  • Loading branch information
aballier committed Oct 14, 2016
1 parent d8d6865 commit b7ae1aa
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 1 deletion.
31 changes: 31 additions & 0 deletions dev-ros/interval_intersection/files/gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
commit c23ddb86367fc43c2d15e08a452ad2dc1a62041b
Author: Hodorgasm <[email protected]>
Date: Mon Sep 19 19:11:57 2016 -0400

Fix "stdlib.h: No such file or directory" errors in GCC-6

Including '-isystem /usr/include' breaks building with GCC-6.
See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129

diff --git a/interval_intersection/CMakeLists.txt b/interval_intersection/CMakeLists.txt
index 9bfd103..73bc0ac 100644
--- a/interval_intersection/CMakeLists.txt
+++ b/interval_intersection/CMakeLists.txt
@@ -4,7 +4,7 @@ project(interval_intersection)
find_package(Boost REQUIRED thread)
find_package(catkin REQUIRED actionlib actionlib_msgs calibration_msgs geometry_msgs rosconsole roscpp roscpp_serialization rostime std_msgs)

-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
+include_directories(${catkin_INCLUDE_DIRS})
include_directories(include)

# generate the messages
@@ -35,7 +35,7 @@ add_executable(interval_intersection_node src/interval_intersection_node.cpp)
target_link_libraries(interval_intersection_node ${PROJECT_NAME})
add_dependencies(interval_intersection_node calibration_msgs_gencpp)

-include_directories(SYSTEM ${BOOST_INCLUDE_DIRS})
+include_directories(${BOOST_INCLUDE_DIRS})
add_executable(interval_intersection_action src/interval_intersection_action.cpp)
target_link_libraries(interval_intersection_action ${Boost_LIBRARIES}
${catkin_LIBRARIES}
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -28,3 +28,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
PATCHES=( "${FILESDIR}/gcc6.patch" )

0 comments on commit b7ae1aa

Please sign in to comment.