Skip to content

Commit

Permalink
dev-php/phptal: Version bump to 1.3.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
Brian Evans committed Apr 25, 2018
1 parent d3170f7 commit b7bd728
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/phptal/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST PHPTAL-1.2.2.tar.gz 163248 BLAKE2B d0b48a5131a4567eb058e6c3395bdfff7d0e9535dae036616dbfcb11564ce9db07bec8a77ee3201dcaff7a0bcdbb451b4d7443307d6092ba81d35b849f05603f SHA512 7af41180bccbc81481a48f474b1d2c811ba678706f85045611ff1e69c3ee820e27e6cf17ea58ec562120dcdaae1cf3d91f606a13b5c262906ceba7570b092d9b
DIST phptal-1.3.1.tar.gz 272883 BLAKE2B 4914b8bb40464f22417fd7ed7dbf88709b95b69a69a905a5152ff640dd5af6af2be7c7d67a622d78029e4075b6b19d8d1bf537a4a6ccc0c97260e5183a961ecd SHA512 74856cbeab3f8d9d552bcb7275a0180fd25e7703230c90e4343fbe9be4001118b091fabbace89efa98a8bf0344f46edf36c4ba709ed0e9b040b82204ea3b7290
35 changes: 35 additions & 0 deletions dev-php/phptal/phptal-1.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PHP_LIB_NAME="PHPTAL"

DESCRIPTION="A templating engine for PHP5 that implements Zope Page Templates syntax"
HOMEPAGE="https://phptal.org/"
SRC_URI="https://github.com/${PN}/${PHP_LIB_NAME}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="dev-lang/php:*"
DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"

S="${WORKDIR}/${PHP_LIB_NAME}-${PV}"

src_compile() { :; }

src_install() {
insinto /usr/share/php/${PN}
doins -r "classes/${PHP_LIB_NAME}"
doins classes/PHPTAL.php tools/phptal_lint.php

dodoc README.md
}

src_test() {
[[ -z $(locale -a |grep en_GB) ]] && ewarn "Tests require en_GB locale to complete"
phpunit || die
}

0 comments on commit b7bd728

Please sign in to comment.