forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-video/kaffeine: Version bump 2.0.9
Package-Manager: Portage-2.3.4, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
67 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kaffeine-2.0.6.tar.xz 2295280 SHA256 70cd8423a23717edc7c8f127bd41e5e98aa93cc5866615ed25a8da3e148464e6 SHA512 ca2f036b629e750703536054dd6e28bc9b8191c3851a745f07548b756799243b3739cba9c7ec031be6eab64c18aa5f2eb96d37bcd0b11456e65eb67b016d1bc2 WHIRLPOOL 0d67538dc45f50cced9ab2c0b1adf1bf2367d823270118bf268ed2126c7bb1a653333b09fabb51e2b60400fcf073de6fe917a4887d54edc3c13204433538d146 | ||
DIST kaffeine-2.0.8.tar.xz 4400524 SHA256 0277e5d3f55e4ac002788fc6954d4ab5c6aa994f63d7c6b9136d3227818facbd SHA512 9ee7b156d5195caef61cdbdf12deaa2493c6acc31724e839e1773dc5d7ee06f0d87cd7f21df74cf67dcb32fa5a347b72f5953f4568eb8476cb337a59121c609f WHIRLPOOL 4ae48e7e2f615428730f02d0b6b08406f6b3e805518da3fad9cb041ec5f1f9623541f521b3c065e94ed75f3f076d6651d5acc9d2fd306bc545527b05d550c01e | ||
DIST kaffeine-2.0.9.tar.xz 4398832 SHA256 ac53b697bba4fa97350706698c777908c21c464f7c567fe1a4ce9352e955754f SHA512 5adf86185aaafce4eadda4cfe40af2e0c867477f51b74a464bf813c018ecf035f9e13f47fffd21c0cd547289825441d2d80298ec7035e260f3cc0414c5fdd0d7 WHIRLPOOL 948eecec4957046c6ddee872747959661725f4d9f8408c735803d0dcc82c38dfcc7df6e9e92c46e8fda58e2f53a41ab6cf8c33da4b88f7d89542aa427a486223 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,66 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
KDE_HANDBOOK="optional" | ||
inherit kde5 | ||
|
||
DESCRIPTION="Media player with digital TV support by KDE" | ||
HOMEPAGE="https://kaffeine.kde.org/" | ||
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2+ handbook? ( FDL-1.3 )" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
CDEPEND=" | ||
$(add_frameworks_dep kconfig) | ||
$(add_frameworks_dep kconfigwidgets) | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep kdbusaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep kwidgetsaddons) | ||
$(add_frameworks_dep kxmlgui) | ||
$(add_frameworks_dep solid) | ||
$(add_qt_dep qtdbus) | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtnetwork) | ||
$(add_qt_dep qtsql 'sqlite') | ||
$(add_qt_dep qtwidgets) | ||
$(add_qt_dep qtx11extras) | ||
$(add_qt_dep qtxml) | ||
media-libs/libv4l | ||
media-video/vlc[X] | ||
x11-libs/libXScrnSaver | ||
" | ||
DEPEND="${CDEPEND} | ||
sys-devel/gettext | ||
virtual/pkgconfig | ||
" | ||
RDEPEND="${CDEPEND} | ||
!media-video/kaffeine:4 | ||
" | ||
|
||
DOCS=( Changelog NOTES README.md ) | ||
|
||
src_prepare() { | ||
kde5_src_prepare | ||
|
||
# unused dependencies incorrectly added during the release process | ||
# they do not appear in upstream git | ||
sed -i \ | ||
-e "/find_package(KF5DocTools CONFIG REQUIRED)/d" \ | ||
-e "/kdoctools_install(po)/d" \ | ||
CMakeLists.txt || die | ||
} | ||
|
||
src_configure() { | ||
# tools working on $HOME directory for a local git checkout | ||
local mycmakeargs=( | ||
-DBUILD_TOOLS=OFF | ||
) | ||
|
||
kde5_src_configure | ||
} |