forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
- Loading branch information
Jeroen Roovers
committed
Jan 24, 2018
1 parent
bf5bf1b
commit b7f997a
Showing
2 changed files
with
74 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST debhelper_11.1.2.tar.xz 448676 BLAKE2B 52e79349449c387f48cacedfae334c241b8e0187071aec1ec571a7fc04a4bfd2a9ea9c54f7cfa75ec96a01ef5d2f859caeac317f53b72479664d4f2670d44a22 SHA512 26cd04eef4cb634b1424b7d08bcc61fdae9b18a96753680658ed412e51c9124b33295e79f3aabbb40579a9d4bb059b526428b97c151d9f34ae93b615b64291bb | ||
DIST debhelper_11.1.3.tar.xz 449268 BLAKE2B 9cbd8a2c71897a5ba28b987b24e939e830a9322332c48f94c42ea417330b94ddee60f5619426b37db96cf4e560b74cd2d1dc221fed27433943b7ff6db7adbeff SHA512 e7a36b2226eb0dcbf91068fa312d42125add7864fd16eefa3346d196162fa739c436df41c053e6d25d82f5d784c95df37dd1a43927dd007c358382dd042c4e92 | ||
DIST debhelper_11.tar.xz 439268 BLAKE2B 45c1eeb046a6fbc59b814f696c7320b344ba3cf1ba47b02e9aafd38f88e72943eaba0c0625115fc35cdce9cec0f01232278956644f02b632beda2e2d052ca1aa SHA512 12eabb2f02df24a2c1d8db8e1d88ecec2fce1547c21e99f99bf89f5a44ebd71d09ebbb7e19e0e30ca7e2f17b252769c79968d81989ab7330f870b7ee42e13521 | ||
DIST debhelper_9.20160814.tar.xz 344328 BLAKE2B 38791ab3dfb74d12e44226b79a377889911a08505cdb45cc0a6e653906edbafcac1038d1d9ff9f5fd9f714ed36681562ce7fb1c9c1109a8528523100128fced6 SHA512 63072ba35ec8c62ee4c4d44833712925264c808a91f1522ef6a73377f2da3d11b285a21ad39158fd44693c801916189261186c8c7b28096719328a81a0a65f62 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,73 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit eutils toolchain-funcs | ||
|
||
DESCRIPTION="Collection of programs that can be used to automate common tasks in debian/rules" | ||
HOMEPAGE="https://tracker.debian.org/pkg/debhelper" | ||
SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux" | ||
IUSE="test" | ||
DH_LANGS=( de es fr ) | ||
IUSE+=" ${DH_LANGS[@]/#/l10n_}" | ||
|
||
NLS_DEPEND=$( | ||
printf "l10n_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LANGS[@]} | ||
) | ||
|
||
RDEPEND=" | ||
>=dev-lang/perl-5.10:= | ||
>=app-arch/dpkg-1.17 | ||
dev-perl/TimeDate | ||
virtual/perl-Getopt-Long | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
${NLS_DEPEND} | ||
test? ( | ||
dev-perl/Test-Pod | ||
sys-apps/fakeroot | ||
) | ||
" | ||
|
||
S=${WORKDIR}/${PN} | ||
|
||
src_compile() { | ||
tc-export CC | ||
|
||
local LANGS="" USE_NLS=no lang | ||
for lang in ${DH_LANGS[@]}; do | ||
if use l10n_${lang}; then | ||
LANGS+=" ${lang}" | ||
USE_NLS=yes | ||
fi | ||
done | ||
|
||
emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install | ||
dodoc doc/* debian/changelog | ||
docinto examples | ||
dodoc examples/* | ||
local lang | ||
for manfile in *.1 *.7 ; do | ||
for lang in ${DH_LANGS[@]}; do | ||
case ${manfile} in | ||
*.${lang}.?) | ||
use l10n_${lang} \ | ||
&& cp ${manfile} "${T}"/${manfile/.${lang}/} \ | ||
&& doman -i18n=${lang} "${T}"/${manfile/.${lang}/} | ||
;; | ||
*) | ||
doman ${manfile} | ||
;; | ||
esac | ||
done | ||
done | ||
} |