forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-office/scribus-9999: updated docdir patch
Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Miroslav Šulc <[email protected]>
- Loading branch information
Showing
2 changed files
with
30 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index f5b3e77..4c5fd3f 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -313,14 +313,16 @@ else() | ||
endif() | ||
|
||
#SHARE - use the default on Apple as TAG_VERSION is empty | ||
-if(WIN32 OR OS2) | ||
- set(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/") | ||
-elseif(TAG_VERSION OR BUILD_OSX_BUNDLE) | ||
- set(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}${TAG_VERSION}/") | ||
-elseif(NOT WANT_VERSIONING) | ||
- set(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}/") | ||
-else() | ||
- set(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}-${VERSION}/") | ||
+if(NOT DOCDIR) | ||
+ if(WIN32 OR OS2) | ||
+ set(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/") | ||
+ elseif(TAG_VERSION OR BUILD_OSX_BUNDLE) | ||
+ set(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}${TAG_VERSION}/") | ||
+ elseif(NOT WANT_VERSIONING) | ||
+ set(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}/") | ||
+ else() | ||
+ set(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/${MAIN_DIR_NAME}-${VERSION}/") | ||
+ endif() | ||
endif() | ||
|
||
if(IS_ABSOLUTE ${DOCDIR} AND WANT_RELOCATABLE) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters