Skip to content

Commit

Permalink
app-emulation/nemu: version bump.
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/698444
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Nov 28, 2019
1 parent 50942d5 commit b827d87
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/nemu/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST nemu-2.1.0.tar.gz 89117 BLAKE2B a44bf67990d79af0b73caf077266c4775f302ffc81d2394993da45870a72f462d487a92d63abdbe875c382d11b8d691f446a5e0b7270355770838ea86328fb1d SHA512 7e655227e22f5e2dd5ec1f77ef1635f1aaab2e57e417fb33d83d35cc67d7b802c35fa9174cf4282287213a1a825714743773260b96b452a382a8248fbef238bf
DIST nemu-2.2.0.tar.gz 94061 BLAKE2B 95304e8834f1d5c1e31065728363de5d797ae79554733dd3fecd90388b2766bc8907acfeded36676272967153eed5a7f30baba9ef2384fca67d19f3519461fa6 SHA512 2f427a560ea5ac4112b7d5cdd8524366521ca3d185676a4faa9bc480331c3381b7a362aed20025dc1acc0f576f07fb627b03137e1998926761a169c5be0eaf97
DIST nemu-2.2.1.tar.gz 94600 BLAKE2B 16060ee1ed00f97a442d9f6b9a3f940d9777d24dea70336e382071ce7e9f7e077d58827110f4b0d64091c5777d516e95968ed0e1d4886b9fe2a3709fb466229d SHA512 e6f244c01582351f9e0f61a0a6848937a68b8d077500d0f8095784b871e9c9809bf5830c27918e84a77a64fcee3d6f81d8a06a031160f0beddc48614eb86624a
73 changes: 73 additions & 0 deletions app-emulation/nemu/nemu-2.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils linux-info

DESCRIPTION="ncurses interface for QEMU"
HOMEPAGE="https://lib.void.so/nemu/ https://bitbucket.org/PascalRD/nemu/"
SRC_URI="https://lib.void.so/src/${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug network-map +ovf savevm spice +vnc-client"

RDEPEND="app-emulation/qemu[vnc,virtfs,spice?]
dev-db/sqlite:3=
sys-libs/ncurses:0=[unicode]
virtual/libusb:1
virtual/libudev:=
network-map? ( media-gfx/graphviz )
ovf? (
dev-libs/libxml2:2
app-arch/libarchive
)
vnc-client? ( net-misc/tigervnc )"

DEPEND="${RDEPEND}"

BDEPEND="sys-devel/gettext"

pkg_pretend() {
if use kernel_linux; then
if ! linux_config_exists; then
eerror "Unable to check your kernel"
else
CONFIG_CHECK="~VETH ~MACVTAP"
ERROR_VETH="You will need the Virtual ethernet pair device driver compiled"
ERROR_VETH+=" into your kernel or loaded as a module to use the"
ERROR_VETH+=" local network settings feature."
ERROR_MACVTAP="You will also need support for MAC-VLAN based tap driver."

check_extra_config
fi
fi
}

src_configure() {
local mycmakeargs=(
-DNM_DEBUG=$(usex debug)
-DNM_WITH_NETWORK_MAP=$(usex network-map)
-DNM_WITH_OVF_SUPPORT=$(usex ovf)
-DNM_SAVEVM_SNAPSHOTS=$(usex savevm)
-DNM_WITH_SPICE=$(usex spice)
-DNM_WITH_VNC_CLIENT=$(usex vnc-client)
)
cmake-utils_src_configure
}

pkg_postinst() {
elog "For non-root usage execute script:"
elog "/usr/share/nemu/scripts/setup_nemu_nonroot.sh linux <username>"
elog "and add udev rule:"
elog "cp /usr/share/nemu/scripts/42-net-macvtap-perm.rules /lib/udev/rules.d"
if use savevm; then
elog ""
elog "QEMU must be patched with qemu-qmp-savevm-VERSION.patch"
elog "Get this patch from nEMU repository"
fi
}

0 comments on commit b827d87

Please sign in to comment.