forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/devhelp: version bump 3.20.0 → 3.22.0
Package-Manager: portage-2.3.1
- Loading branch information
Showing
2 changed files
with
61 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST devhelp-3.18.1.tar.xz 464312 SHA256 303a162ad294dc6f9984898e501a06dc5d2aa9812b06801c2e39b250d8c51aef SHA512 7b3eca28f1e6117e2aa0599645fec8e1b18f05c44d8f79de7f7de6804bdf485034515ff6bdd9599810ba9880c8eac0901ba5d29b8272a061196cfc5bd563eb79 WHIRLPOOL 284a3ec2548429a5ee7ebce5eb38e586737d71430a19777e1e05c634c011bbc173ddcaf7f4cf24f3e2e68965b117b5c4f0228467cd080c15e4ab05385b468a47 | ||
DIST devhelp-3.20.0.tar.xz 489308 SHA256 a23375c2e2b2ef6240994bc2327fcacfd42403af6d872d0cba2e16dd45ca1f1d SHA512 4f64d95bddc41031a4c7589fdd6ed15b17654917c82a77b82044d5c7ac7bf02546ac1d689a6909bb5128f125a992910ccb4eb0c0e261ffa94eea0f0fef39316b WHIRLPOOL 41d015394f0a5f8e4757c6aae09f74b3e902f2ad8753face16041e850e72b176629eb6f733de97272f6dc42d51f4ebae1c5cad875f419b4df2ddec7e5d56f0bd | ||
DIST devhelp-3.22.0.tar.xz 491908 SHA256 59cae02e12d238cc5fc3f049d779895ba89701426d9173f5b534d4ab90c5ffb0 SHA512 16d9853c4514d7b28381e3755e34682a2e9d64d666bb7d39094289d4990eb981efac041b7bf7f8beef5a018cab71c461ecd4e7b7a099fbc132f5b8f7b79749dc WHIRLPOOL a46088f7cf373106cfecaa87f2cac350e05fb94dc925f12e22f9f000754124dfe62845d23a14689c386167e54f0b74bdd4ec5bb2b08b0aad61c54d5f16070713 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
# gedit-3.8 is python3 only, this also per: | ||
# https://bugzilla.redhat.com/show_bug.cgi?id=979450 | ||
PYTHON_COMPAT=( python{3_3,3_4,3_5} ) | ||
|
||
inherit gnome2 python-single-r1 toolchain-funcs | ||
|
||
DESCRIPTION="An API documentation browser for GNOME" | ||
HOMEPAGE="https://wiki.gnome.org/Apps/Devhelp" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0/3-1" # subslot = 3-(libdevhelp-3 soname version) | ||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd" | ||
IUSE="gedit" | ||
REQUIRED_USE="gedit? ( ${PYTHON_REQUIRED_USE} )" | ||
|
||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.37.3:2[dbus] | ||
>=x11-libs/gtk+-3.19.3:3 | ||
>=net-libs/webkit-gtk-2.6.0:4 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
gedit? ( | ||
${PYTHON_DEPS} | ||
app-editors/gedit[introspection,python,${PYTHON_USEDEP}] | ||
dev-python/pygobject:3[${PYTHON_USEDEP}] | ||
x11-libs/gtk+[introspection] ) | ||
gnome-base/gsettings-desktop-schemas | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
${PYTHON_DEPS} | ||
>=dev-util/intltool-0.40 | ||
gnome-base/gnome-common | ||
virtual/pkgconfig | ||
" | ||
|
||
pkg_setup() { | ||
use gedit && python-single-r1_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
if ! use gedit ; then | ||
sed -e '/SUBDIRS/ s/gedit-plugin//' -i misc/Makefile.{am,in} || die | ||
fi | ||
|
||
gnome2_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local myconf="" | ||
# ICC is crazy, silence warnings (bug #154010) | ||
if [[ $(tc-getCC) == "icc" ]] ; then | ||
myconf="--with-compile-warnings=no" | ||
fi | ||
gnome2_src_configure ${myconf} | ||
} |