Skip to content

Commit

Permalink
www-client/opera-developer: Version 54.0.2936.0.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
Jeroen Roovers committed Apr 26, 2018
1 parent dcea8b5 commit b873e7a
Show file tree
Hide file tree
Showing 2 changed files with 115 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/opera-developer/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST opera-developer_54.0.2929.0_amd64.deb 55440718 BLAKE2B ecc20106b19d4ce687dc525b536adfcf4b8bb9bdab26791fc28eaa9e68d3b8b58df4ba7c42d5caefeb9ab1bb4062e08b60ccadb3bad837a393e1290a5ea4667a SHA512 5a3dbdac8fa4578db6e37f9d2f0ef30cd6fea7195a25d736572195a9cdd4a818ab0cfc47605b835ce2db32c0ada09ccc25c13698ba0d9bd46a85470a5de5b6ca
DIST opera-developer_54.0.2934.0_amd64.deb 55198712 BLAKE2B 1d94cb440146405d27f9757d8175d0bb44151f272bc948595d2f69d37d88155278d6fae86bee25982ecc8eee85414551cea5e8a7c4eb04756a0d518f92fce491 SHA512 7fc9189d63871626a33454201c51f460bab85356b1a6e31b81b9fd199b75838e5af3a704d5fcc38cc23d30aea6626ee008c7d7773a0ee20db2c5e3fd93ed53cf
DIST opera-developer_54.0.2936.0_amd64.deb 55512814 BLAKE2B 171f09cc453d08b6f225e1c67d0b239e3f0f3a479d6aed8feb07b3ade1f8629e963c3bdc96defe1c18d0bbdca6daafccdb8bc0961b2e992d704cf080ba130551 SHA512 8f808c5c3b814f108a63b2b1e1862ddd8c81e3d46404c3d05fd583e6e69c52271226d49b320c005d70455e02900a7cd079e8f6ee84b005e309d861e4482b2f84
114 changes: 114 additions & 0 deletions www-client/opera-developer/opera-developer-54.0.2936.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,114 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
CHROMIUM_LANGS="
be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it
ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
zh-CN zh-TW
"
inherit chromium-2 gnome2-utils multilib unpacker xdg-utils

DESCRIPTION="A fast and secure web browser"
HOMEPAGE="http://www.opera.com/"
LICENSE="OPERA-2014"
SLOT="0"
SRC_URI_BASE="
http://download1.operacdn.com/pub/
http://download2.operacdn.com/pub/
http://download3.operacdn.com/pub/
http://download4.operacdn.com/pub/
"
SRC_URI="amd64? ("
for uri in ${SRC_URI_BASE}; do
SRC_URI+="
"${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb"
"
done
SRC_URI+=")"
KEYWORDS="~amd64"

RDEPEND="
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
gnome-base/gconf:2
media-libs/alsa-lib
media-libs/fontconfig
media-libs/freetype
net-misc/curl
net-print/cups
sys-apps/dbus
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:3
x11-libs/libX11
x11-libs/libXScrnSaver
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXtst
x11-libs/libnotify
x11-libs/pango[X]
"

QA_PREBUILT="*"
S=${WORKDIR}
OPERA_HOME="usr/$(get_libdir)/${PN}"

src_unpack() {
unpack_deb ${A}
}

src_prepare() {
case ${ARCH} in
amd64)
mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
rm -r usr/lib || die
;;
x86)
mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
;;
esac

rm usr/bin/${PN} || die

rm usr/share/doc/${PN}/copyright || die
mv usr/share/doc/${PN} usr/share/doc/${PF} || die

pushd "${OPERA_HOME}/localization" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die

sed -i \
-e 's|^TargetEnvironment|X-&|g' \
usr/share/applications/${PN}.desktop || die
}

src_install() {
mv * "${D}" || die
dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

pkg_postinst() {
gnome2_icon_cache_update
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

0 comments on commit b873e7a

Please sign in to comment.