Skip to content

Commit

Permalink
dev-libs/libcdio-paranoia: Bump to version 0.94_p1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Lars Wendler committed Apr 19, 2017
1 parent 0b2fbad commit b8753ce
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libcdio-paranoia/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libcdio-paranoia-10.2+0.90+1.tar.gz 634050 SHA256 7608c8e3195ba438aa1ae05b60d76ef9aacbcc27233a3eb03a0439abea464be6 SHA512 c3d00b57f22deb19be929ba87f41bbd83fc51ca66e8ccc1da7acb4131d85449fdd38161cc3ec0f1714fc0571e219d72029b5a72f853c139aa479695df783aad6 WHIRLPOOL 920d8d8f377dd6ae4f95e777d3c926250b24572d27fcf7171ec5cdf434dbbf5b084b30448303d9ae93328eee7003d763df082455d318440fb9a5f3d0e9c9e7db
DIST libcdio-paranoia-10.2+0.93+1.tar.gz 686055 SHA256 4617792b4eb301de45b61732bdc0617447ad06b53068ae45db37695275c0dd4c SHA512 2bb418c99ef037aeb90ba3db841ea9182c5bc401e74c6f4b552730e6c8561552f7d3e27be71ef4fbb07b4fcd9db418a4fe330d5278e8f41cdd99c757aa4b8bc6 WHIRLPOOL 2109ff999820e63b07853ea26c059e3f60af4b2ac42083f122551dbf7e8b78d5ad522df209f236040bd355dc134d68d4ef3345c57c65bc7392327667d1facd38
DIST libcdio-paranoia-10.2+0.94+1.tar.gz 703424 SHA256 ce22ab868b61ee3b648359dbdec83566b37b1e03f26a2460be6ccdf4a6ad3c99 SHA512 9b2381491271090bac08594cb1d84de98e9f0a5afc6a2c98e9ffcf4b95addc3adcd0f0b9adeb928dfbf8178356ad6a7ccfeb048685c823d138b2af232f0b4c93 WHIRLPOOL fc2441ac70e8f4fa0e36380476c3982d04874a8806dce9a0fe2f62c4fdfa515064da9ce9b575f5c3153549c211361528cfb44444b70615782fed044a1229e511
63 changes: 63 additions & 0 deletions dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
MY_P=${PN}-10.2+${PV/_p/+}

inherit eutils autotools multilib-minimal flag-o-matic

DESCRIPTION="an advanced CDDA reader with error correction"
HOMEPAGE="https://www.gnu.org/software/libcdio/"
SRC_URI="mirror://gnu/${PN%-*}/${MY_P}.tar.gz"

# COPYING-GPL from cdparanoia says "2 or later"
# COPYING-LGPL from cdparanoia says "2.1 or later" but 2 files are without the
# clause "or later" so we use LGPL-2.1 without +
LICENSE="GPL-3+ GPL-2+ LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="+cxx static-libs test"

RDEPEND="app-eselect/eselect-cdparanoia
>=dev-libs/libcdio-0.94:0=[${MULTILIB_USEDEP}]
>=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r10
!app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
test? ( dev-lang/perl )"

S="${WORKDIR}/${MY_P}"

DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )

src_prepare() {
sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
default
eautoreconf

[[ ${CC} == *clang* ]] && append-flags -std=gnu89
}

multilib_src_configure() {
local myeconfargs=(
--disable-maintainer-mode
--disable-example-progs
$(use_enable cxx)
--disable-cpp-progs
--with-cd-paranoia-name=libcdio-paranoia
)
# Darwin linker doesn't get this
[[ ${CHOST} == *-darwin* ]] && myeconfargs+=( --without-versioned-libs )
ECONF_SOURCE="${S}" \
econf "${myeconfargs[@]}"
}

pkg_postinst() {
eselect cdparanoia update ifunset
}

pkg_postrm() {
eselect cdparanoia update ifunset
}

0 comments on commit b8753ce

Please sign in to comment.