Skip to content

Commit

Permalink
gnome-extra/evolution-data-server: version bump 3.24.5 → 3.24.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
EvaSDK committed Sep 11, 2017
1 parent 4e3140b commit b8ae31f
Show file tree
Hide file tree
Showing 2 changed files with 148 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/evolution-data-server/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST evolution-data-server-3.22.7.tar.xz 5564924 SHA256 43127fe1f190873c73e13a4cada6cfe47870f1cc962e540a682cca123d959203 SHA512 53648c0b893982b3577008aeae57e213e084aa5ba4663ca109f200b268635fd1544408c1ace065e91e5eaf48a20f59609c8e895a1907501ea5e64119d1590d44 WHIRLPOOL 83b3e667048bda6373c8002a506ea796f8813fd95f88006f634e054038693bbc69f8c436d0310820f1548107a102ccd5a354828691cebf270e6f743c65aa4115
DIST evolution-data-server-3.24.5.tar.xz 4254720 SHA256 6d8ec04b79c02bb517cc3e23ac3b23c7503465dfa27b7415955201a2f62844e1 SHA512 ebe77bb8b1025b07378a32df5a822add11a2ef1e3daf57d8eae14ea05ba479cfe5e8ebf1d8dda585a6f3232d270f212dcfa9cd580fa1488b06a96204775a1c21 WHIRLPOOL dcd9a18cf52b82b087e16e821e32c1274261b619a591dbb9d818e81c104d808801551488d15162f6f7fca4277c24b4e562309520933efedf379daf652c96fc45
DIST evolution-data-server-3.24.6.tar.xz 4252940 SHA256 058040214c9362e5e0f7592455418813da28b533b9ff2d6e2d868c39e580189e SHA512 01eece83217e66ce7e08e333ceaf38bae226800dd8a015dda29583b0155b9f1fbef4f18d95a7127d08421cd27b3203d2b7cc6a3bc0b5adba1b06197c85be96e6 WHIRLPOOL 02dd5fee09134b08f2e3544a914d9b215b268117bb9a96c982f294f41c2eb889825b7e97f50caa4beae717408142a01d8767ae7587516ac784be859985b3cd91
147 changes: 147 additions & 0 deletions gnome-extra/evolution-data-server/evolution-data-server-3.24.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,147 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
VALA_USE_DEPEND="vapigen"

inherit cmake-utils db-use flag-o-matic gnome2 python-any-r1 systemd vala virtualx

DESCRIPTION="Evolution groupware backend"
HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"

# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
SLOT="0/60" # subslot = libcamel-1.2 soname version

IUSE="api-doc-extras berkdb +gnome-online-accounts +gtk google +introspection ipv6 ldap kerberos vala +weather"
REQUIRED_USE="vala? ( introspection )"

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"

# sys-libs/db is only required for migrating from <3.13 versions
# gdata-0.17.7 soft required for new gdata_feed_get_next_page_token API to handle more than 100 google tasks
# berkdb needed only for migrating old calendar data, bug #519512
gdata_depend=">=dev-libs/libgdata-0.17.7:="
RDEPEND="
>=app-crypt/gcr-3.4
>=app-crypt/libsecret-0.5[crypt]
>=dev-db/sqlite-3.7.17:=
>=dev-libs/glib-2.46:2
>=dev-libs/libical-0.43:=
>=dev-libs/libxml2-2
>=dev-libs/nspr-4.4:=
>=dev-libs/nss-3.9:=
>=net-libs/libsoup-2.42:2.4
dev-libs/icu:=
sys-libs/zlib:=
virtual/libiconv
berkdb? ( >=sys-libs/db-4:= )
gtk? (
>=app-crypt/gcr-3.4[gtk]
>=x11-libs/gtk+-3.10:3
)
google? (
>=dev-libs/json-glib-1.0.4
>=net-libs/webkit-gtk-2.11.91:4
${gdata_depend}
)
gnome-online-accounts? (
>=net-libs/gnome-online-accounts-3.8:=
${gdata_depend} )
introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
kerberos? ( virtual/krb5:= )
ldap? ( >=net-nds/openldap-2:= )
weather? ( >=dev-libs/libgweather-3.10:2= )
"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
dev-util/gdbus-codegen
dev-util/gperf
>=dev-util/gtk-doc-am-1.14
>=dev-util/intltool-0.35.5
>=sys-devel/gettext-0.18.3
virtual/pkgconfig
vala? ( $(vala_depend) )
"

# Some tests fail due to missings locales.
# Also, dbus tests are flacky, bugs #397975 #501834
# It looks like a nightmare to disable those for now.
RESTRICT="test"

pkg_setup() {
python-any-r1_pkg_setup
}

src_prepare() {
use vala && vala_src_prepare
gnome2_src_prepare

# Make CMakeLists versioned vala enabled
sed -e "s;\(find_program(VALAC\) valac);\1 ${VALAC});" \
-e "s;\(find_program(VAPIGEN\) vapigen);\1 ${VAPIGEN});" \
-i "${S}"/CMakeLists.txt || die
}

src_configure() {
# /usr/include/db.h is always db-1 on FreeBSD
# so include the right dir in CPPFLAGS
use berkdb && append-cppflags "-I$(db_includedir)"

local google_auth_enable
if use google || use gnome-online-accounts; then
google_auth_enable="ON"
else
google_auth_enable="OFF"
fi

# phonenumber does not exist in tree
local mycmakeargs=(
-DENABLE_GTK_DOC=$(usex api-doc-extras)
-DWITH_PRIVATE_DOCS=$(usex api-doc-extras)
-DENABLE_SCHEMAS_COMPILE=OFF
-DENABLE_INTROSPECTION=$(usex introspection)
-DWITH_KRB5=$(usex kerberos)
-DWITH_KRB5_INCLUDES=$(usex kerberos "${EPREFIX}"/usr "")
-DWITH_KRB5_LIBS=$(usex kerberos "${EPREFIX}"/usr/$(get_libdir) "")
-DWITH_OPENLDAP=$(usex ldap)
-DWITH_PHONENUMBER=OFF
-DENABLE_SMIME=ON
-DENABLE_GTK=$(usex gtk)
-DENABLE_GOOGLE_AUTH=${google_auth_enable}
-DENABLE_EXAMPLES=OFF
-DENABLE_GOA=$(usex gnome-online-accounts)
-DENABLE_UOA=OFF
-DWITH_LIBDB=$(usex berkdb "${EPREFIX}"/usr OFF)
# ENABLE_BACKTRACES requires libdwarf ?
-DENABLE_IPV6=$(usex ipv6)
-DENABLE_WEATHER=$(usex weather)
-DENABLE_GOOGLE=$(usex google)
-DENABLE_LARGEFILE=ON
-DENABLE_VALA_BINDINGS=$(usex vala)
)

cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_test() {
virtx cmake-utils_src_test
}

src_install() {
cmake-utils_src_install

if use ldap; then
insinto /etc/openldap/schema
doins "${FILESDIR}"/calentry.schema
dosym ../../../usr/share/${PN}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
fi
}

0 comments on commit b8ae31f

Please sign in to comment.