Skip to content

Commit

Permalink
dev-php/pecl-stomp: Version bump including php 7.1 support
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Brian Evans committed May 12, 2017
1 parent d1eddac commit b8b3c37
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-stomp/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST stomp-1.0.9.tgz 23166 SHA256 7a7d748c6327ef8c6853dcadaedd41b4366ff821b401b11fab7b915cb5246575 SHA512 e3ab5bfb03c29edde63de4006b448e0204efbac5817b1443ee5b1a0249c2f96d58443847b878e838108b66e5307f6e803f807aff7430af748af4994bfca5199a WHIRLPOOL 0812a75f7e0ee7b8eeb87cbcc29eb68a33035d05aec56432eceb550c1caec3df1dcba683e2bca386a1aae26c3de1878dcfc401ede59f7b9bedb69447cdf63cdf
DIST stomp-2.0.0.tgz 23422 SHA256 7a51195b26e2178bcdacd4ae09023cf50c756964fea85bf3837ab0b2ea7fa727 SHA512 f999762f842f19e920bca35175e65e20173c9ef5162eba3b79a7a2a70a52991c5d39f6d9dd6d9dfa081f1c2fb23e0dae5fa42224dcad4626666e5785076f1a12 WHIRLPOOL d7f5422a45982de5b9baded1c6c0105d631a10ceeda8ef1ea7902ffe0efb95b31e82b461aaaafe8c73795cd2c334d51e3e8eac90873f058d1c8e8cd41e118954
DIST stomp-2.0.1.tgz 23494 SHA256 8ce920612a2611046eefc9d6a1795ffa6cce8fa40ab845f0ef4a59a18e45d342 SHA512 61cfacbd96f1061dc869ede6c1ca0f7bceb6120b28cc4a78fabcbace54a66ba540faf41ef72747b8bcc6a4ef98e405daac04e82bd4e079d90293f030684b04d3 WHIRLPOOL b5691f7e02b178cb3ce16ba1b35f939de4367fe9c6dbb535bd3465b3862d61c9122037de287faa8f0759c0b66670038e6e00580650e68b43eccac27f251e5d00
49 changes: 49 additions & 0 deletions dev-php/pecl-stomp/pecl-stomp-2.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_PHP="php5-6 php7-0 php7-1"
PHP_EXT_NAME="stomp"
DOCS=( CREDITS doc/classes.php doc/functions.php )

inherit php-ext-pecl-r3

USE_PHP="php7-0 php7-1"

KEYWORDS="~amd64 ~x86"

DESCRIPTION="PHP extension to communicate with Stomp message brokers"
LICENSE="PHP-3.01"
SLOT="7"
IUSE="examples ssl test"

DEPEND="${DEPEND}
php_targets_php7-0? ( dev-lang/php:7.0[ssl?] )
php_targets_php7-1? ( dev-lang/php:7.1[ssl?] )
"

RDEPEND="${DEPEND}
php_targets_php5-6? ( dev-php/pecl-stomp:0 )"

src_prepare() {
if use php_targets_php7-0 || use php_targets_php7-1 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
fi
}

src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-stomp
--with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
)
php-ext-source-r3_src_configure
}

src_install() {
if use php_targets_php7-0 || use php_targets_php7-1 ; then
php-ext-pecl-r3_src_install
fi
}

0 comments on commit b8b3c37

Please sign in to comment.