Skip to content

Commit

Permalink
dev-haskell/double-conversion: new package, a depend of esqueleto-3.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Aug 29, 2020
1 parent bedf56d commit b8c2116
Show file tree
Hide file tree
Showing 3 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-haskell/double-conversion/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST double-conversion-2.0.2.0.tar.gz 7023616 BLAKE2B ecdd9ff171a976f48390626eda39a23f3e6b9f3ec204515a9730ebc22bb6a49b40baf77f5c12dc01f47c90225055d5c1199b00e739ef809861bf564d3aaa38df SHA512 1713c4e8a28de2ee85e1f312dc12d30a9c6d7a139d89f04ea88048578ce65c8bdf62ded90b92bce011955b95867ca95a623a5109758276a29ba7b6843fbe37eb
38 changes: 38 additions & 0 deletions dev-haskell/double-conversion/double-conversion-2.0.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

# ebuild generated by hackport 0.5.1.9999
#hackport: flags: -developer

CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal

DESCRIPTION="Fast conversion between double precision floating point and text"
HOMEPAGE="https://github.com/bos/double-conversion"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""

RESTRICT=test # fails to compare 0.0 with 0.0

RDEPEND=">=dev-haskell/text-0.11.0.8:=[profile?]
>=dev-lang/ghc-7.4.1:=
sys-devel/gcc:*[cxx]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
test? ( dev-haskell/hunit
dev-haskell/test-framework
dev-haskell/test-framework-hunit
dev-haskell/test-framework-quickcheck2 )
"

src_configure() {
haskell-cabal_src_configure \
--flag=-developer
}
26 changes: 26 additions & 0 deletions dev-haskell/double-conversion/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Haskell</name>
</maintainer>
<longdescription>
A library that performs fast, accurate conversion between double
precision floating point and text.

This library is implemented as bindings to the C++
@double-conversion@ library written by Florian Loitsch at Google:
&lt;http://code.google.com/p/double-conversion/&gt;.

The 'Text' versions of these functions are about 30 times faster
than the default 'show' implementation for the 'Double' type.

The 'ByteString' versions are /slower/ than the 'Text' versions;
roughly half the speed. (This seems to be due to the cost of
allocating 'ByteString' values via @malloc@.)

As a final note, be aware that the @bytestring-show@ package is
about 50% slower than simply using 'show'.
</longdescription>
</pkgmetadata>

0 comments on commit b8c2116

Please sign in to comment.