Skip to content

Commit

Permalink
games-fps/freedm-data: version bump to 0.12.0
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/697432
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: William Breathitt Gray <[email protected]>
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
vilhelmgray authored and chewi committed Oct 12, 2019
1 parent ff3f5b0 commit b8c2c21
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-fps/freedm-data/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST freedoom-0.11.3.tar.gz 17010131 BLAKE2B a0b601575da8516cf9f83466fe2146b708aa3cb21a3df2f7cbcd018a560f65b9b89c85907115050c4985b64eff29a3a9d2cfb7d31e93043e9d3c35fe7749d749 SHA512 51e0d5f7ca7c846c556fcba36b0f9c815090bfc76a80200aebd1526291da16b71145fbe254100cc5ad37ffc044d4380ef07b8bd4bdb811f00b9150e7b34dd636
DIST freedoom-0.12.0.tar.gz 18409554 BLAKE2B 01ae58c8edb12a8453f6026f09f45d54b19949d38f0668ddc6d4a6ee5fee4cc62c3926af0fb8e30e5f574b46ad1990fb20b57369821562851ae0cef0a6a5e5f1 SHA512 055cae8d16cc7ca2017eeabcaca9436da044def5f630ab46fb0c4cd7d36b9db3b416f9ddeb855e79f21f7c5337d25fb82625ac987712910daec448b49ef9c41e
54 changes: 54 additions & 0 deletions games-fps/freedm-data/freedm-data-0.12.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{5,6,7} )

inherit prefix python-any-r1 xdg

DESCRIPTION="Game resources for FreeDM"
HOMEPAGE="https://freedoom.github.io"
SRC_URI="https://github.com/freedoom/freedoom/archive/v${PV}.tar.gz -> freedoom-${PV}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"

BDEPEND="
$(python_gen_any_dep 'dev-python/pillow[${PYTHON_USEDEP}]')
app-text/asciidoc
games-util/deutex"

S="${WORKDIR}/freedoom-${PV}"

DOOMWADPATH=share/doom

python_check_deps() {
has_version -b "dev-python/pillow[${PYTHON_USEDEP}]"
}

src_prepare() {
xdg_src_prepare
eapply_user

hprefixify dist/freedoom
}

src_compile() {
emake wads/freedm.wad
}

src_install() {
emake install-freedm \
prefix="${ED}/usr/" \
bindir="bin/" \
mandir="share/man/" \
waddir="${DOOMWADPATH}/"
}

pkg_postinst() {
xdg_pkg_postinst

elog "FreeDM WAD file installed into ${EPREFIX}/usr/${DOOMWADPATH} directory."
}

0 comments on commit b8c2c21

Please sign in to comment.