Skip to content

Commit

Permalink
games-rpg/xu4: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Oct 18, 2016
1 parent 41067a7 commit b8d712d
Show file tree
Hide file tree
Showing 5 changed files with 90 additions and 14 deletions.
8 changes: 4 additions & 4 deletions games-rpg/xu4/files/0.9-savegame.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/savegame.c.orig
+++ src/savegame.c
--- a/src/savegame.c.
+++ b/src/savegame.c
@@ -21,23 +21,24 @@
char *partySavFilename() {
char *fname;
Expand Down Expand Up @@ -61,8 +61,8 @@
return fname;
}

--- src/u4.c.orig
+++ src/u4.c
--- a/src/u4.c
+++ b/src/u4.c
@@ -38,6 +38,10 @@
osxInit(argv[0]);
#endif
Expand Down
4 changes: 2 additions & 2 deletions games-rpg/xu4/files/xu4-0.9-ldflags.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/Makefile.common.old
+++ src/Makefile.common
--- a/src/Makefile.common
+++ b/src/Makefile.common
@@ -68,25 +68,25 @@
mkutils:: dumpsavegame$(EXEEXT) lzwenc$(EXEEXT) lzwdec$(EXEEXT) rleenc$(EXEEXT) rledec$(EXEEXT) tlkconv$(EXEEXT)

Expand Down
8 changes: 4 additions & 4 deletions games-rpg/xu4/files/xu4-0.9-warnings.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- u4.orig/src/u4.c
+++ u4/src/u4.c
--- a/src/u4.c
+++ b/src/u4.c
@@ -3,6 +3,8 @@
*/

Expand All @@ -9,8 +9,8 @@
#include <stdlib.h>
#include <stdarg.h>
#include <string.h>
--- u4.orig/u4.desktop
+++ u4/u4.desktop
--- a/u4.desktop
+++ b/u4.desktop
@@ -1,9 +1,8 @@
[Desktop Entry]
-Encoding=UTF-8
Expand Down
8 changes: 4 additions & 4 deletions games-rpg/xu4/files/xu4-0.9-zip.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/unzip.c.orig
+++ src/unzip.c
--- a/src/unzip.c
+++ b/src/unzip.c
@@ -493,7 +493,7 @@
/*
Get Info about the current file in the zipfile, with internal only info
Expand All @@ -9,8 +9,8 @@
unz_file_info *pfile_info,
unz_file_info_internal
*pfile_info_internal,
--- src/unzip.h.orig
+++ src/unzip.h
--- a/src/unzip.h
+++ b/src/unzip.h
@@ -8,7 +8,7 @@
Encryption and multi volume ZipFile (span) are not supported.
Old compressions used by old PKZip 1.x are not supported
Expand Down
76 changes: 76 additions & 0 deletions games-rpg/xu4/xu4-0.9-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils

DESCRIPTION="A remake of the computer game Ultima IV"
HOMEPAGE="http://xu4.sourceforge.net/"
SRC_URI="mirror://sourceforge/xu4/${P}.tar.gz
mirror://sourceforge/xu4/ultima4-1.01.zip
mirror://sourceforge/xu4/u4upgrad.zip"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

RDEPEND="dev-libs/libxml2
media-libs/libsdl[sound,video]
media-libs/sdl-mixer[timidity]"
DEPEND="${RDEPEND}
app-arch/unzip"

S=${WORKDIR}/u4

src_unpack() {
# xu4 will read the data files right out of the zip files
# but we want the docs from the original.
unpack ${P}.tar.gz
cp "${DISTDIR}"/{ultima4-1.01.zip,u4upgrad.zip} . || die
cd "${WORKDIR}" || die
mv ultima4-1.01.zip ultima4.zip || die
mkdir u4-dos || die
cd u4-dos || die
unzip -q ../ultima4.zip || die
}

PATCHES=(
"${FILESDIR}/${P}-ldflags.patch"
"${FILESDIR}/${PV}-savegame.patch"
"${FILESDIR}/${P}-warnings.patch"
"${FILESDIR}/${P}-zip.patch"
)
src_prepare() {
default

sed -i \
-e "s:/usr/local/lib/u4:/usr/$(get_libdir)/u4:" src/u4file.c \
|| die
sed -i \
-e 's:-Wall:$(E_CFLAGS):' src/Makefile \
|| die
}

src_compile() {
emake -C src \
DEBUGCFLAGS= \
E_CFLAGS="${CFLAGS}" \
bindir="/usr/bin" \
datadir="/usr/share" \
libdir="/usr/$(get_libdir)"
}

src_install() {
emake -C src \
DEBUGCFLAGS= \
E_CFLAGS="${CFLAGS}" \
bindir="${D}/usr/bin" \
datadir="${D}/usr/share" \
libdir="${D}/usr/$(get_libdir)" \
install
dodoc AUTHORS README doc/*txt "${WORKDIR}/u4-dos/ULTIMA4/"*TXT
insinto "/usr/$(get_libdir)/u4"
doins "${WORKDIR}/"*zip
}

0 comments on commit b8d712d

Please sign in to comment.