Skip to content

Commit

Permalink
sys-apps/util-linux: version bump to 2.28.1
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Aug 11, 2016
1 parent f02e624 commit b8f0039
Show file tree
Hide file tree
Showing 3 changed files with 186 additions and 6 deletions.
1 change: 1 addition & 0 deletions sys-apps/util-linux/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST util-linux-2.26.2.tar.xz 3863868 SHA256 0e29bda142528a48a0a953c39ff63093651a4809042e1790fbd6aa8663fd9666 SHA512 1cb8e2f32882b3f496d31c250a45cfb61bedb79f7a2802b358c23134d4257fa9bc9cde8888cfa1aaba12109f82b93345c6dc0bec2d11629ffa084f2a4476a91b WHIRLPOOL 699ff057f9930fe53f44090817c64ffe089345e7aba4c836e18cd3d2088881add805640b0e41b8d60bc08e3632be919025417feb9c2ddda454c87821a59122ed
DIST util-linux-2.27.1.tar.xz 3964512 SHA256 0a818fcdede99aec43ffe6ca5b5388bff80d162f2f7bd4541dca94fecb87a290 SHA512 a450a0c2d26a6deaf5e53b8f6bddf59409aefb1f0aaf07393f68a418408fbc62c5da353c8ba53c7cac8ea6e3dddfad59161753d888c31f5ccea445e81accbad8 WHIRLPOOL b0641f013762a667efcb2fabe6e3e09dd09252835d841e25cde506aca3a74876ad34f8130f3227683c7e8f19359205c4014dfcd9055d860ae6e3e54621478639
DIST util-linux-2.28.1.tar.xz 4157892 SHA256 3ece4ea4a34ef786b68f5c415e848390424232abd1ee00f7ee5bddc30657b60f SHA512 58f2fdb1db6cf712dc8ca02550d17735cb0b5892b8151f26f5565cdaa6fe008207457c1d5b7d7c2a5b866ee86f4cf423b22911f63328e0ebd5cad7b197b53213 WHIRLPOOL dba986be51d07f83f84bfe7bd405457ce3045995f4cbc0c4bae08f7399c5ba74590e1bbc8e687094fa171f7405f7dbe5526b738f965acd7ab13dac1d5bcf7ab3
DIST util-linux-2.28.tar.xz 4119560 SHA256 395847e2a18a2c317170f238892751e73a57104565344f8644090c8b091014bb SHA512 a1f911bdfda5985de87105d39501e501a5f9ec0fe6a433e3f2fed9a80e104342bb4a7e0e6dc9b7d677d5429249f05b343cb5370b0ea0e068dc889699d4ec1f8a WHIRLPOOL fad046ca85923be7455e5a56705b2b87e37c1c5979fba162c076d5bb401ca265af0b99aebba06d63f9fa131442cb9b16f7c1cd3b8e9578352c17f4e776a26698
182 changes: 182 additions & 0 deletions sys-apps/util-linux/util-linux-2.28.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,182 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

PYTHON_COMPAT=( python2_7 python3_{3,4,5} )

inherit eutils toolchain-funcs libtool flag-o-matic bash-completion-r1 \
python-single-r1 multilib-minimal systemd

MY_PV=${PV/_/-}
MY_P=${PN}-${MY_PV}

if [[ ${PV} == 9999 ]] ; then
inherit git-2 autotools
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
SRC_URI="mirror://kernel/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz"
fi

DESCRIPTION="Various useful Linux utilities"
HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/"

LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
IUSE="build caps +cramfs fdformat kill ncurses nls pam python +readline selinux slang static-libs +suid systemd test tty-helpers udev unicode"

# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
RDEPEND="caps? ( sys-libs/libcap-ng )
cramfs? ( sys-libs/zlib )
ncurses? ( >=sys-libs/ncurses-5.2-r2:0=[unicode?] )
pam? ( sys-libs/pam )
python? ( ${PYTHON_DEPS} )
readline? ( sys-libs/readline:0 )
selinux? ( >=sys-libs/libselinux-2.2.2-r4[${MULTILIB_USEDEP}] )
slang? ( sys-libs/slang )
!build? ( systemd? ( sys-apps/systemd ) )
udev? ( virtual/libudev:= )"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )
test? ( sys-devel/bc )
virtual/os-headers"
RDEPEND+="
kill? (
!sys-apps/coreutils[kill]
!sys-process/procps[kill]
)
!sys-process/schedutils
!sys-apps/setarch
!<sys-apps/sysvinit-2.88-r7
!sys-block/eject
!<sys-libs/e2fsprogs-libs-1.41.8
!<sys-fs/e2fsprogs-1.41.8
!<app-shells/bash-completion-2.3-r2"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

S=${WORKDIR}/${MY_P}

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
if [[ ${PV} == 9999 ]] ; then
po/update-potfiles
eautoreconf
fi
elibtoolize
}

lfs_fallocate_test() {
# Make sure we can use fallocate with LFS #300307
cat <<-EOF > "${T}"/fallocate.${ABI}.c
#define _GNU_SOURCE
#include <fcntl.h>
main() { return fallocate(0, 0, 0, 0); }
EOF
append-lfs-flags
$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.${ABI}.c -o /dev/null >/dev/null 2>&1 \
|| export ac_cv_func_fallocate=no
rm -f "${T}"/fallocate.${ABI}.c
}

multilib_src_configure() {
lfs_fallocate_test
# The scanf test in a run-time test which fails while cross-compiling.
# Blindly assume a POSIX setup since we require libmount, and libmount
# itself fails when the scanf test fails. #531856
tc-is-cross-compiler && export scanf_cv_alloc_modifier=ms
export ac_cv_header_security_pam_misc_h=$(multilib_native_usex pam) #485486
export ac_cv_header_security_pam_appl_h=$(multilib_native_usex pam) #545042
ECONF_SOURCE=${S} \
econf \
--enable-fs-paths-extra="${EPREFIX}/usr/sbin:${EPREFIX}/bin:${EPREFIX}/usr/bin" \
--docdir='${datarootdir}'/doc/${PF} \
$(multilib_native_use_enable nls) \
--enable-agetty \
--with-bashcompletiondir="$(get_bashcompdir)" \
--enable-bash-completion \
$(multilib_native_use_enable caps setpriv) \
--disable-chfn-chsh \
$(multilib_native_use_enable cramfs) \
$(multilib_native_use_enable fdformat) \
--with-ncurses=$(multilib_native_usex ncurses $(usex unicode auto yes) no) \
$(use_enable kill) \
--disable-login \
$(multilib_native_use_enable tty-helpers mesg) \
--disable-nologin \
--enable-partx \
$(multilib_native_use_with python) \
--enable-raw \
$(multilib_native_use_with readline) \
--enable-rename \
--disable-reset \
--enable-schedutils \
--disable-su \
$(multilib_native_use_enable tty-helpers wall) \
$(multilib_native_use_enable tty-helpers write) \
$(multilib_native_use_enable suid makeinstall-chown) \
$(multilib_native_use_enable suid makeinstall-setuid) \
$(use_with selinux) \
$(multilib_native_use_with slang) \
$(use_enable static-libs static) \
$(multilib_native_use_with systemd) \
--with-systemdsystemunitdir=$(multilib_native_usex systemd "$(systemd_get_unitdir)" "no") \
$(multilib_native_use_with udev) \
$(tc-has-tls || echo --disable-tls)
}

multilib_src_compile() {
if multilib_is_native_abi; then
default
else
# build libraries only
emake -f Makefile -f - mylibs \
<<< 'mylibs: $(usrlib_exec_LTLIBRARIES) $(pkgconfig_DATA)'
fi
}

multilib_src_test() {
multilib_is_native_abi && emake check
}

multilib_src_install() {
if multilib_is_native_abi; then
default
else
emake DESTDIR="${D}" install-usrlib_execLTLIBRARIES \
install-pkgconfigDATA install-uuidincHEADERS \
install-nodist_blkidincHEADERS install-nodist_mountincHEADERS \
install-nodist_smartcolsincHEADERS install-nodist_fdiskincHEADERS
fi

if multilib_is_native_abi; then
# need the libs in /
gen_usr_ldscript -a blkid mount smartcols uuid

use python && python_optimize
fi
}

multilib_src_install_all() {
dodoc AUTHORS NEWS README* Documentation/{TODO,*.txt,releases/*}

# e2fsprogs-libs didnt install .la files, and .pc work fine
prune_libtool_files
}

pkg_postinst() {
if ! use tty-helpers; then
elog "The mesg/wall/write tools have been disabled due to USE=-tty-helpers."
fi

if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "The agetty util now clears the terminal by default. You"
elog "might want to add --noclear to your /etc/inittab lines."
fi
}
9 changes: 3 additions & 6 deletions sys-apps/util-linux/util-linux-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

Expand All @@ -27,6 +26,8 @@ LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
IUSE="build caps +cramfs fdformat kill ncurses nls pam python +readline selinux slang static-libs +suid systemd test tty-helpers udev unicode"

# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
RDEPEND="caps? ( sys-libs/libcap-ng )
cramfs? ( sys-libs/zlib )
ncurses? ( >=sys-libs/ncurses-5.2-r2:0=[unicode?] )
Expand All @@ -36,11 +37,7 @@ RDEPEND="caps? ( sys-libs/libcap-ng )
selinux? ( >=sys-libs/libselinux-2.2.2-r4[${MULTILIB_USEDEP}] )
slang? ( sys-libs/slang )
!build? ( systemd? ( sys-apps/systemd ) )
udev? ( virtual/libudev:= )
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20150406-r2
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
)"
udev? ( virtual/libudev:= )"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )
Expand Down

0 comments on commit b8f0039

Please sign in to comment.