Skip to content

Commit

Permalink
dev-python/python-senlinclient: adding for heat
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
prometheanfire committed Oct 3, 2016
1 parent b7e54ef commit b91ea27
Show file tree
Hide file tree
Showing 3 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/python-senlinclient/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST python-senlinclient-1.0.0.tar.gz 101396 SHA256 eb4fe96425cfc2c8137b97f2ab9071ebea1a2862b334ab1882513379fed12876 SHA512 3e98cc9a238250ca4069289343011d27d9bf6b35e0c8709bbf209b7774ff7b84151533104795fcc21403202cf6c834503685a9994d320a48aa690a854e1570f9 WHIRLPOOL 559b26f5be8ef0e99c63474f79b22e7baa05ca38b804c309fde4459668dbceba022175d8db156fc283af66bb87322ffe31e58cdd39c022d25f1af2e1ae00d497
19 changes: 19 additions & 0 deletions dev-python/python-senlinclient/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Matthew Thode</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Openstack</name>
</maintainer>
<longdescription lang="en">
This is a client for the OpenStack Senlin API.
</longdescription>
<upstream>
<remote-id type="pypi">python-senlinclient</remote-id>
<remote-id type="github">openstack/python-senlinclient</remote-id>
</upstream>
</pkgmetadata>
41 changes: 41 additions & 0 deletions dev-python/python-senlinclient/python-senlinclient-1.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 python3_5 )

inherit distutils-r1

DESCRIPTION="A client for the OpenStack Senlin API"
HOMEPAGE="https://github.com/openstack/python-senlinclient"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"

CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
>=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
<dev-python/prettytable-0.8[${PYTHON_USEDEP}]
>=dev-python/openstacksdk-0.9.4
>=dev-python/osc-lib-1.0.2
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
>=dev-python/python-heatclient-1.4.0
>=dev-python/pyyaml-3.1.0
>=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
"

python_prepare_all() {
# built in...
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}

0 comments on commit b91ea27

Please sign in to comment.