Skip to content

Commit

Permalink
dev-libs/xapian-bindings: version bump 1.2 branch to 1.2.25
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
blueness committed Oct 6, 2017
1 parent 8b4810e commit b99d4e9
Show file tree
Hide file tree
Showing 2 changed files with 204 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/xapian-bindings/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST xapian-bindings-1.2.22.tar.xz 844040 SHA256 b15ca7984980a1d2aedd3378648ef5f3889cb39a047bac1522a8e5d04f0a8557 SHA512 0eec204ebb92f1230b9dbd080ad2b56ea5fa8e6170eb4354556e5790c7a7da7ba4c8475aaf86fb8f10f102a461d91590184271220626315f55c0631e73e122e0 WHIRLPOOL 05ac5b31d73f9de0c101da832ef289f6a505baa68216eba6fa0cf80df1709feef7e42c7b8f4cf9af35f775e8514c6d4b944c2acebffff10bc558a83305a637ce
DIST xapian-bindings-1.2.24.tar.xz 886148 SHA256 0c2a0df0a4616e2bd8e578d372c9bb4684780573abebbd1ac515502177229965 SHA512 aaedac02ec9fb192ef8b45b07bef5584bc60aff7068c2e3fa0008430ed8296a653780cad04176431d81fe014802df333a3090469dce63204923eead15e6bbaef WHIRLPOOL 996b960727a79dbe669ae8139863c3896c6efdbe781177098d00960982b86a43739433c69db32e62b6660dd4751736d859f5d950d26d6b635c310c35d75a8a0f
DIST xapian-bindings-1.2.25.tar.xz 1711860 SHA256 5f07425d6c5fc540fab965cd011bb043e3ee0df7da03a8814d6fc20dc5e9dd0f SHA512 5d27b2ae2722409ea99a1b9e6bf3f5c61ed9195b67121c090f1533340d3b11c546014985d0989a0725b60a07b392b9705bce054495f423bd3a7c99835aa336c7 WHIRLPOOL aa5c5c310bee6d10f75bb0586386982ec9c32af0b9fbffde8f8c12c37d4a306c66bea69f6dd5502aa6ca93d9d288720fef0d8f7ab6bcea235803c2e3c5b3e57e
DIST xapian-bindings-1.4.4.tar.xz 1117140 SHA256 3b323eac41c42750b7dacc9319b1477a7c1b552c95f590127643dee3b44d8a39 SHA512 006e771b3ea654130b4f76f1a1caee576fd5a3fa6317ca44f1e5483671e8c83073ecbde4f3fc7f84c75590eec53acb59701af4cf9bcd72355ed9d53924492b53 WHIRLPOOL 6932654e8fb4feea2de6db9f58273ab1fd253e0a90992377224c94a671979e102992052396fc319a5a3a8b3122d6a12d43a4bcd73e81e9dfc2b1a3b04838beae
203 changes: 203 additions & 0 deletions dev-libs/xapian-bindings/xapian-bindings-1.2.25.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,203 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"

USE_PHP="php5-6"

PHP_EXT_NAME="xapian"
PHP_EXT_INI="yes"
PHP_EXT_OPTIONAL_USE="php"

#mono violates sandbox, we disable it until we figure this out
#inherit java-pkg-opt-2 mono-env php-ext-source-r3 python
inherit java-pkg-opt-2 php-ext-source-r3 python-r1 toolchain-funcs

DESCRIPTION="SWIG and JNI bindings for Xapian"
HOMEPAGE="http://www.xapian.org/"
SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
#IUSE="java lua mono perl php python ruby tcl"
#REQUIRED_USE="|| ( java lua mono perl php python ruby tcl )"
IUSE="java lua perl php python ruby tcl"
REQUIRED_USE="|| ( java lua perl php python ruby tcl ) python? ( ${PYTHON_REQUIRED_USE} )"

COMMONDEPEND="dev-libs/xapian:0/1.2.22
lua? ( dev-lang/lua:0 )
perl? ( dev-lang/perl:= )
python? ( ${PYTHON_DEPS} )
ruby? ( dev-lang/ruby:= )
tcl? ( >=dev-lang/tcl-8.1:0= )"
# mono? ( >=dev-lang/mono-1.0.8 )
DEPEND="${COMMONDEPEND}
virtual/pkgconfig
java? ( >=virtual/jdk-1.3 )"
RDEPEND="${COMMONDEPEND}
java? ( >=virtual/jre-1.3 )"

pkg_setup() {
java-pkg-opt-2_pkg_setup
}

src_unpack() {
default
}

src_prepare() {
java-pkg-opt-2_src_prepare
if use java; then
sed \
-e 's/$(JAVAC)/$(JAVAC) $(JAVACFLAGS)/' \
-i java{/,/org/xapian/errors/,/org/xapian/}Makefile.in || die "sed failed"
fi

if use python; then
sed \
-e 's:\(^pkgpylib_DATA = xapian/__init__.py\).*:\1:' \
-e 's|\(^xapian/__init__.py: modern/xapian.py\)|\1 xapian/_xapian.so|' \
-i python/Makefile.in || die "sed failed"
fi
}

src_configure() {
if use java; then
CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
fi

if use perl; then
export PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
export PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
fi

if use lua; then
export LUA_LIB="$($(tc-getPKG_CONFIG) --variable=INSTALL_CMOD lua)"
fi

econf \
$(use_with java) \
$(use_with lua) \
$(use_with perl) \
$(use_with php) \
$(use_with python) \
$(use_with ruby) \
$(use_with tcl)
# $(use_with mono csharp) \

# PHP and Python bindings are built/tested/installed manually.
sed -e "/SUBDIRS =/s/ php//" -i Makefile || die "sed Makefile"
sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile"
}

src_compile() {
default

if use php; then
local php_slot
for php_slot in $(php_get_slots); do
cp -r php php-${php_slot}
emake -C php-${php_slot} \
PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \
PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \
PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \
PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)"
done
fi

if use python; then
python_copy_sources
# building() {
# emake -C python \
# PYTHON="$(PYTHON)" \
# PYTHON_INC="$(python_get_includedir)" \
# PYTHON_LIB="$(python_get_libdir)" \
# PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
# pkgpylibdir="$(python_get_sitedir)/xapian"
# }
building() {
emake -C python \
PYTHON_INC="$(python_get_includedir)" \
pkgpylibdir="$(python_get_sitedir)/xapian"
VERBOSE="1"
}
python_foreach_impl building
fi
}

src_test() {
default

if use php; then
local php_slot
for php_slot in $(php_get_slots); do
emake -C php-${php_slot} \
PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \
PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \
PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \
PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" \
check
done
fi

if use python; then
testing() {
emake -C python \
PYTHON_INC="$(python_get_includedir)" \
pkgpylibdir="$(python_get_sitedir)/xapian" \
VERBOSE="1" \
check
}
python_foreach_impl testing
fi
}

src_install () {
emake DESTDIR="${D}" install

if use java; then
java-pkg_dojar java/built/xapian_jni.jar
# TODO: make the build system not install this...
java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so"
rm "${D}/${S}/java/built/libxapian_jni.so"
rmdir -p "${D}/${S}/java/built"
rmdir -p "${D}/${S}/java/native"
fi

if use php; then
local php_slot
for php_slot in $(php_get_slots); do
emake DESTDIR="${D}" -C php-${php_slot} \
PHP="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php" \
PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" \
PHP_EXTENSION_DIR="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --extension-dir)" \
PHP_INC="$("${EPREFIX}/usr/$(get_libdir)/${php_slot}/bin/php-config" --includes)" \
install
done

php-ext-source-r3_createinifiles
fi

if use python; then
installation() {
emake -C python \
DESTDIR="${D}" \
PYTHON_INC="$(python_get_includedir)" \
pkgpylibdir="$(python_get_sitedir)/xapian" \
VERBOSE="1" \
install
}
python_foreach_impl installation
fi

# For some USE combinations this directory is not created
if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
fi

dodoc AUTHORS HACKING NEWS TODO README
}

0 comments on commit b99d4e9

Please sign in to comment.