forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-metrics/mysqld_exporter: bump to v0.12.1 snapshot from 2020-06-22
Closes: https://bugs.gentoo.org/730990 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <[email protected]>
- Loading branch information
Showing
2 changed files
with
77 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST mysqld_exporter-0.10.0.tar.gz 971604 BLAKE2B ec077b7b6a15f6173e5cc04e741c51c4d26a214601da8eb1aede49ee325f52bea2140b8e5b3bdbc2a1e527e40c95099dca2a57501d44a26e787cdc330f4aa8b8 SHA512 0a7b0ff537ad59a9b64aa18dfe1d1eb9253b12ae566d5c151555fbd4457b7e65890b6569632b452ae317b3acbfa94c12d96f6fb6e4f982b9b2161fc4747330f5 | ||
DIST mysqld_exporter-0.11.0.tar.gz 1393809 BLAKE2B ac6b04d2ad24f1c083c411f10bbb6724c2458be357ff60e1950aa624955497432295726e7f739dff03aa1ed8290d852a9511e01893f5a2b293e79b3214270578 SHA512 69f39ecc1b17bfcfd3acdad9d92a70c1daf3f0c9690770fa390a818bd29f43a98bfe4856f22b48e9d2d9945ce98ded0ea54c95010755a85ebc3ebfdc353d0c24 | ||
DIST mysqld_exporter-0.12.1_p20200622.tar.gz 1640334 BLAKE2B fa52fd7474af548bc9429026d7c92bc543cff7f2e2f5e17007a52adc647d6d022a4ec9d099376cc469b4fdc8bab285e0e699a1b10938fc6b7a6704dcc1466a50 SHA512 ccac9a718214c9ab82362deeb81949cecaa6c2fc6567ef7e3d099ca2dbf8385cb9c498837e41ad0bcdf5ec2c9d82fd159792245b97e53c182a30917e80a20cf1 |
76 changes: 76 additions & 0 deletions
76
app-metrics/mysqld_exporter/mysqld_exporter-0.12.1_p20200622.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,76 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit go-module | ||
# uncomment the first setting of MY_PV for a normal release | ||
# MY_PV="v${PV/_rc/-rc.}" | ||
# set MY_PV to the full commit hash for a snapshot release | ||
MY_PV=f5d5289f7627016d8b53b0b3fa7615da8a73b56a | ||
MYSQLD_EXPORTER_COMMIT=f5d5289f | ||
|
||
DESCRIPTION="Prometheus exporter for MySQL server metrics" | ||
HOMEPAGE="https://github.com/prometheus/mysqld_exporter" | ||
SRC_URI="https://github.com/prometheus/mysqld_exporter/archive/${MY_PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
BDEPEND="dev-util/promu" | ||
|
||
DEPEND="acct-group/mysqld_exporter | ||
acct-user/mysqld_exporter" | ||
|
||
RDEPEND="${DEPEND}" | ||
|
||
# Comment this for a normal release. | ||
S="${WORKDIR}/${PN}-${MY_PV}" | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed -i -e "s/{{.Revision}}/${MYSQLD_EXPORTER_COMMIT}/" .promu.yml || die | ||
} | ||
|
||
src_compile() { | ||
mkdir -p bin || die | ||
|
||
promu build --prefix bin || die | ||
|
||
# comment this for a normal release. | ||
mv bin/${PN}-${MY_PV} bin/${PN} || die | ||
} | ||
|
||
src_install() { | ||
dobin bin/* | ||
dodoc {README,CHANGELOG,CONTRIBUTING}.md | ||
|
||
keepdir /var/lib/mysqld_exporter /var/log/mysqld_exporter | ||
fowners ${PN}:${PN} /var/lib/mysqld_exporter /var/log/mysqld_exporter | ||
fperms 0770 /var/lib/mysqld_exporter | ||
|
||
newinitd "${FILESDIR}"/${PN}-r1.initd ${PN} | ||
newconfd "${FILESDIR}"/${PN}-r1.confd ${PN} | ||
|
||
insinto /etc/logrotate.d/ | ||
newins "${FILESDIR}"/${PN}.logrotate ${PN} | ||
} | ||
|
||
pkg_postinst() { | ||
if [[ -z "${REPLACING_VERSIONS}" ]]; then | ||
# This is a new installation | ||
elog "Create \"${EROOT%/}/var/lib/mysqld_exporter/.my.cnf\" to read MySQL credentials from file." | ||
else | ||
local _replacing_version= | ||
for _replacing_version in ${REPLACING_VERSIONS}; do | ||
if ! ver_test "${_replacing_version}" -ge "0.11.0"; then | ||
elog "Starting with ${PN}-0.11.0, command-line flags will require double dashes (--)." | ||
elog "You must update your configuration or ${PN} won't start." | ||
|
||
break | ||
fi | ||
done | ||
fi | ||
} |