Skip to content

Commit

Permalink
mail-filter/postgrey: restore 1.37 (modernised)
Browse files Browse the repository at this point in the history
This reverts commit 5db5e8f.
Contains a different form of the whitelist which may be useful
for some people. No real rush to cleanup.

Bug: https://bugs.gentoo.org/811882
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Sep 7, 2021
1 parent 2f0718c commit ba40a98
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-filter/postgrey/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST postgrey-1.37.tar.gz 41815 BLAKE2B dd8a1f62f56a614c25863afde089f1882a1567e3a53a24b1d12b6f23994388caf99059f05775853065143f4f953a6fd964625d5c865993e0e679dd545b848c11 SHA512 369968212ea60539efc0d4a7ae84f7c3ce13f5622e6ee070a0089423ef81ca8f7541ebd20289291d0e6a3aec2ca30dbc9c0d9c0a6f0a686adfadb5d0dd7830ca
DIST postgrey-1.37_p20190625.tar.gz 124667 BLAKE2B ca2caba51a72198e42d6d4d9c5c7590b62c1bd1589d05bfb4096fb4d95ff62ff96976beac8c1b35136a4a6830af936244485ff7dcdcd46d8558a4bef0bbb123a SHA512 f3caf3c7663bd8784701c7e1ad45d1c577edf6fac14591a6983fda25e7f8a875f2501780a8f97ce72e6a324878404e9ac2a003a07ae07ad4debae61fe734b8d4
74 changes: 74 additions & 0 deletions mail-filter/postgrey/postgrey-1.37.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit systemd

DESCRIPTION="Postgrey is a Postfix policy server implementing greylisting"
HOMEPAGE="https://postgrey.schweikert.ch/"
SRC_URI="http://postgrey.schweikert.ch/pub/${P}.tar.gz
http://postgrey.schweikert.ch/pub/old/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ppc64 x86"

DEPEND="
acct-group/postgrey
acct-user/postgrey
"
# TODO: Use db.eclass?
RDEPEND="
${DEPEND}
>=dev-lang/perl-5.6.0
dev-perl/Net-Server
dev-perl/IO-Multiplex
dev-perl/BerkeleyDB
dev-perl/Net-DNS
dev-perl/NetAddr-IP
dev-perl/Net-RBLClient
dev-perl/Parse-Syslog
virtual/perl-Digest-SHA
>=sys-libs/db-4.1
"

src_prepare() {
default

# bug 479400
sed -i 's@#!/usr/bin/perl -T -w@#!/usr/bin/perl -w@' postgrey || die "sed failed"
}

src_install() {
# postgrey data/DB in /var
diropts -m0770 -o ${PN} -g ${PN}
dodir /var/spool/postfix/${PN}
keepdir /var/spool/postfix/${PN}
fowners postgrey:postgrey /var/spool/postfix/${PN}
fperms 0770 /var/spool/postfix/${PN}

# postgrey binary
dosbin ${PN}
dosbin contrib/postgreyreport

# policy-test script
dosbin policy-test

# postgrey data in /etc/postfix
insinto /etc/postfix
insopts -o root -g ${PN} -m 0640
doins postgrey_whitelist_clients postgrey_whitelist_recipients

# documentation
dodoc Changes README README.exim

# init.d + conf.d files
insopts -o root -g root -m 755
newinitd "${FILESDIR}"/${PN}-1.34-r3.rc.new ${PN}

insopts -o root -g root -m 640
newconfd "${FILESDIR}"/${PN}.conf.new ${PN}

systemd_dounit "${FILESDIR}"/postgrey.service
}

0 comments on commit ba40a98

Please sign in to comment.