Skip to content

Commit

Permalink
dev-libs/librdkafka: bump to v1.5.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.8, Repoman-3.0.2
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Oct 20, 2020
1 parent 2d0aafc commit ba8100a
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/librdkafka/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST librdkafka-1.4.4.tar.gz 2734332 BLAKE2B 47c22f00d88d58eb6366e17a8f0ddaee4984bc65f01a627c5d3b8eee019519a2de9a7ae6e2ab2053354a5d72337107b7f515ad65ff205b6838e154b95d9f2331 SHA512 478d17f56efd39b312ea774695bc31d22a83aae3a94913fb0dd07e7f04f3f2a6e3f3610dc7501864dbacbcf4a3207603c6e1d5eebac4e5246ee868cde398021d
DIST librdkafka-1.5.0.tar.gz 2757553 BLAKE2B a9bbcdaa011944e43f9c70e2062199c5f12d1b92e40ba55707520002ed3a909ff13308336703924388625570d88a94d58b24cd19b5d6e9f79acd31dd92d0d7ed SHA512 ccd8dd3e90c9315833610745c28e0ffa60786324c938c7cbbb2ff847d7493d1b72d97adf5e5210bbc87970047cfd7e58a85141534d227187f2f17c492bef4262
DIST librdkafka-1.5.2.tar.gz 2771823 BLAKE2B 61a56d36ba49539eb52f89a0d5b48e0245b1cedd09c40e65063d65208b50bb95aa5f00ce3c050d4203b4720b2ce63a9f1d6eee7100fdf85c50e7a15457a52010 SHA512 6a796c58aef9d91fe85f3815ee523a0dcafad59f33c83e5c20c62d4e4337c21c2d223dd0d6a88f37cf86d14a8e55facfa87c651990e08d9522f7cf78b0d17446
93 changes: 93 additions & 0 deletions dev-libs/librdkafka/librdkafka-1.5.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

PYTHON_COMPAT=( python3_{6..9} )

inherit python-any-r1 toolchain-funcs

DESCRIPTION="Apache Kafka C/C++ client library"
HOMEPAGE="https://github.com/edenhill/librdkafka"

if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/edenhill/${PN}.git"

inherit git-r3
else
SRC_URI="https://github.com/edenhill/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
fi

LICENSE="BSD-2"

# subslot = soname version
SLOT="0/1"

IUSE="lz4 sasl ssl static-libs zstd"

LIB_DEPEND="
lz4? ( app-arch/lz4:=[static-libs(+)] )
sasl? ( dev-libs/cyrus-sasl:=[static-libs(+)] )
ssl? ( dev-libs/openssl:0=[static-libs(+)] )
zstd? ( app-arch/zstd:=[static-libs(+)] )
sys-libs/zlib:=[static-libs(+)]
"

BDEPEND="
virtual/pkgconfig
${PYTHON_DEPS}
"

RDEPEND="!static-libs? ( ${LIB_DEPEND//\[static-libs(+)]} )"

DEPEND="
${RDEPEND}
static-libs? ( ${LIB_DEPEND} )
"

pkg_setup() {
python-any-r1_pkg_setup
}

src_prepare() {
default

if [[ ${PV} != "9999" ]]; then
sed -i \
-e "s/^\(export RDKAFKA_GITVER=\).*/\1\"${PV}@release\"/" \
tests/run-test.sh || die
fi
}

src_configure() {
tc-export AR CC CXX LD NM OBJDUMP PKG_CONFIG STRIP

local myeconf=(
--no-cache
--no-download
--disable-debug-symbols
$(use_enable lz4)
$(use_enable sasl)
$(usex static-libs '--enable-static' '')
$(use_enable ssl)
$(use_enable zstd)
)

econf ${myeconf[@]}
}

src_test() {
emake -C tests run_local
}

src_install() {
emake -j1 \
DESTDIR="${D}" \
docdir="/usr/share/doc/${PF}" \
install

if ! use static-libs; then
find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
fi
}

0 comments on commit ba8100a

Please sign in to comment.