Skip to content

Commit

Permalink
media-tv/plex-media-server: version bump to 1.9.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.11, Repoman-2.3.3
  • Loading branch information
Jonathan Vasquez committed Oct 10, 2017
1 parent cc82f8c commit ba8354a
Show file tree
Hide file tree
Showing 2 changed files with 136 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-tv/plex-media-server/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST plexmediaserver_1.8.1.4139-c789b3fbb_amd64.deb 107251412 SHA256 30b907c94d5b76991831fd3555e4447724683c4e01617a71d39bfe5be11af126 SHA512 17b6de15920013e74f0a634f004b9b599bebd266412f694963967c766e8879b54485a9b07178a575d246c6bc53b202e38da89e293fd7219d0cf993bf9e27afec WHIRLPOOL c907c627a8e693b5b029958e87b01b8c27e3f40ec6ddc04d9b95e67570260ac344bfad9aa35dfdd2ec13f492f7fed3817373c713b5163b7f9c22db1970b8091f
DIST plexmediaserver_1.9.2.4285-9f65b88ae_amd64.deb 107651788 SHA256 b6d79e40ca8e44c56a5900d41519efd6e5fbc0e194a77400922418887abe31b6 SHA512 7703ccd91b97952f7db3ca58fb207702c1d10e0d9f7c8df82f42e4f876eb72b41f0ccdefd6aad02ad64b605e914809ff08c2982e10db0af2aa454d0a8069da5c WHIRLPOOL ab5d98ba417613d49c23543863c412897332a456790e1e27817f647cba43222f90e1d4d2a2fe2daf6d178005f788614e3e960cc7f0098f949045a9fa66c8c855
135 changes: 135 additions & 0 deletions media-tv/plex-media-server/plex-media-server-1.9.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,135 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )
inherit eutils user systemd unpacker pax-utils python-single-r1

MINOR_VERSION="4285-9f65b88ae"

_APPNAME="plexmediaserver"
_USERNAME="plex"
_SHORTNAME="${_USERNAME}"
_FULL_VERSION="${PV}.${MINOR_VERSION}"

URI="https://downloads.plex.tv/plex-media-server"

DESCRIPTION="A free media library that is intended for use with a plex client."
HOMEPAGE="http://www.plex.tv/"
SRC_URI="amd64? ( ${URI}/${_FULL_VERSION}/plexmediaserver_${_FULL_VERSION}_amd64.deb )"
SLOT="0"
LICENSE="Plex"
RESTRICT="bindist strip"
KEYWORDS="-* ~amd64"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

DEPEND="
sys-apps/fix-gnustack
dev-python/virtualenv[${PYTHON_USEDEP}]"

RDEPEND="
net-dns/avahi
${PYTHON_DEPS}"

QA_DESKTOP_FILE="usr/share/applications/plexmediamanager.desktop"
QA_PREBUILT="*"
QA_MULTILIB_PATHS=(
"usr/lib/${_APPNAME}/.*"
"usr/lib/${_APPNAME}/Resources/Python/lib/python2.7/.*"
)

EXECSTACKED_BINS=( "${ED%/}/usr/lib/plexmediaserver/libgnsdk_dsp.so*" )
BINS_TO_PAX_MARK=( "${ED%/}/usr/lib/plexmediaserver/Plex Script Host" )

S="${WORKDIR}"
PATCHES=( "${FILESDIR}/virtualenv_start_pms.patch" )

pkg_setup() {
enewgroup ${_USERNAME}
enewuser ${_USERNAME} -1 /bin/bash /var/lib/${_APPNAME} "${_USERNAME},video"
python-single-r1_pkg_setup
}

src_unpack() {
unpack_deb ${A}
}

src_install() {
# Move the config to the correct place
local CONFIG_VANILLA="/etc/default/plexmediaserver"
local CONFIG_PATH="/etc/${_SHORTNAME}"
dodir "${CONFIG_PATH}"
insinto "${CONFIG_PATH}"
doins "${CONFIG_VANILLA#/}"
sed -e "s#${CONFIG_VANILLA}#${CONFIG_PATH}/${_APPNAME}#g" -i "${S}"/usr/sbin/start_pms || die

# Remove Debian specific files
rm -rf "usr/share/doc" || die

# Copy main files over to image and preserve permissions so it is portable
cp -rp usr/ "${ED}" || die

# Make sure the logging directory is created
local LOGGING_DIR="/var/log/pms"
dodir "${LOGGING_DIR}"
chown "${_USERNAME}":"${_USERNAME}" "${ED%/}/${LOGGING_DIR}" || die

# Create default library folder with correct permissions
local DEFAULT_LIBRARY_DIR="/var/lib/${_APPNAME}"
dodir "${DEFAULT_LIBRARY_DIR}"
chown "${_USERNAME}":"${_USERNAME}" "${ED%/}/${DEFAULT_LIBRARY_DIR}" || die

# Install the OpenRC init/conf files
doinitd "${FILESDIR}/init.d/${PN}"
doconfd "${FILESDIR}/conf.d/${PN}"

_handle_multilib

# Install systemd service file
local INIT_NAME="${PN}.service"
local INIT="${FILESDIR}/systemd/${INIT_NAME}"
systemd_newunit "${INIT}" "${INIT_NAME}"

_remove_execstack_markings
_add_pax_markings

einfo "Configuring virtualenv"
virtualenv -v --no-pip --no-setuptools --no-wheel "${ED}"usr/lib/plexmediaserver/Resources/Python || die
pushd "${ED}"usr/lib/plexmediaserver/Resources/Python &>/dev/null || die
find . -type f -exec sed -i -e "s#${D}##g" {} + || die
popd &>/dev/null || die
}

pkg_postinst() {
einfo ""
elog "Plex Media Server is now installed. Please check the configuration file in /etc/${_SHORTNAME}/${_APPNAME} to verify the default settings."
elog "To start the Plex Server, run 'rc-config start plex-media-server', you will then be able to access your library at http://<ip>:32400/web/"
}

# Finds out where the library directory is for this system
# and handles ldflags as to not break library dependencies
# during rebuilds.
_handle_multilib() {
# Prevent revdep-rebuild, @preserved-rebuild breakage
cat > "${T}"/66plex <<-EOF || die
LDPATH="${EPREFIX}/usr/$(get_libdir)/plexmediaserver"
EOF

doenvd "${T}"/66plex
}

# Remove execstack flags from some libraries/executables so that it works in hardened setups.
_remove_execstack_markings() {
for f in "${EXECSTACKED_BINS[@]}"; do
# Unquoting 'f' so that expansion works.
fix-gnustack -f ${f} > /dev/null
done
}

# Add pax markings to some binaries so that they work on hardened setup.
_add_pax_markings() {
for f in "${BINS_TO_PAX_MARK[@]}"; do
pax-mark m "${f}"
done
}

0 comments on commit ba8354a

Please sign in to comment.