Skip to content

Commit

Permalink
media-gfx/graphviz: fix dotty meny calls
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/682524
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Mikle Kolyada <[email protected]>
  • Loading branch information
Zlogene committed Jun 18, 2020
1 parent 3c89fad commit baa88e6
Show file tree
Hide file tree
Showing 3 changed files with 26 additions and 2 deletions.
22 changes: 22 additions & 0 deletions media-gfx/graphviz/files/dotty_change_button.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
diff --git a/cmd/dotty/dotty_ui.lefty b/cmd/dotty/dotty_ui.lefty
index a8c9116..a708c61 100644
--- a/cmd/dotty/dotty_ui.lefty
+++ b/cmd/dotty/dotty_ui.lefty
@@ -342,7 +342,7 @@ dotty.protovt.normal.uifuncs = [
else
gt.insertedge (gt, data.pobj, null, data.obj, null, null, 1);
};
- 'rightdown' = function (data) {
+ 'rightup' = function (data) {
local vt, gt, menu, i;

vt = dotty.views[data.widget];
@@ -447,7 +447,7 @@ dotty.protovt.birdseye.uifuncs = [
'middledown' = dotty.protovt.normal.uifuncs.middledown;
'middlemove' = dotty.protovt.normal.uifuncs.middlemove;
'middleup' = dotty.protovt.normal.uifuncs.middleup;
- 'rightdown' = dotty.protovt.normal.uifuncs.rightdown;
+ 'rightup' = dotty.protovt.normal.uifuncs.rightup;
'keyup' = dotty.protovt.normal.uifuncs.keyup;
'redraw' = dotty.protovt.normal.uifuncs.redraw;
'closeview' = dotty.protovt.normal.uifuncs.closeview;
3 changes: 2 additions & 1 deletion media-gfx/graphviz/graphviz-2.42.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -143,7 +143,8 @@ DEPEND="${RDEPEND}
# sci-libs/gts, x11-libs/gtk. Also needs 'gtk','glade','glut','gts' and 'png'
# with flags enabled at configure time

PATCHES=( "${FILESDIR}"/${PN}-2.34.0-Xaw-configure.patch )
PATCHES=( "${FILESDIR}"/${PN}-2.34.0-Xaw-configure.patch
"${FILESDIR}"/dotty_change_button.patch )

pkg_setup() {
use python && python-single-r1_pkg_setup
Expand Down
3 changes: 2 additions & 1 deletion media-gfx/graphviz/graphviz-2.44.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -143,7 +143,8 @@ DEPEND="${RDEPEND}
# sci-libs/gts, x11-libs/gtk. Also needs 'gtk','glade','glut','gts' and 'png'
# with flags enabled at configure time

PATCHES=( "${FILESDIR}"/${PN}-2.34.0-Xaw-configure.patch )
PATCHES=( "${FILESDIR}"/${PN}-2.34.0-Xaw-configure.patch
"${FILESDIR}"/dotty_change_button.patch )

pkg_setup() {
use python && python-single-r1_pkg_setup
Expand Down

0 comments on commit baa88e6

Please sign in to comment.