Skip to content

Commit

Permalink
dev-python/astroid: version bump to 1.5.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
zmedico committed Jun 23, 2017
1 parent 53a9154 commit bad9289
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/astroid/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST astroid-1.3.8.tar.gz 155302 SHA256 3971c35c675dc7acfceb636eb1758b7df9fc3ad7
DIST astroid-1.4.8.tar.gz 184091 SHA256 5f064785a7e45ed519285f2eb30b795e58a4932a0736b32030da6fef3394ddb3 SHA512 54bb20edf5518b417470a2d63210802b267fe727f9d30e1ac5000db00a7894739b1c4249468fb55df81b55d382f3a5bbe019876141f7ee4d94040fd699dc0c2c WHIRLPOOL 1d1d4ea2c14057a42023d776cc65e50c965f20cc0b37ad62fbf77446a8bba07669b5a3aae92c9987c232e9a639fe330d0a0dd05980c030a531dbda3040de0c48
DIST astroid-1.4.9.tar.gz 189315 SHA256 a483e7891ce3a06dadfc6cb9095b0938aca58940d43576d72e4502b480c085d7 SHA512 9091afbeffeae3f10a5f4b0dfb476ed5515661744508dde159bb3faa4af032c6359f4544cc3766a6613974f7725e6f8e28bad45bc68e3282764def019a233303 WHIRLPOOL 296973dbbf853766e424a5bd5f5ac7a1eae29f2e4d28efe75eeb4751e4265038c425f20fb186a5038c53b33c862a6610605af673706e0c62e871450b33872b00
DIST astroid-1.5.2.tar.gz 240007 SHA256 271f1c9ad6519a5dde2a7f0c9b62c2923b55e16569bdd888f9f9055cc5be37ed SHA512 e8e4facc34f7a5ca1128961c3134d3adb0e59437aa38ef567bfe777b94215fedc32ae524135c6d376a3bc648c851d59315f4caadac684d7576e582e5d9e3b2fe WHIRLPOOL 084cfcd38379df10193bcf32ddb2b70737a10f058847f02c9b26bb6971d32bba2a031bb2f26a09fc52748bca84f525381c56168edc03220d9fba588c7213d111
DIST astroid-1.5.3.tar.gz 240617 SHA256 492c2a2044adbf6a84a671b7522e9295ad2f6a7c781b899014308db25312dd35 SHA512 2a224d9bf8e41059a1316d80738cdc0f1e4c4e0f987baf3969710bae7192466b708c7942cd7e4eeccea55582ce70bb687c96b9e7dece3229ae4cffc558aa2319 WHIRLPOOL e1843a668b6a13bbbd9428c1e0b7399d7fa0ce79496edd7ee490f465930703e25c6a814eb8bf500833de2306c0e3a19162bd675ec01c546e33e3827557f1af68
51 changes: 51 additions & 0 deletions dev-python/astroid/astroid-1.5.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )

inherit distutils-r1

DESCRIPTION="Abstract Syntax Tree for logilab packages"
HOMEPAGE="https://bitbucket.org/logilab/astroid https://pypi.python.org/pypi/astroid"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x64-macos ~x86-macos"
IUSE="test"

# Version specified in __pkginfo__.py.
RDEPEND="
dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/wrapt[${PYTHON_USEDEP}]
virtual/python-enum34[${PYTHON_USEDEP}]
virtual/python-singledispatch[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' -2)"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' 'python*')
>=dev-python/pylint-1.6.0[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
)"

python_prepare_all() {
# Disable failing tests
# TODO: investigate if it's our fault and how can we fix it
sed -i -e "s/test_namespace_package_pth_support/_&/" \
astroid/tests/unittest_manager.py || die
# we hack xml module, so it does not match what they expect...
sed -i -e "s/test_module_model/_&/" \
astroid/tests/unittest_object_model.py || die
distutils-r1_python_prepare_all
}

python_test() {
${EPYTHON} -m unittest discover -p "unittest*.py" --verbose || die
}

0 comments on commit bad9289

Please sign in to comment.