Skip to content

Commit

Permalink
app-vim/vim-latex: version bump to 1.9.0
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Oct 8, 2017
1 parent 797b03f commit bae4fc2
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-vim/vim-latex/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST vim-latex-1.8.23-20130116.788-git2ef9956.tar.gz 287749 SHA256 99f47151d5108901f85c793496a301341fe6be66b39bd5b42ea7db2e0afd426c SHA512 27cbea24ef5cf8c5ef6c2a9790bd1745d7d907640dd47dd199e579b8e04c33e30b1907f89e9898f8197e46f002ce4145e5c63635801ca8729d4ad988aaa7b590 WHIRLPOOL 74d11d665568ff4afaa40e3208764919e32c9f899ba3e993ed4e4d0049c9f067c2446e2abdecdf3b598ec89c9d4187f24f9ca04a654ecbaa4dc2cfdcc0e06975
DIST vim-latex-1.8.23-20141116.812-gitd0f31c9.tar.gz 288376 SHA256 b3f8c395ae4d012bc6597e3beb22568c84554195bcba3cd3edc6c84270458eab SHA512 18444b7aef9ca1d7288e2616c0329274172afa3f932096fddc5e40888f65c8cacae2454ab316c5699395268aa88af13b32f3ae6e36058e27e4e48e6d6591b762 WHIRLPOOL f5a133483fd3f8ce33c82baa82fb6632942baa9d919814516904994c848264ec08d89cac299592d9fd741282a4644f63c2ca46ce5e8296c4dd64bf36d46a46f7
DIST vim-latex-1.9.0.tar.gz 289271 SHA256 1fe71b034eb72061380ba3f35dde3e4f6095e8584827ce78bf745a546b6f46ee SHA512 4cce21683af74a5a1034e5ecc0f6268b5065324908671d40b4d6b60ac880890df1e9c3d6c16fa57dd1edc33766ded374fd43473699a974ba83e4aeac42030e63 WHIRLPOOL 259920a04e27c780e0857b30a17f6311b358fe89d38fad3786d7ad958a88ce59cbc3d1dacd7f11b89aa32bd02d46e1b9438120f8e5fe073a44011bbe153233b9
64 changes: 64 additions & 0 deletions app-vim/vim-latex/vim-latex-1.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 )

inherit vim-plugin python-single-r1

DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
HOMEPAGE="http://vim-latex.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"

LICENSE="vim"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
${PYTHON_DEPS}
|| (
app-editors/vim[python,${PYTHON_USEDEP}]
app-editors/gvim[python,${PYTHON_USEDEP}]
)
virtual/latex-base
!app-vim/vimtex"

VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"

src_compile() { :; }

src_install() {
# remove unused metadata
rm vim-latex.metainfo.xml || die

# don't mess up vim's doc dir with random files
mv doc mydoc || die
mkdir doc || die
mv mydoc/*.txt doc/ || die
rm -rf mydoc || die

# don't install buggy tags scripts, use ctags instead
rm latextags ltags || die

vim-plugin_src_install

# use executable permissions (bug #352403)
fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py

python_fix_shebang "${ED}"
}

pkg_postinst() {
vim-plugin_pkg_postinst

if [[ -z ${REPLACING_VERSIONS} ]]; then
echo
elog "To use the vim-latex plugin add:"
elog " filetype plugin on"
elog ' set grepprg=grep\ -nH\ $*'
elog " let g:tex_flavor='latex'"
elog "to your ~/.vimrc-file"
echo
fi
}

0 comments on commit bae4fc2

Please sign in to comment.