Skip to content

Commit

Permalink
games-emulation/cega-jg: add 0.6.0
Browse files Browse the repository at this point in the history
Signed-off-by: orbea <[email protected]>
Closes: gentoo#30615
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
orbea authored and thesamesam committed Apr 16, 2023
1 parent b31a082 commit bae6887
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/cega-jg/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cega-0.5.2.tar.bz2 221146 BLAKE2B eba8dcee12ebc2c4f290b7c4546e110bd4d154e3a2d9572fe8a0141c435e45fcd270085882754bf46e0a26388c8b92c5ac390c52b0be3a56a08122acd98d052b SHA512 e2177079a984e531480572e3552d3e52cc14ee2f55ba5d7836becda1c893c9721a637c3e89e992a0fe4039471b41c718f92c53b74f7165690cbc2e709623d7cb
DIST cega-0.6.0.tar.bz2 224108 BLAKE2B 0ecbdcc05c4d7de405e78723117a5c09f7d26a39355a25e516a68c6473ee403cab55d7d12e57e3382db6730a406d7b639153ebcb6a6b038bf661af0eb08cfa72 SHA512 64d05bdc9dbc123400a2bd718e2e6b65edb87eaed7ef7915ce5bc9b86ce5ed9a801ffb9192103ac08a58a9c06193d7588dbe47b78143edb90a89139cf75cdc68
46 changes: 46 additions & 0 deletions games-emulation/cega-jg/cega-jg-0.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

MY_PN=${PN%-*}
MY_P=${MY_PN}-${PV}
DESCRIPTION="Jolly Good SG-1000, SMS, and Game Gear Emulator"
HOMEPAGE="https://gitlab.com/jgemu/cega"
if [[ "${PV}" == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
else
SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64"
fi

LICENSE="BSD MIT MPL-2.0 ZLIB"
SLOT="1"

DEPEND="
media-libs/jg:1=
media-libs/speexdsp
"
RDEPEND="
${DEPEND}
games-emulation/jgrf
"
BDEPEND="
virtual/pkgconfig
"

src_compile() {
emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
}

src_install() {
emake install \
DESTDIR="${D}" \
PREFIX="${EPREFIX}"/usr \
DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
LIBDIR="${EPREFIX}/usr/$(get_libdir)"
}

0 comments on commit bae6887

Please sign in to comment.