forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-apps/pick: fix building against ncurses with split out libtinfo
Closes: https://bugs.gentoo.org/630864
- Loading branch information
Showing
2 changed files
with
31 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
Use pkg-config to determine ncurses libs and cflags to use. Fixes when building | ||
against ncurses with libtinfo split out. | ||
|
||
--- pick-1.8.0/configure.ac | ||
+++ pick-1.8.0/configure.ac | ||
@@ -5,13 +5,10 @@ | ||
AC_PROG_CC | ||
AM_PROG_CC_C_O | ||
AC_CHECK_FUNCS([pledge reallocarray strtonum]) | ||
-AC_SEARCH_LIBS([setupterm], [curses], [], | ||
- [ | ||
- AC_SEARCH_LIBS([setupterm], [ncursesw], | ||
- [AC_DEFINE([HAVE_NCURSESW_H], [1], [Define if ncursesw is available])], | ||
- [AC_MSG_ERROR([unable to find setupterm function])] | ||
- ) | ||
- ] | ||
-) | ||
+PKG_CHECK_MODULES([NCURSES], [ncursesw], | ||
+ [AC_DEFINE([HAVE_NCURSESW_H], [1], [Define if ncursesw is available])], | ||
+ [PKG_CHECK_MODULES([NCURSES], [ncurses])]) | ||
+CFLAGS="$CFLAGS $NCURSES_CFLAGS" | ||
+LIBS="$LIBS $NCURSES_LIBS" | ||
AC_CONFIG_FILES([Makefile]) | ||
AC_OUTPUT |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters