Skip to content

Commit

Permalink
x11-terms/gnome-terminal: bump to 3.18.3
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
RemiCardona committed Mar 7, 2016
1 parent 095fc2c commit baf179d
Show file tree
Hide file tree
Showing 2 changed files with 80 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-terms/gnome-terminal/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gnome-terminal-3.16.2.tar.xz 1798620 SHA256 9df7bab7bfd15ca9a3c60612e425baaf5c8b32ba181619f740b7129a0768f4e0 SHA512 06327569de64ec9d1a045ea191edaabfe80e62dc55b5b8722d36e9d419f8d0cdfda29503f4aec68ae61798d77269ad902864eee8609369da31315368a9ab254f WHIRLPOOL 559833e2080c784080e001260a732fa480f187d17a8d1d069253175b9afd053d4fbd1d7a557442c467b915d31432e50bb4f0f9a94699fb3ed95810fb5f32b56e
DIST gnome-terminal-3.18.2.tar.xz 1836144 SHA256 5e35c0fa1395258bab83952cfabe4c1828b8655bcd761f8faed70b452bd89efa SHA512 9fb3e15d90990e1c066a71a34657845a3a3531dcda928f5a61477528df3bd65125fcf28dfd278535e844ebf57fae738451cb5e6f0118bb75bedb98e92624ad41 WHIRLPOOL b8bfc15e37d7bc959057d0beff227f4724f046d3777f4e9111fae469891e37dce8bb6c296191822f55458b06b62dd84ba213b6345ff189861b0ddeddf2b3d14f
DIST gnome-terminal-3.18.3.tar.xz 1845452 SHA256 14c2fce1c6a80a3fb0cc8666d7752228adcb60d199634ab69150de32e3c17d56 SHA512 3375038f69f3dbe2dee49c0835dd7ed8bd787e5a9ca59a905b737d6482d9a0ba27e4d98558b37bcb5561d143dfa8bed5613d4f9a46ae3a420e5a80803a88f756 WHIRLPOOL 04e0fdc12d18b14cfe41c50a43ca2a1d2107be2d23b17fc88189964e002b24ce812c0ec0a247c6eb8ade4bef89e537f475e7a318b26e4cbcb0f89a0fab4bdf52
79 changes: 79 additions & 0 deletions x11-terms/gnome-terminal/gnome-terminal-3.18.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"

inherit autotools eutils gnome2 readme.gentoo

DESCRIPTION="The Gnome Terminal"
HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"

LICENSE="GPL-3+"
SLOT="0"
IUSE="debug +gnome-shell +nautilus vanilla"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"

# FIXME: automagic dependency on gtk+[X]
RDEPEND="
>=dev-libs/glib-2.42:2[dbus]
>=x11-libs/gtk+-3.10:3[X]
>=x11-libs/vte-0.42.1:2.91
>=gnome-base/dconf-0.14
>=gnome-base/gsettings-desktop-schemas-0.1.0
sys-apps/util-linux
x11-libs/libSM
x11-libs/libICE
gnome-shell? ( gnome-base/gnome-shell )
nautilus? ( >=gnome-base/nautilus-3 )
"
# itstool required for help/* with non-en LINGUAS, see bug #549358
# xmllint required for glib-compile-resources, see bug #549304
DEPEND="${RDEPEND}
app-text/yelp-tools
dev-libs/libxml2
dev-util/desktop-file-utils
dev-util/gdbus-codegen
dev-util/itstool
>=dev-util/intltool-0.50
sys-devel/gettext
virtual/pkgconfig
"

DOC_CONTENTS="To get previous working directory inherited in new opened
tab you will need to add the following line to your ~/.bashrc:\n
. /etc/profile.d/vte.sh"

src_prepare() {
if ! use vanilla; then
# OpenSuSE patches, https://bugzilla.gnome.org/show_bug.cgi?id=695371
epatch "${FILESDIR}"/${PN}-3.18.2-transparency.patch
epatch "${FILESDIR}"/${PN}-3.18.2-transparency-fix-for-broken-themes.patch
epatch "${FILESDIR}"/${PN}-3.18.2-dark-theme.patch
eautoreconf
fi
gnome2_src_prepare
}

src_configure() {
gnome2_src_configure \
--disable-static \
--disable-migration \
$(use_enable debug) \
$(use_enable gnome-shell search-provider) \
$(use_with nautilus nautilus-extension) \
VALAC=$(type -P true)
}

src_install() {
DOCS="AUTHORS ChangeLog HACKING NEWS"
gnome2_src_install
readme.gentoo_create_doc
}

pkg_postinst() {
gnome2_pkg_postinst
readme.gentoo_print_elog
}

0 comments on commit baf179d

Please sign in to comment.