forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-editors/kakoune: bump to 2021.11.08
Signed-off-by: Ian Hixson <[email protected]> Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
Showing
2 changed files
with
41 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kakoune-2021.10.28.tar.bz2 537860 BLAKE2B b7a5bf27505af99e40b65eef1e6c34c2c7fb43b9e0a1b0be5f307cf658f830646f5289bb52c70456e2ba585247528df829de3825edffc40f525b218b0237396c SHA512 60adf3d56006b5fde0b0acd8990501a858df6ed850201b603e2722fc893a873f2bb74f4be9caa35b6aa088ba7cd7aef86c0ca952168de92557c03b208461e0d2 | ||
DIST kakoune-2021.11.08.tar.bz2 538466 BLAKE2B 30cb80c971c065610a8b40d9df0af2d3c1650baa065f14c22557b3c22e3cd2832e227a3a167d10d3892579eee30a70b5e3b62ad502dac7bdbb1c252b71c66e99 SHA512 429e11ff51fce18394e0a8fc55cd58a346b91dbe41b842b96c31a984bc92ea67b186c9f819d2d3ee88422ba453347281b0416a5bc4b1e7816240b9aba688a7e5 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 2020-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit toolchain-funcs | ||
|
||
DESCRIPTION="Modal editor inspired by vim" | ||
HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune" | ||
SRC_URI="https://github.com/mawww/kakoune/releases/download/v${PV}/${P}.tar.bz2" | ||
|
||
LICENSE="Unlicense" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86" | ||
|
||
BDEPEND="virtual/pkgconfig" | ||
|
||
src_prepare() { | ||
sed -i '/CXXFLAGS += -O3/d' src/Makefile || die | ||
default | ||
} | ||
|
||
src_configure() { | ||
tc-export CXX | ||
} | ||
|
||
src_compile() { | ||
emake -C src all | ||
} | ||
|
||
src_test() { | ||
emake -C src test | ||
} | ||
|
||
src_install() { | ||
emake PREFIX="${D}"/usr docdir="${ED}/usr/share/doc/${PF}" install | ||
|
||
rm "${ED}/usr/share/man/man1/kak.1.gz" || die | ||
doman doc/kak.1 | ||
} |