Skip to content

Commit

Permalink
app-office/taskcoach: 1.4.2 (bug #522420)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
hartwork committed Jan 10, 2016
1 parent 181a140 commit bafda41
Show file tree
Hide file tree
Showing 3 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/taskcoach/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST TaskCoach-1.3.27.tar.gz 2750875 SHA256 37b7b5f94aef590593e7f5db0b8ea28b45aa
DIST TaskCoach-1.3.29.tar.gz 2759329 SHA256 77deaee656a43fd2b5772a77adee1c58d75fb8f3b62047823c06963393a7c036 SHA512 e7a796556be51db3c6342199f9141b3e52a8af7a99275d92c69decbae78e7960455b565e671110e3d27e9f413e6bac6c3b75cfde782b438d76a1ba94c392a802 WHIRLPOOL 3339e89a94ef2f14010fe026febc2ce87295371227c760ae7507f6ccf372f71f233cf181abdf696a72b15b4f502e0095819d89f64e6786cb7ae6c6af5d290a71
DIST TaskCoach-1.3.32.tar.gz 2789269 SHA256 cf6dbc09eb62aa2c5540ea464ba47bc3f0841b0c7e8d2b63a710929ac9fe4a52 SHA512 4d8addafad65aaf209d0b1611f71d4555ddfe839f073d51bed29b6cdc9fb3b87d3a386b39a5a5800844b6c4e9654adf882c0403c7183a8d80760b1c297f0e0f5 WHIRLPOOL bf03242878dd46fc80d6b0f2ecbbd2188b18879872f769edd35a777104b143cdbd258d13a4264a873ac093916f0bb5f0015a57e968ed772ba136d72ef1931bd3
DIST TaskCoach-1.3.40.tar.gz 2826741 SHA256 564284c47b6900e863eff08a84498fc0c366789dbdeab2de7f9bdaaabb36ab32 SHA512 54a9eed8c568b61a5ce6e61c02782f804d18f10fab73be658217ee8c225e355155e5e36877e84b97b48004995eafd1faa79d1e64bd30d738cb782a34387041be WHIRLPOOL eeed80c3358a88c724668f9e95ac89a0b12018577940413e5be2a462579f4ccb2d704492c7de614164b114dcab071e400a1ab8c8f13574d3802a2bbcc9e2c1f9
DIST TaskCoach-1.4.2.tar.gz 2905614 SHA256 2f9a70f6abab688704ea0536f0eacbbb599a1cadda84f10d7dc5de07f711e34f SHA512 0f2465b45771cd211c21949265b758aa097cc76143a09f3c1d81cf15b1381fc6549f71839cb27563a1ab04369b8c925ca06275c799871f880005af2f907f9357 WHIRLPOOL 640ddeb357fc67e1321370c57184fd4e684715b8ddc60f7ffdb08441a0555855b3ca40775fcbcf568ca63acfa9ef2bfb2d23bc9edc50bea08a3c012abe72a03a
23 changes: 23 additions & 0 deletions app-office/taskcoach/files/taskcoach-1.4.2-fix-desktop-file.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
From dd39524692896995daabc69c7090ecf66e64858e Mon Sep 17 00:00:00 2001
From: Sebastian Pipping <[email protected]>
Date: Sun, 10 Jan 2016 01:34:13 +0100
Subject: [PATCH] Fix .desktop file

error: value "task;todo;reminder" for locale string list key "Keywords" in group "Desktop Entry" does not have a semicolon (';') as trailing character
---
build.in/linux_common/taskcoach.desktop | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/build.in/linux_common/taskcoach.desktop b/build.in/linux_common/taskcoach.desktop
index 9382b0b..b1a4bd1 100644
--- a/build.in/linux_common/taskcoach.desktop
+++ b/build.in/linux_common/taskcoach.desktop
@@ -7,4 +7,4 @@ Icon=taskcoach
Terminal=false
Type=Application
Categories=Office;Calendar;
-Keywords=task;todo;reminder
+Keywords=task;todo;reminder;
--
2.7.0

50 changes: 50 additions & 0 deletions app-office/taskcoach/taskcoach-1.4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )

inherit distutils-r1 eutils versionator

MY_PN="TaskCoach"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="Simple personal tasks and todo lists manager"
HOMEPAGE="http://www.taskcoach.org https://pypi.python.org/pypi/TaskCoach"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="libnotify"
DEPEND="|| (
>=dev-python/wxpython-2.8.9.2:2.8[${PYTHON_USEDEP}]
dev-python/wxpython:3.0[${PYTHON_USEDEP}]
)
>=dev-python/twisted-core-10.0"
RDEPEND="${DEPEND}
libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )"

S="${WORKDIR}/${MY_P}"

DOCS=( CHANGES.txt README.txt )

src_prepare() {
epatch "${FILESDIR}"/${P}-fix-desktop-file.patch
}

python_install_all() {
distutils-r1_python_install_all

doicon "icons.in/${PN}.png"
make_desktop_entry ${PN}.py "Task Coach" ${PN} Office
}

pkg_postinst() {
if [[ -n ${REPLACING_VERSIONS} ]]; then
if ! version_is_at_least 1.3.40 ${REPLACING_VERSIONS}; then
elog "Since version 1.3.40, the Task Coach executable is called ${PN}.py"
fi
fi
}

0 comments on commit bafda41

Please sign in to comment.