Skip to content

Commit

Permalink
media-libs/vulkan-loader: Bump to 1.2.182
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Nick Sarnie <[email protected]>
  • Loading branch information
sarnex committed Jul 4, 2021
1 parent b1d0bbe commit bb05b66
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/vulkan-loader/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST vulkan-loader-1.2.162.tar.gz 1421710 BLAKE2B 94b739821c5a12a94a52d8f0a9d79c13055ef3b45b907d53b82325b7be13db52b77d01397534e939bed5629d7a405ff8a09f8da374274a066986b4126fae9863 SHA512 89a99f282b73ec59dde30e4c8c09056b40416185a14ff9b7f7bd496754840e5ac764e7624f1f9a0f11792e786b00f19c3c9e55ccbb22a3c501d8ea9e815d84f9
DIST vulkan-loader-1.2.170.tar.gz 1422110 BLAKE2B 8903fceee3172970ee4e9c41df7c9ceb3c4d21d380061c9442cf6c3c07412e5568f7d4653591bf53128088b928d7db8050782e9a90441b66e12ba12135e5c242 SHA512 b9512c8b30b68799a6cc2905e7a5593a1c03214edae7a99fd7bc27b1761f17ef70a61f422fc318dd805ac089bbfc6cf18dfe69d1b8a91789a1774ee396058747
DIST vulkan-loader-1.2.179.tar.gz 1430935 BLAKE2B b12fbbac071560ca0542c26cb72379104fdca1973306bf0ed0c1566a4bbc9daf22817f0e8e8389104072188705c8bf3dd6283fcfd396defe2834d2e1565e6be0 SHA512 3186f5d8f93b28a69e731da505ce4e8cd768c8935eda9e6765b834aaa137d249b5cb4c7d0fb1e1e713c3d02b3c9a71ad8554e2ea239dbd5e4def2b96331cd71d
DIST vulkan-loader-1.2.182.tar.gz 1469024 BLAKE2B d180154bd0878c45327b1ad06a8efcc637b73fd75ad5ca349740d7f8d6944b2974828cb055a32150c4db4eb94f1b420d94852228d91e46bd8340229fa0ad30fd SHA512 06cf308caae1fd1992b279e8130b8f40bdcc7df44294c73e221d537950c689e552afeda4ae9406645b1d773693fa27c7727ab012daecbcff2793c4995c7f0db0
65 changes: 65 additions & 0 deletions media-libs/vulkan-loader/vulkan-loader-1.2.182.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_PN=Vulkan-Loader
CMAKE_ECLASS="cmake"
inherit flag-o-matic cmake-multilib toolchain-funcs

if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
EGIT_SUBMODULES=()
inherit git-r3
else
SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv"
S="${WORKDIR}"/${MY_PN}-${PV}
fi

DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Loader"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="layers wayland X"

BDEPEND=">=dev-util/cmake-3.10.2"
DEPEND="
~dev-util/vulkan-headers-${PV}
wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
X? (
x11-libs/libX11:=[${MULTILIB_USEDEP}]
x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
)
"
PDEPEND="layers? ( media-libs/vulkan-layers:=[${MULTILIB_USEDEP}] )"

multilib_src_configure() {
# Integrated clang assembler doesn't work with x86 - Bug #698164
if tc-is-clang && [[ ${ABI} == x86 ]]; then
append-cflags -fno-integrated-as
fi

local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
-DBUILD_TESTS=OFF
-DBUILD_LOADER=ON
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
-DVULKAN_HEADERS_INSTALL_DIR="${ESYSROOT}/usr"
)
cmake_src_configure
}

multilib_src_install() {
keepdir /etc/vulkan/icd.d

cmake_src_install
}

pkg_postinst() {
einfo "USE=demos has been dropped as per upstream packaging"
einfo "vulkaninfo is now available in the dev-util/vulkan-tools package"
}

0 comments on commit bb05b66

Please sign in to comment.