forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-db/percona-server: Version bump; drop hppa keyword
hppa dropped due to unsatisfied dependency of dev-util/valgrind Package-Manager: portage-2.2.20.1
- Loading branch information
Brian Evans
committed
Sep 17, 2015
1 parent
6fd72a7
commit bb1639a
Showing
3 changed files
with
169 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST mysql-extras-20150113-1853Z.tar.bz2 1494439 SHA256 420553dc8557d0622ad762ee6924900acc74fd4f367fd3840acab03114fada4d SHA512 b1252d905b71a6f42484eaa796ebcd2f0769affc566e6c277ef3bc0ef9bc446a1c22aac3faa48ef7b9305056a1302b37d7ef86b547c44514528a5956ce61d372 WHIRLPOOL d14f0d88358eb0bbd2c338052ec086ab8260988497ef09da934365ded3c30c7e905ea936a0c9817ccb49d1f6e3408b3f6a438455a2455c65c2f26a9fc6367ff3 | ||
DIST mysql-extras-20150717-1707Z.tar.bz2 1491956 SHA256 d67cc1e2c581ab7c57122b7d29864643869799893a95a158a18e14201d4ffc10 SHA512 3a7cb07773099e766f8e796d4e555d42874b85285cc2c7c60220370cc6aafc36a60eb340008637298d85d83f529e73392895a81c1438ffccff9eb8f354b29ba9 WHIRLPOOL 11e75f4b696e2547c1da40e69d8ab75df4bf7080426204c040632f24846407b07d71061c09c4ff4a1d21a9d14a94769d8f8ef62421d0aecd99efe832caf4dd22 | ||
DIST percona-server-5.6.25-73.0.tar.gz 34152178 SHA256 790d056931b9dd5b158a732812490fdaf9407012aaf93d3f1c1b21942dcdc251 SHA512 9bb4ee29ceb7e80460d2ffa779ca0aefaa6c0af1c4e5309c1c5f37840da4e85da1196a936e1862bacb3f36d064a6dcb6ad45b3eb55f60b033f2741ec6b487b9d WHIRLPOOL 76c59da78fda5cf70802117e59ceb0a877513ed83b0069c6d5a3f169595eac43516897bc02c092caa71cb059424ed3d4cbb97133c6946f870ab7734e8ca7a282 | ||
DIST percona-server-5.6.26-74.0.tar.gz 54819177 SHA256 9156038d84bd1190a5b5df963877876584d30bd515ba3ad39e65a532430c1608 SHA512 1874b5e5d40da3ba6a9ea5bf15b7b851b4c067edf3cbca4139c078536000010acaecb8ee94933f5c4482ea091967a30f042b3bd08bef5e3716cae0be8607410e WHIRLPOOL fd8d712d3ed1a785ad455d9d83f537303ad9b58d0562cf73adaba71527ab42513e0682b568aced5601b419e738f9d904d09bb37f387feaa42944795461e96b8e |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
166 changes: 166 additions & 0 deletions
166
dev-db/percona-server/percona-server-5.6.26.74.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,166 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
MY_EXTRAS_VER="20150717-1707Z" | ||
HAS_TOOLS_PATCH="1" | ||
SUBSLOT="18" | ||
|
||
inherit toolchain-funcs mysql-multilib | ||
# only to make repoman happy. it is really set in the eclass | ||
IUSE="$IUSE tokudb tokudb-backup-plugin" | ||
|
||
# REMEMBER: also update eclass/mysql*.eclass before committing! | ||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-linux" | ||
|
||
# When MY_EXTRAS is bumped, the index should be revised to exclude these. | ||
EPATCH_EXCLUDE='' | ||
|
||
DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 ) | ||
tokudb? ( app-arch/snappy ) | ||
tokudb-backup-plugin? ( dev-util/valgrind )" | ||
RDEPEND="${RDEPEND}" | ||
|
||
REQUIRED_USE="tokudb? ( jemalloc ) tokudb-backup-plugin? ( tokudb )" | ||
|
||
# Please do not add a naive src_unpack to this ebuild | ||
# If you want to add a single patch, copy the ebuild to an overlay | ||
# and create your own mysql-extras tarball, looking at 000_index.txt | ||
|
||
# Official test instructions: | ||
# USE='extraengine perl ssl static-libs community' \ | ||
# FEATURES='test userpriv -usersandbox' \ | ||
# ebuild percona-server-X.X.XX.ebuild \ | ||
# digest clean package | ||
multilib_src_test() { | ||
|
||
if ! multilib_is_native_abi ; then | ||
einfo "Server tests not available on non-native abi". | ||
return 0; | ||
fi | ||
|
||
local TESTDIR="${CMAKE_BUILD_DIR}/mysql-test" | ||
local retstatus_unit | ||
local retstatus_tests | ||
|
||
# Bug #213475 - MySQL _will_ object strenously if your machine is named | ||
# localhost. Also causes weird failures. | ||
[[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost" | ||
|
||
if use server ; then | ||
|
||
if [[ $UID -eq 0 ]]; then | ||
die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root." | ||
fi | ||
has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox" | ||
|
||
einfo ">>> Test phase [test]: ${CATEGORY}/${PF}" | ||
addpredict /this-dir-does-not-exist/t9.MYI | ||
|
||
# Run CTest (test-units) | ||
cmake-utils_src_test | ||
retstatus_unit=$? | ||
[[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed" | ||
|
||
# Ensure that parallel runs don't die | ||
export MTR_BUILD_THREAD="$((${RANDOM} % 100))" | ||
# Enable parallel testing, auto will try to detect number of cores | ||
# You may set this by hand. | ||
# The default maximum is 8 unless MTR_MAX_PARALLEL is increased | ||
export MTR_PARALLEL="${MTR_PARALLEL:-auto}" | ||
|
||
# create directories because mysqladmin might right out of order | ||
mkdir -p "${T}"/var-tests{,/log} | ||
|
||
# Create a symlink to provided binaries so the tests can find them when client-libs is off | ||
if ! use client-libs ; then | ||
ln -srf /usr/bin/my_print_defaults "${BUILD_DIR}/client/my_print_defaults" || die | ||
ln -srf /usr/bin/perror "${BUILD_DIR}/client/perror" || die | ||
mysql-multilib_disable_test main.perror "String mismatch due to not building local perror" | ||
fi | ||
|
||
# These are failing in Percona 5.6 for now and are believed to be | ||
# false positives: | ||
# | ||
# main.information_schema, binlog.binlog_statement_insert_delayed, | ||
# main.mysqld--help-notwin, binlog.binlog_mysqlbinlog_filter | ||
# perfschema.binlog_edge_mix, perfschema.binlog_edge_stmt | ||
# funcs_1.is_columns_mysql funcs_1.is_tables_mysql funcs_1.is_triggers | ||
# engines/funcs.db_alter_character_set engines/funcs.db_alter_character_set_collate | ||
# engines/funcs.db_alter_collate_ascii engines/funcs.db_alter_collate_utf8 | ||
# engines/funcs.db_create_character_set engines/funcs.db_create_character_set_collate | ||
# fails due to USE=-latin1 / utf8 default | ||
# | ||
# main.mysql_client_test: | ||
# segfaults at random under Portage only, suspect resource limits. | ||
# | ||
# main.percona_bug1289599 | ||
# Looks to be a syntax error in the test file itself | ||
# | ||
# main.variables main.myisam main.merge_recover | ||
# fails due to ulimit not able to open enough files (needs 5000) | ||
# | ||
# main.mysqlhotcopy_archive main.mysqlhotcopy_myisam | ||
# Called with bad parameters should be reported upstream | ||
# | ||
# innodb_stress.innodb_stress | ||
# innodb_stress.innodb_stress_blob innodb_stress.innodb_stress_blob_nocompress | ||
# innodb_stress.innodb_stress_crash innodb_stress.innodb_stress_crash_blob | ||
# innodb_stress.innodb_stress_crash_blob_nocompress innodb_stress.innodb_stress_crash_nocompress | ||
# innodb_stress.innodb_stress_nocompress | ||
# Dependent on python2 being the system python | ||
|
||
for t in main.mysql_client_test \ | ||
binlog.binlog_statement_insert_delayed main.information_schema \ | ||
main.mysqld--help-notwin binlog.binlog_mysqlbinlog_filter \ | ||
perfschema.binlog_edge_mix perfschema.binlog_edge_stmt \ | ||
funcs_1.is_columns_mysql funcs_1.is_tables_mysql funcs_1.is_triggers \ | ||
main.variables main.myisam main.merge_recover \ | ||
engines/funcs.db_alter_character_set engines/funcs.db_alter_character_set_collate \ | ||
engines/funcs.db_alter_collate_ascii engines/funcs.db_alter_collate_utf8 \ | ||
engines/funcs.db_create_character_set engines/funcs.db_create_character_set_collate \ | ||
main.percona_bug1289599 main.mysqlhotcopy_archive main.mysqlhotcopy_myisam ; do | ||
mysql-multilib_disable_test "$t" "False positives in Gentoo" | ||
done | ||
|
||
for t in innodb_stress.innodb_stress \ | ||
innodb_stress.innodb_stress_blob innodb_stress.innodb_stress_blob_nocompress \ | ||
innodb_stress.innodb_stress_crash innodb_stress.innodb_stress_crash_blob \ | ||
innodb_stress.innodb_stress_crash_blob_nocompress innodb_stress.innodb_stress_crash_nocompress \ | ||
innodb_stress.innodb_stress_nocompress ; do | ||
mysql-multilib_disable_test "$t" "False positives due to python exception syntax" | ||
done | ||
|
||
# Run mysql tests | ||
pushd "${TESTDIR}" | ||
|
||
# Set file limits higher so tests run | ||
ulimit -n 3000 | ||
|
||
# run mysql-test tests | ||
perl mysql-test-run.pl --force --vardir="${T}/var-tests" \ | ||
--testcase-timeout=30 --reorder | ||
retstatus_tests=$? | ||
[[ $retstatus_tests -eq 0 ]] || eerror "tests failed" | ||
has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox" | ||
|
||
popd | ||
|
||
# Cleanup is important for these testcases. | ||
pkill -9 -f "${S}/ndb" 2>/dev/null | ||
pkill -9 -f "${S}/sql" 2>/dev/null | ||
|
||
failures="" | ||
[[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit" | ||
[[ $retstatus_tests -eq 0 ]] || failures="${failures} tests" | ||
has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox" | ||
|
||
[[ -z "$failures" ]] || die "Test failures: $failures" | ||
einfo "Tests successfully completed" | ||
|
||
else | ||
|
||
einfo "Skipping server tests due to minimal build." | ||
fi | ||
} |