Skip to content

Commit

Permalink
app-backup/btrbk: 0.29.0 version bump
Browse files Browse the repository at this point in the history
Drop dependency on sys-apps/pv
Add dependency on sys-block/mbuffer

See: https://github.com/digint/btrbk/releases/tag/v0.29.0
Closes: https://bugs.gentoo.org/673250
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Oct 27, 2019
1 parent 300085c commit bb2a8bb
Show file tree
Hide file tree
Showing 3 changed files with 80 additions and 2 deletions.
1 change: 1 addition & 0 deletions app-backup/btrbk/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -9,3 +9,4 @@ DIST btrbk-0.28.0.tar.xz 99336 BLAKE2B 4becaac5a34029e57345baa3c8bb787032ddfdc52
DIST btrbk-0.28.1.tar.xz 94740 BLAKE2B 75313aabab7208083e06a2d4bb607950c7d5d0e87188a9a8f8c97cba1549cc2d3bcfff14b2bc2d20898c44bcc0fe50d74db2e16b213dde852d89704704b70ece SHA512 0e24908b3162b2ab67e0482a38fb966bf33b3c3ee5b2f62259673af14e9309bc4707bd049403579240ec416efae6643a8b5da73f4763e3dc01b3893047e92581
DIST btrbk-0.28.2.tar.xz 94888 BLAKE2B 4501a8bbe1c88e2449c67d3c5e2322c8b3d3bd5b855cbc0451ff59a3e9aea66de4110587f786fee8f21acfb8a7e496f80a21a91a0e0756d37130bd49a76bb26f SHA512 43e9e0dfe48b0b0c8d1b64e2ce447b9dde9c494b2ad233d68e6ad0648d746d1e950751199f72affe77e06b0c94567912b399bd0b6aa8ebc31dd8fb87ef9ae0ae
DIST btrbk-0.28.3.tar.xz 95000 BLAKE2B 95de0eae8621b313e9dce3a90ba416a0e4553b05e7e9e1432bd740941ea4b7bdc154a6dd34c9cf7b7ef9fb98f46fd4bc99a3b37933b4c9bd21ef493a7f51e2a5 SHA512 a2919527ab14486113c075fdb2646ee70fa20c813e5a69fc8a0cd16b75bc7aaccee338b272da938f6223a4be8c2d539839426b55ce72d338c7cf20680a41a849
DIST btrbk-0.29.0.tar.xz 97632 BLAKE2B dc7b63804a2a4ff99ae33e2247363402cfa683bad852c1b70bbb8fc3571730a690589cff1184a3c6e63b66b385430027b55da959e7dca96b7eca6eff900be109 SHA512 e3b0fd45bcaafa4fe53e230bb66cc23ae950dd91251d5e4d19a576021f2dcc52b219cd348b1b747224c2da803b47554266f4fc91c092a62decedc74ac59b9b28
77 changes: 77 additions & 0 deletions app-backup/btrbk/btrbk-0.29.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit systemd

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/digint/btrbk.git"
inherit git-r3
SRC_URI=""
KEYWORDS=""
else
SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
HOMEPAGE="https://digint.ch/btrbk/"
LICENSE="GPL-3+"
SLOT="0"
IUSE="+doc"

DEPEND="doc? ( >=dev-ruby/asciidoctor-1.5.7 )"

RDEPEND="dev-lang/perl
net-misc/openssh
>=sys-block/mbuffer-20180505
>=sys-fs/btrfs-progs-4.12"

src_compile() {
emake clean
use doc && emake -C doc
}
src_install() {
local targets="install-bin install-etc install-share install-systemd"
use doc && targets="${targets} install-man install-doc"
emake \
DESTDIR="${D}" \
DOCDIR="/usr/share/doc/${PF}" \
SYSTEMDDIR="$(systemd_get_systemunitdir)" \
${targets}
}
pkg_preinst() {
if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
upgrade_0_26_0_warning="1"
fi
if has_version "<${CATEGORY}/${PN}-0.27.0" ; then
upgrade_0_27_0_warning="1"
fi
}
pkg_postinst() {
if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
ewarn "If you are using raw targets, make sure to run the"
ewarn "\"raw_suffix2sidecar\" utility in each target directory."
fi
if [[ "${upgrade_0_27_0_warning}" == "1" ]]; then
ewarn 'Due to a bugfix in the scheduler [1] [2], previously preserved'
ewarn 'monthly/yearly backups could get deleted when upgrading to'
ewarn 'btrbk-0.27.0.'
ewarn ''
ewarn 'Before upgrading to btrbk-0.27.0, make sure to stop all cron jobs'
ewarn 'or systemd timers calling btrbk.'
ewarn ''
ewarn 'After upgrading, run "btrbk prune --dry-run --print-schedule" and'
ewarn 'check if any snapshots/backups would get deleted. If you want to'
ewarn 'forcibly preserve a snapshot/backup forever, rename it:'
ewarn ''
ewarn ' mv mysubvol.YYYYMMDD mysubvol.YYYYMMDD.keep_forever'
ewarn ''
ewarn 'Note that btrbk ignores subvolumes with unknown naming scheme, e.g.'
ewarn '(".keep_forever" suffix in the example above).'
ewarn ''
ewarn ' [1] https://github.com/digint/btrbk/issues/217'
ewarn ' [2] https://github.com/digint/btrbk/commit/719fb5f'
fi
}
4 changes: 2 additions & 2 deletions app-backup/btrbk/btrbk-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -19,13 +19,13 @@ DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
HOMEPAGE="https://digint.ch/btrbk/"
LICENSE="GPL-3+"
SLOT="0"
IUSE="+pv +doc"
IUSE="+doc"

DEPEND="doc? ( >=dev-ruby/asciidoctor-1.5.7 )"

RDEPEND="dev-lang/perl
net-misc/openssh
pv? ( sys-apps/pv )
>=sys-block/mbuffer-20180505
>=sys-fs/btrfs-progs-4.12"

src_compile() {
Expand Down

0 comments on commit bb2a8bb

Please sign in to comment.