Skip to content

Commit

Permalink
net-libs/libyahoo2: bump EAPI; drop eutils; add LibreSSL support
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
FuzzyGophers committed May 30, 2018
1 parent 4990dd9 commit bb55109
Show file tree
Hide file tree
Showing 2 changed files with 19 additions and 12 deletions.
4 changes: 2 additions & 2 deletions net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/Makefile.am
+++ src/Makefile.am
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,11 +21,9 @@
noinst_PROGRAMS = yahoo autoresponder

Expand Down
27 changes: 17 additions & 10 deletions net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=2
inherit autotools eutils
EAPI=7
inherit autotools

DESCRIPTION="interface to the new Yahoo! Messenger protocol"
HOMEPAGE="http://libyahoo2.sourceforge.net/"
Expand All @@ -11,33 +11,40 @@ SRC_URI="mirror://sourceforge/libyahoo2/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="static-libs ssl"
IUSE="libressl ssl static-libs"

RDEPEND="dev-libs/glib:2
ssl? ( dev-libs/openssl )"
ssl? (
libressl? ( dev-libs/libressl:0= )
!libressl? ( dev-libs/openssl:0= )
)
"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}/${P}-asneeded.patch"
)

src_prepare() {
epatch "${FILESDIR}"/${P}-asneeded.patch
default
sed -i -e 's:-ansi -pedantic::' configure.ac || die #240912
eautoreconf
}

src_configure() {
econf \
--disable-dependency-tracking \
$(use_enable static-libs static) \
$(use_enable ssl sample-client)
}

src_install() {
emake DESTDIR="${D}" install || die
default

if use ssl; then
dobin src/.libs/{autoresponder,yahoo} || die
dobin src/.libs/{autoresponder,yahoo}
fi

dodoc AUTHORS ChangeLog doc/*.txt NEWS README TODO

find "${D}" -name '*.la' -exec rm -f '{}' +
find "${D}" -name '*.la' -delete || die "Pruning failed"
}

0 comments on commit bb55109

Please sign in to comment.