Skip to content

Commit

Permalink
dev-qt/qtwayland: add 6.6.0
Browse files Browse the repository at this point in the history
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Oct 10, 2023
1 parent 5ba6508 commit bb5e375
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-qt/qtwayland/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST qtwayland-everywhere-opensource-src-5.15.10.tar.xz 568552 BLAKE2B c5cd4ed5f
DIST qtwayland-everywhere-opensource-src-5.15.11.tar.xz 569072 BLAKE2B 83b96ac4eb220aa924539a67b28bb20eff97256203f0c36efb0687b9266a2d0f3c69cec6648870e27431120bc1bd0eecf14dcc4f118e3d77ed78c1eb66298329 SHA512 b47a3358bc37f52dde0839940431e8049abfaa827722e6d57362b07547c35fe9fb422d28fd28c69a13f5773c24efc3eeea1e584372737a0151ed94bf4c5b9980
DIST qtwayland-everywhere-src-6.5.2.tar.xz 1059356 BLAKE2B 4708b78ff5c8e413edaa4d4400317f58dd068273a5eef7caf1500abf8afbe4e9ac405b6854691ef93265a7eeb0cfb7406024826a0b7c7ba3f8149218af67fd48 SHA512 520d109402f1d629481029a3b1eaab740e66135db4069c34651172bb2ad821b22de60e9956a96331d2f32a4522fc52c6a4ba99b474092d755760cad08c776477
DIST qtwayland-everywhere-src-6.5.3.tar.xz 1059396 BLAKE2B f3b495e712a3eae53b0fe9abc4430414868fe8668468cadc844672b11597c348b0daa82a602f7e5d15f1ec67f5336d0d50466a64ca0d0a571401681ae02137d6 SHA512 e516dd5158ed1aadc989b3f1bbaad87fa38b59872b44c7c92ec1c349e7e923a6b07b7fb3a3493312330eaf581b0d27aeaad2ec03629523ee28e3627b7c30ea89
DIST qtwayland-everywhere-src-6.6.0.tar.xz 1125748 BLAKE2B e1024866761b1872ed762ef565cc4805e0dcea5a3319ec6d4aaf4d9e46477a0a4f1aea7b39faeb88ab10afa6b2fb5e0dd22a7864a3d18b479c87e345b34c7153 SHA512 e9cf63ccc71d4dc61b04a0f8a1a466e9ede09aa689c53c1ccc9db5233e324894bfd198c9204d8d93509c770a7a6612c8eb9981e0b3ee7428f8bf2dcbdc255109
47 changes: 47 additions & 0 deletions dev-qt/qtwayland/qtwayland-6.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit qt6-build

DESCRIPTION="Wayland platform plugin for Qt"

if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
fi

IUSE="compositor qml vulkan"

RDEPEND="
dev-libs/wayland
~dev-qt/qtbase-${PV}:6[gui,opengl,vulkan=]
media-libs/libglvnd
x11-libs/libxkbcommon
compositor? (
qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
)
"
DEPEND="
${RDEPEND}
vulkan? ( dev-util/vulkan-headers )
"
BDEPEND="dev-util/wayland-scanner"

CMAKE_SKIP_TESTS=(
# segfaults for not-looked-into reasons, but not considered
# an issue given >=seatv5 exists since wayland-1.10 (2016)
tst_seatv4
# needs a compositor/opengl, skip the extra trouble
tst_surface
tst_xdgdecorationv1
)

src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Quick)
$(qt_feature compositor wayland_server)
)

qt6-build_src_configure
}

0 comments on commit bb5e375

Please sign in to comment.