Skip to content

Commit

Permalink
dev-php/pecl-mailparse: Version bump, cleaning dependencies
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Brian Evans committed Dec 19, 2016
1 parent 52faa1c commit bb87221
Show file tree
Hide file tree
Showing 3 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-mailparse/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mailparse-2.1.6.tgz 36538 SHA256 73705197d2b2ee782efa5477eb2a21432f592c2cb05a72c3a037bbe39e02b5cc SHA512 a7337dd2e99a953a55b38c236da95a6bd2950c2bca16fc0ddfec39be8b0ffe01007353fc7b562d0509e0bb1623c3d2b03935d1c98a07dcd9f0b14bb508bce374 WHIRLPOOL 238f209a45d83eb9b91cf34f1398ff85c538e8273f73791d4736b15e21de3d48395fd0b838e927cd9dd247bff265782c3e96c87b1d90e73bffc1e6b04beea1ba
DIST mailparse-3.0.1.tgz 38226 SHA256 42ee10de881a3739acf73ddef8800d80c3c57f70072f41bdb22e6e87ebc9cc62 SHA512 42318d145c49644b0a1aea0e18aa3c6899f8ee2a8def7b9c22f7c02737426de22aba00a4c899a269b1d8e64c190654413d857622c882b92caa07f201620f1e61 WHIRLPOOL 0f451f7059e983cc95b87672da07c241be94393b504d44a3faf096be10de4d270191a20591ce2e7fa12ad5572424064a6f10480a769ec5f0b4e09f4638c294dd
DIST mailparse-3.0.2.tgz 38206 SHA256 d81a6f8a48e43fca1c0f0d6c90d666830c24d584a23a60add43062aaf221843b SHA512 be04e15cf3577542447186d7ead4e31159c171c99de0a255d4ee2f6f760b80ecb44be056bd9089180601f622b9a71f4331f194e1adaa702d1d964009682896f6 WHIRLPOOL d93cedfa38d5c746e680edcdcac2c6e8baf5f223b01c1868b1a8f9390ef1b3ebe50802c50e338b45528d68a4342c4b7020236e90cb397a97479b70cdf3f99e20
43 changes: 43 additions & 0 deletions dev-php/pecl-mailparse/pecl-mailparse-2.1.6-r4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PHP_EXT_NAME="mailparse"
PHP_EXT_ECONF_ARGS=""
DOCS=( README )

USE_PHP="php5-6 php7-0 php7-1"

inherit php-ext-pecl-r3

USE_PHP="php5-6"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"

DESCRIPTION="PHP extension for parsing RFC822 and RFC2045 (MIME) messages"
LICENSE="PHP-2.02"
SLOT="0"
IUSE=""

RDEPEND="php_targets_php5-6? ( dev-lang/php:5.6[unicode] )"
DEPEND="${RDEPEND}
dev-util/re2c"
PDEPEND="
php_targets_php7-0? ( dev-php/pecl-mailparse:7[php_targets_php7-0] )
php_targets_php7-1? ( dev-php/pecl-mailparse:7[php_targets_php7-1] )
"

src_prepare() {
if use php_targets_php5-6 ; then
php-ext-source-r3_src_prepare
else
eapply_user
fi
}

src_install() {
if use php_targets_php5-6 ; then
php-ext-pecl-r3_src_install
fi
}
51 changes: 51 additions & 0 deletions dev-php/pecl-mailparse/pecl-mailparse-3.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PHP_EXT_NAME="mailparse"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_EXT_ECONF_ARGS=""
DOCS=( README )

USE_PHP="php7-0 php7-1 php5-6"

inherit php-ext-pecl-r3

# Only build for 7.x
USE_PHP="php7-0 php7-1"

KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"

DESCRIPTION="PHP extension for parsing and working with RFC822 and MIME compliant messages"
LICENSE="PHP-3.01"
SLOT="7"
IUSE=""

for target in ${USE_PHP}; do
phpslot=${target/php}
phpslot=${phpslot/-/.}
PHPUSEDEPEND="${PHPUSEDEPEND}
php_targets_${target}? ( dev-lang/php:${phpslot}[unicode] )"
done
unset target phpslot

DEPEND="${PHPUSEDEPEND}
dev-util/re2c"
RDEPEND="${PHPUSEDEPEND} php_targets_php5-6? ( dev-php/pecl-mailparse:0[php_targets_php5-6] )"

src_prepare() {
if use php_targets_php7-0 || use php_targets_php7-1 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
fi
}

src_install() {
if use php_targets_php7-0 || use php_targets_php7-1 ; then
php-ext-pecl-r3_src_install
fi
}

0 comments on commit bb87221

Please sign in to comment.