Skip to content

Commit

Permalink
net-fs/samba: Bump to version 4.3.4
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jan 12, 2016
1 parent 2ef3e2a commit bba0e26
Show file tree
Hide file tree
Showing 2 changed files with 233 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-fs/samba/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,4 +3,5 @@ DIST samba-3.5.22.tar.gz 35385144 SHA256 b4c98f77f5634478da109063334acd9b6ad7bcb
DIST samba-3.6.25.tar.gz 34121828 SHA256 8f2c8a7f2bd89b0dfd228ed917815852f7c625b2bc0936304ac3ed63aaf83751 SHA512 25a5c56dae4517e82e196b59fa301b661ec75db57effbb0ede35fb23b018f78cdea6513e8760966caf58abc43335fcebda77fe5bf5bb9d4b27fd3ca6e5a3b626 WHIRLPOOL 68c4a335b3912bf3c6baecae337b1131127515191052366ca9a04ec6d919f2fb69c912aefb087e2578134f3a9bde7b496ea880f2197a8dbf8221058dd1e8444d
DIST samba-4.2.7.tar.gz 20741971 SHA256 f586ab3166ce4c663360f15b1de24ef083816a5471856e3ad49bc26b35f0104a SHA512 74314083c04689696f0423bc990947bfafad679edcac97e6c137e99c17de1e262a4d8450b57de733a70c86c746300c7c5a1365b56c0e353ce79b05e0baf8eb9a WHIRLPOOL 84e7d2f3a60701ee929198caf86371c9e1694be6def47a4f0f12d4d221b995209505c23564c304fbdd95ab5ae528f941946bd361ec6e388f7ba4db08792ff3ba
DIST samba-4.3.3.tar.gz 20427281 SHA256 e62d21313acbb29e24b0b80aaf2b63fdd1ccce4cfb741f333deca95a1a3a70df SHA512 2c66d97f543e22a25ff77481359e7c69817d97c20b77a3ab02a1aab415e0b8a9a6024f4466abcca8312979f9b26596e016ca5bb78ccfe3746e3e9cec0fa303be WHIRLPOOL dae3cbe3aebd0aa70a726b4946470829b703f30c0aaf59f9ae094e7f4dfa25b0573e6c49690d91308f3dddc25cf6fbf0b1341da33446dc4ee29a115db48f9604
DIST samba-4.3.4.tar.gz 20434434 SHA256 5d0eb52e842832af922f7d57716eacff23192906ec3bdf6727e18ca24f1419d9 SHA512 021351534a70cd351934d7f8bfc3c4e9ed9ea3f11f778f6f9d076b3368103f7f478ff1745cb257de0bf2ee38ae76ecba58e01a4db6cbcacbd8a4876e8e1b30f2 WHIRLPOOL 328721951ed932c5813d6157ca2933e22adb793d5cd6667577e40151bcdae8dcddf5ca4e053cd6494e0f82f5801ae480716520c625dd9c337557abc168e00dec
DIST smb_traffic_analyzer_v2.diff.bz2 12226 SHA256 1bae7eafbe8ac2382313d5ab9d43d73ba64b63a714f0f588516952d476fb868d SHA512 aa0e457a0dd282e61e6dfcd5705c29b319832dca9711b1b5baf8373e2f079991399c3537c050219ccb861a93f86353ebff677a5c625d2e3f1f3a13ee5c4087d0 WHIRLPOOL 85ee72a360f67ebe71be5cd400ecd635280a0d7c64ebb8b94656a5ef1a94f74a987de86408af00ce1b81cc8363b1b3cf14726860d29b72ee610d4bab73d6b139
232 changes: 232 additions & 0 deletions net-fs/samba/samba-4.3.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,232 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='threads(+)'

inherit python-single-r1 waf-utils multilib-minimal linux-info systemd eutils

MY_PV="${PV/_rc/rc}"
MY_P="${PN}-${MY_PV}"

SRC_PATH="stable"
[[ ${PV} = *_rc* ]] && SRC_PATH="rc"

SRC_URI="mirror://samba/${SRC_PATH}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~hppa ~x86"
[[ ${PV} = *_rc* ]] && KEYWORDS="~hppa"

DESCRIPTION="Samba Suite Version 4"
HOMEPAGE="http://www.samba.org/"
LICENSE="GPL-3"

SLOT="0"

IUSE="acl addc addns ads aio avahi client cluster cups dmapi fam gnutls iprint
ldap pam quota selinux syslog +system-mitkrb5 systemd test winbind"

MULTILIB_WRAPPED_HEADERS=(
/usr/include/samba-4.0/policy.h
)

# sys-apps/attr is an automagic dependency (see bug #489748)
CDEPEND="${PYTHON_DEPS}
>=app-arch/libarchive-3.1.2[${MULTILIB_USEDEP}]
dev-libs/libbsd[${MULTILIB_USEDEP}]
dev-libs/iniparser:0
dev-libs/popt[${MULTILIB_USEDEP}]
sys-libs/readline:=
virtual/libiconv
dev-python/subunit[${PYTHON_USEDEP}]
>=net-libs/socket_wrapper-1.1.3[${MULTILIB_USEDEP}]
sys-apps/attr[${MULTILIB_USEDEP}]
sys-libs/libcap
>=sys-libs/ldb-1.1.24[${MULTILIB_USEDEP}]
sys-libs/ncurses:0=
>=sys-libs/nss_wrapper-1.0.3[${MULTILIB_USEDEP}]
>=sys-libs/talloc-2.1.3[python,${PYTHON_USEDEP},${MULTILIB_USEDEP}]
>=sys-libs/tdb-1.3.7[python,${PYTHON_USEDEP},${MULTILIB_USEDEP}]
>=sys-libs/tevent-0.9.25[${MULTILIB_USEDEP}]
>=sys-libs/uid_wrapper-1.1.0[${MULTILIB_USEDEP}]
sys-libs/zlib[${MULTILIB_USEDEP}]
virtual/pam
acl? ( virtual/acl )
addns? ( net-dns/bind-tools[gssapi] )
aio? ( dev-libs/libaio )
cluster? ( >=dev-db/ctdb-1.0.114_p1 )
cups? ( net-print/cups )
dmapi? ( sys-apps/dmapi )
fam? ( virtual/fam )
gnutls? ( dev-libs/libgcrypt:0
>=net-libs/gnutls-1.4.0 )
ldap? ( net-nds/openldap )
system-mitkrb5? ( app-crypt/mit-krb5[${MULTILIB_USEDEP}] )
!system-mitkrb5? ( >=app-crypt/heimdal-1.5[-ssl,${MULTILIB_USEDEP}] )
systemd? ( sys-apps/systemd:0= )"
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
client? ( net-fs/cifs-utils[ads?] )
selinux? ( sec-policy/selinux-samba )
"

REQUIRED_USE="addc? ( gnutls !system-mitkrb5 )
ads? ( acl gnutls ldap )
${PYTHON_REQUIRED_USE}"

S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}/${PN}-4.2.3-heimdal_compilefix.patch"
"${FILESDIR}/${PN}-4.2.7-pam.patch"
"${FILESDIR}/${PN}-4.3.3-disable-python-for-altabi.patch"
)

CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"

WAF_BINARY="${S}/buildtools/bin/waf"

pkg_setup() {
python-single-r1_pkg_setup
if use aio ; then
if ! linux_config_exists || ! linux_chkconfig_present AIO; then
ewarn "You must enable AIO support in your kernel config, "
ewarn "to be able to support asynchronous I/O. "
ewarn "You can find it at"
ewarn
ewarn "General Support"
ewarn " Enable AIO support "
ewarn
ewarn "and recompile your kernel..."
fi
fi
}

src_prepare() {
epatch ${PATCHES[@]}
# Allow user patches
epatch_user
multilib_copy_sources
}

multilib_src_configure() {
local myconf=()
myconf=(
--enable-fhs
--sysconfdir=/etc
--localstatedir=/var
--with-modulesdir=/usr/$(get_libdir)/samba
--with-piddir=/var/run/${PN}
--bundled-libraries=NONE
--builtin-libraries=NONE
--disable-rpath
--disable-rpath-install
--nopyc
--nopyo
)
if multilib_is_native_abi ; then
myconf+=(
$(use_with acl acl-support)
$(usex addc '' '--without-ad-dc')
$(use_with addns dnsupdate)
$(use_with ads)
$(usex ads '--with-shared-modules=idmap_ad' '')
$(use_with aio aio-support)
$(usex cluster '--with-ctdb-dir=/usr' '')
$(use_enable avahi)
$(use_with cluster cluster-support)
$(use_enable cups)
$(use_with dmapi)
$(use_with fam)
$(use_enable gnutls)
$(use_enable iprint)
$(use_with ldap)
$(use_with pam)
$(use_with pam pam_smbpass)
$(usex pam "--with-pammodulesdir=/$(get_libdir)/security" '')
$(use_with quota quotas)
$(use_with syslog)
$(use_with systemd)
$(usex system-mitkrb5 '--with-system-mitkrb5' '')
$(use_with winbind)
$(usex test '--enable-selftest' '')
)
else
myconf+=(
--without-acl-support
--without-ad-dc
--without-dnsupdate
--without-ads
--without-aio-support
--disable-avahi
--without-cluster-support
--disable-cups
--without-dmapi
--without-fam
--disable-gnutls
--disable-iprint
--without-ldap
--without-pam
--without-pam_smbpass
--without-quotas
--without-syslog
--without-systemd
$(usex system-mitkrb5 '--with-system-mitkrb5' '')
--without-winbind
--disable-python
)
fi

CPPFLAGS="-I${SYSROOT}/usr/include/et ${CPPFLAGS}" \
waf-utils_src_configure ${myconf[@]}
}

multilib_src_install() {
waf-utils_src_install

# Make all .so files executable
find "${D}" -type f -name "*.so" -exec chmod +x {} +

if multilib_is_native_abi; then
# install ldap schema for server (bug #491002)
if use ldap ; then
insinto /etc/openldap/schema
doins examples/LDAP/samba.schema
fi

# install example config file
insinto /etc/samba
doins examples/smb.conf.default

# Install init script and conf.d file
newinitd "${CONFDIR}/samba4.initd-r1" samba
newconfd "${CONFDIR}/samba4.confd" samba

systemd_dotmpfilesd "${FILESDIR}"/samba.conf
systemd_dounit "${FILESDIR}"/nmbd.service
systemd_dounit "${FILESDIR}"/smbd.{service,socket}
systemd_newunit "${FILESDIR}"/smbd_at.service '[email protected]'
systemd_dounit "${FILESDIR}"/winbindd.service
systemd_dounit "${FILESDIR}"/samba.service
fi
}

multilib_src_test() {
if multilib_is_native_abi ; then
"${WAF_BINARY}" test || die "test failed"
fi
}

pkg_postinst() {
ewarn "Be aware the this release contains the best of all of Samba's"
ewarn "technology parts, both a file server (that you can reasonably expect"
ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
ewarn "controller work previously known as 'samba4'."

elog "For further information and migration steps make sure to read "
elog "http://samba.org/samba/history/${P}.html "
elog "http://samba.org/samba/history/${PN}-4.2.0.html and"
elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
}

0 comments on commit bba0e26

Please sign in to comment.