Skip to content

Commit

Permalink
games-board/pysolfc: Bump to 2.6.4, EAPI 7, fix card sets
Browse files Browse the repository at this point in the history
Thanks to Scott Furry. This now installs for a single Python version
as multiple versions do not make sense here. I've dropped Python 2 for
simplicity and because it's old.

Closes: https://bugs.gentoo.org/679362
Package-Manager: Portage-2.3.69, Repoman-2.3.13
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
chewi committed Jul 29, 2019
1 parent 380ba0d commit bbf38c3
Show file tree
Hide file tree
Showing 3 changed files with 86 additions and 0 deletions.
2 changes: 2 additions & 0 deletions games-board/pysolfc/Manifest
Original file line number Diff line number Diff line change
@@ -1,5 +1,7 @@
DIST PySolFC-2.0.tar.bz2 4208776 BLAKE2B 0675de0923c6ee381f58f8abbaef5e27bd6fc85bbee9dcd182026ba7259c25c38282623e0cd35b582e8999754d21b092d6a824499bc890a2c0c89c53679182fd SHA512 ec5a11565bd43e097cf1854fe246b8f92acd74077c0b3b158c999f9dc45966e8f805c60a2cfbd815137d970e0e6409d0ae437b9807bac9c39353657cf596b6fc
DIST PySolFC-Cardsets--Minimal-2.0.1.tar.xz 1450064 BLAKE2B 629318963ee9bf82f6ab0de03f1b59047b896f7528d0f9f5be973fb550b496b523238b9ef8fcdc034f53b5a7adc4c3b56326e912bb83fcfa7e7ad2f9dec8be6b SHA512 56c9ad3c1f9231c6f3866366d694eb6be6036b1b46c8a1ffbd6f7a243a19ab377d30ee4ccaae34f13e35727357d4168db7d9bc044562ec2d86445fb8aec84e4a
DIST PySolFC-Cardsets-2.0.tar.bz2 30687905 BLAKE2B f17f5095a05cf42ea9eb3e7a3a7fefe055cc3452882bf96db82bb4d1bebb2307ffc2d0fd8836f7414bfcd93b1d8de52adb43ef22701a0806f2c6c036d9306501 SHA512 24275cd3656024e268a49487ac75e1e67e61ec20e0a9f88e2d1c287f91314a1a9343856d1202ce468f8863f4e9a9bf27526fbb1979a7d765718b38e64ca0cfc8
DIST pysolfc-2.2.0.tar.gz 4504375 BLAKE2B ea48910d36b704667654292cd4fc2e62bcf259d9a3677369371ab7aadd387505d5ae658496ad8982e08ca0405b44971bc1e2375e91cd90f84c569f8f26249ff3 SHA512 c6d09803eab8fe7fc2c4203537d75b8db3216dfcbd5cc60be5b89f23544c871a37f7b16d20df7be4b70c6f014d47b8c361e1557ab04cb1008451f41b456d0ad2
DIST pysolfc-2.4.0.tar.gz 6788273 BLAKE2B c852ec9912aabc37317f92941fea2c0fb7230467d188ac3a0a8a78b4a4e243bfac8b3d1ddbb03dde136d7518d03cf3fb02b48386e35218ce5891b54049e9c981 SHA512 177edf60797346b763c9da9daf73feae5fb3ef88529227a60e98b68eb6120289cd0cd76b8ca5925b0452cf43298b12acbb16a53872c892d56b71cbcf0fe93e03
DIST pysolfc-2.6.2.tar.gz 6791741 BLAKE2B 473105f04bfb2fb174d3b50de5a7a55d586756a75e37eb36a9ff688a5a4b148ee940467b18fa4710f828d461d9156163c8fc9cd323b1562da18f0eb02e096916 SHA512 37b4f5f5f53c8041e7b908719456ad3c26401744389ffd44f445402d653b515c44e02ba55950e24d6a3aa2fc2bf914f8575f630335fe1b52c698154b47fb5717
DIST pysolfc-2.6.4.tar.gz 7380668 BLAKE2B d172a5d69ab2d9ca2c2c56327111b564bcdaf4800f0903051bd5a4f06e22be7ca5630f7f8b9b70b7ebfcb7ad88cc5fea2357e13a9f0bb791edb6edd42f210127 SHA512 da127a2859315eba72b6affe8210068b3b8bf16837ba106a268e0de84b908528aef1a97d5fc63cecfa89317e3bef815758e44007c50d772fb96a1f62045e5906
1 change: 1 addition & 0 deletions games-board/pysolfc/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -10,6 +10,7 @@
<flag name="sound">Enable sound support using <pkg>dev-python/pygame</pkg></flag>
</use>
<upstream>
<remote-id type="github">shlomif/PySolFC</remote-id>
<remote-id type="sourceforge">pysolfc</remote-id>
</upstream>
</pkgmetadata>
83 changes: 83 additions & 0 deletions games-board/pysolfc/pysolfc-2.6.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,83 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{5,6,7} )
DISTUTILS_SINGLE_IMPL=1
PYTHON_REQ_USE="tk"

inherit distutils-r1 desktop

MY_PN=PySolFC
CARD_BASE="${MY_PN}-Cardsets"
CARD_BASEV="${CARD_BASE}-2.0"
CARD_BASE_MINV="${CARD_BASE}--Minimal-2.0.1"
SF_CARD_BASE="mirror://sourceforge/${PN}/${CARD_BASE}"

DESCRIPTION="An exciting collection of more than 1000 solitaire card games"
HOMEPAGE="https://pysolfc.sourceforge.net/"
SRC_URI="https://github.com/shlomif/${MY_PN}/archive/${P}.tar.gz
extra-cardsets? ( ${SF_CARD_BASE}/${CARD_BASEV}/${CARD_BASEV}.tar.bz2 )
!extra-cardsets? ( ${SF_CARD_BASE}/minimal/${CARD_BASE_MINV}.tar.xz )"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="extra-cardsets minimal +sound"

S="${WORKDIR}/${MY_PN}-${P}"

RDEPEND="
dev-python/random2[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
!minimal? (
dev-python/pillow[tk,${PYTHON_USEDEP}]
dev-tcltk/tktable
)
sound? (
dev-python/pygame[${PYTHON_USEDEP}]
)"

PATCHES=(
"${FILESDIR}/${PN}-gentoo.patch" #591904
"${FILESDIR}/${PN}-locales.patch"
)

python_prepare_all() {
sed -i \
-e "/pysol.desktop/d" \
-e "s:share/icons:share/pixmaps:" \
-e "s:data_dir =.*:data_dir = \'/usr/share/${PN}\':" \
setup.py || die

distutils-r1_python_prepare_all
}

python_compile_all() {
pushd html-src > /dev/null || die "html-src not found"
PYTHONPATH=.. "${EPYTHON}" gen-html.py || die "gen-html failed"
mv images html/ || die "mv images failed"
popd > /dev/null
}

python_install_all() {
make_desktop_entry pysol.py "PySol Fan Club Edition" pysol02

if use extra-cardsets; then
insinto /usr/share/${PN}
doins -r "${WORKDIR}"/"${CARD_BASEV}"/*
else
# upstream bug #89
# repo does not contain minimal cardsets in archive
insinto /usr/share/${PN}
doins -r "${WORKDIR}"/"${CARD_BASE_MINV}"/*
fi

dosym ../doc/${PF}/html /usr/share/${PN}/html

doman docs/*.6
DOCS=( README.md AUTHORS.md docs/README docs/README.SOURCE )
HTML_DOCS=( html-src/html/. )
distutils-r1_python_install_all
}

0 comments on commit bbf38c3

Please sign in to comment.